dev-python/ansi2html: 1.2.0
authorSebastian Pipping <sping@gentoo.org>
Wed, 22 Feb 2017 22:18:11 +0000 (23:18 +0100)
committerSebastian Pipping <sping@gentoo.org>
Wed, 22 Feb 2017 22:18:26 +0000 (23:18 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

dev-python/ansi2html/Manifest
dev-python/ansi2html/ansi2html-1.2.0.ebuild [new file with mode: 0644]

index 278cf6e3461318f6915add4fc8b5aecd0b003247..938ccf1480c43f2e1424008b105a74a827f13fab 100644 (file)
@@ -1 +1,2 @@
 DIST ansi2html-1.1.1.tar.gz 46591 SHA256 5c8a482e92fd49005c083d5ed5aa946d424a71eda60be27fda005bbb5ed8c53f SHA512 5f08e6e3e89797f23759da7aac8cbd17e86ffcac37af8db8c345423c69744d88a1517cb0f17dc9c366b509b972484d25877cce8c7466a7a463eea24af17133de WHIRLPOOL 3d2555784c7077b6541df30b485af5f7f4884c40018b11c8a78afaac8c942f7f0903bf2fe442cdc75ddbb09b7be77cf58cc6a1f980617ded3b6eb68324d441d1
+DIST ansi2html-1.2.0.tar.gz 46748 SHA256 3e5d5ada557e0bbe3e204a686f959de17f76c86c20615c034767e5ebdc0740f1 SHA512 3106488da19cd093d7ae2a7499a66baf77877f47da0e497791cea2a63079c184f1d36743e78116b3faf08ab145ca97b5774151114b9ca193020578c8a3bdc860 WHIRLPOOL d19a79d21c630ccbb5ad7a66fd076c47d93d06879f493cb1e6c2e2eed5b66f8a9208c38ada9ef37159d9d27bc2915abdbdec5869b53cb8678c8316c98eedf04d
diff --git a/dev-python/ansi2html/ansi2html-1.2.0.ebuild b/dev-python/ansi2html/ansi2html-1.2.0.ebuild
new file mode 100644 (file)
index 0000000..f5e2758
--- /dev/null
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Convert text with ANSI color codes to HTML"
+HOMEPAGE="https://pypi.python.org/pypi/ansi2html https://github.com/ralphbean/ansi2html"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+
+# They miserably fail.
+RESTRICT="test"
+
+RDEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       >=dev-python/six-1.7.3[${PYTHON_USEDEP}]"
+DEPEND="
+       test? (
+               ${RDEPEND}
+               dev-python/nose[${PYTHON_USEDEP}]
+               $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7 pypy)
+       )
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       "
+
+python_test() {
+       chmod -x "${S}"/tests/* || die
+       esetup.py check
+       esetup.py test
+}
+
+python_install_all() {
+       doman man/"${PN}.1"
+       DOCS=(  README.rst man/"${PN}".1.txt )
+       distutils-r1_python_install_all
+}