media-plugins/vdr-remoteosd: patched for media-video/vdr-2.4
authorJoerg Bornkessel <hd_brummy@gentoo.org>
Wed, 25 Dec 2019 21:15:40 +0000 (22:15 +0100)
committerJoerg Bornkessel <hd_brummy@gentoo.org>
Wed, 25 Dec 2019 21:16:11 +0000 (22:16 +0100)
Package-Manager: Portage-2.3.82, Repoman-2.3.18
Signed-off-by: Joerg Bornkessel <hd_brummy@gentoo.org>
media-plugins/vdr-remoteosd/files/vdr-2.4_remoteosd-1.0.0.patch [new file with mode: 0644]
media-plugins/vdr-remoteosd/vdr-remoteosd-1.0.0-r1.ebuild [new file with mode: 0644]

diff --git a/media-plugins/vdr-remoteosd/files/vdr-2.4_remoteosd-1.0.0.patch b/media-plugins/vdr-remoteosd/files/vdr-2.4_remoteosd-1.0.0.patch
new file mode 100644 (file)
index 0000000..af6515b
--- /dev/null
@@ -0,0 +1,38 @@
+compile fix for >=vdr-2.3.1 
+suggested by MatthiasK on vdr-portal.de
+
+Signed-off-by: Joerg Bornkessel <hd_brummy@gentoo.org> ( 25 Dec 2019 )
+diff -Naur remoteosd-1.0.0.orig/menu.c remoteosd-1.0.0/menu.c
+--- remoteosd-1.0.0.orig/menu.c        2019-12-25 21:59:10.907492713 +0100
++++ remoteosd-1.0.0/menu.c     2019-12-25 22:01:09.717492713 +0100
+@@ -69,7 +69,8 @@
+       }
+       if (RemoteOsdSetup.tuneServer) {
+-              cChannel *channel = Channels.GetByNumber(cDevice::CurrentChannel());
++              LOCK_CHANNELS_READ;
++              const cChannel *channel = Channels->GetByNumber(cDevice::CurrentChannel());
+               CmdCHAN(channel);
+       }
+@@ -98,7 +99,7 @@
+       return cmd.responseCode;
+ }
+-bool cRemoteOsdMenu::CmdCHAN(cChannel *Channel) {
++bool cRemoteOsdMenu::CmdCHAN(const cChannel *Channel) {
+       SvdrpCommand_v1_0 cmd;
+       cmd.command = cString::sprintf("CHAN %s\r\n", *Channel->GetChannelID().ToString());
+       cmd.handle = svdrp.handle;
+diff -Naur remoteosd-1.0.0.orig/menu.h remoteosd-1.0.0/menu.h
+--- remoteosd-1.0.0.orig/menu.h        2019-12-25 21:59:10.906492713 +0100
++++ remoteosd-1.0.0/menu.h     2019-12-25 22:01:37.733492713 +0100
+@@ -27,7 +27,7 @@
+               bool                    isEmpty;
+               bool                    plugOsd;
+-              bool CmdCHAN(cChannel *Channel);
++              bool CmdCHAN(const cChannel *Channel);
+               bool CmdHITK(const char *Key);
+               bool CmdLSTO();
+               bool CmdOSDT();
diff --git a/media-plugins/vdr-remoteosd/vdr-remoteosd-1.0.0-r1.ebuild b/media-plugins/vdr-remoteosd/vdr-remoteosd-1.0.0-r1.ebuild
new file mode 100644 (file)
index 0000000..6df2e44
--- /dev/null
@@ -0,0 +1,18 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vdr-plugin-2
+
+DESCRIPTION="VDR Plugin: server/client remoteosd"
+HOMEPAGE="http://vdr.schmirler.de/"
+SRC_URI="http://vdr.schmirler.de/remoteosd/${P}.tgz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~arm ~x86"
+
+DEPEND=">=media-video/vdr-2.4"
+
+PATCHES=( "${FILESDIR}/vdr-2.4_remoteosd-${PV}.patch" )
\ No newline at end of file