sys-apps/irqbalance: Bump to version 1.2.0
authorLars Wendler <polynomial-c@gentoo.org>
Wed, 1 Mar 2017 17:15:12 +0000 (18:15 +0100)
committerLars Wendler <polynomial-c@gentoo.org>
Wed, 1 Mar 2017 17:20:41 +0000 (18:20 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

sys-apps/irqbalance/Manifest
sys-apps/irqbalance/files/irqbalance-1.2.0-tinfo.patch [new file with mode: 0644]
sys-apps/irqbalance/files/irqbalance.init.4 [new file with mode: 0644]
sys-apps/irqbalance/irqbalance-1.2.0.ebuild [new file with mode: 0644]

index 1bcd2b23a92ef7193492e171cb41603edab55350..f2409a80dfd23ac93a9052b724e4b7abb6b3d2e7 100644 (file)
@@ -5,3 +5,4 @@ DIST irqbalance-1.0.6.tar.gz 352325 SHA256 95ac79992e6de501f613c781b0fc8aa17a4aa
 DIST irqbalance-1.0.7.tar.gz 41209 SHA256 8c3916780d254b74fb1c7ec22876d63ac01f1b32776d9204a604b73c8f591d2a SHA512 388f982fe620d8df850e6e298a194a5ba1393f29f1b25897bfa79e34f3acb32e762b86e31154e7af614d5d84a38a61b85ff07c0dd2032e1eb6b0e30ea9010612 WHIRLPOOL fdbaa8817aae91bc1960115aa457e4dc92b36f62ba7680e9aac35459072d73f2e30015c616c86ce451ac6cd335406ac2423328232768c893e17e17537c3c951e
 DIST irqbalance-1.0.9.tar.gz 44661 SHA256 f1b8115948bb9f0bc36b9d7143ee8be751a294bc189d311408e753acc37169c3 SHA512 ef3ce9eeec11ec86291e2e3cd701e782ee1fb4ba256e2ea5ea0ea04b373f97ff2eae0a44919127c4dbd7fd805e9e3df3a5e62a3528e4d1c9bbab4db39186b5c5 WHIRLPOOL 7bed3d8dd868b4ad697b997143a59b9101815d0bfc08d1d594248c1fcfeaec22045fbe779605583a89aa7d2c8a54e079317bf8a6e4ef8135fc887e2d1518e706
 DIST irqbalance-1.1.0.tar.gz 46742 SHA256 91506e638b03bf27cf5da7dc250d58a753ce8a0288a20265fc7ff0266040706b SHA512 66abf71b87e25df190417afbf9da24d826d817de3c0ebdc686e3ae56ac131b2f9586092ba67e5f9c749cb139fbf2faaa2af2ef30700955a5b347f1964f61bf6b WHIRLPOOL 581cb27ae79648d69200ea2746cabf6dde8c865fd3afc80d87a0c43a150b40b6ad5e22ecd15fef5cc9aff166055b568e6217554c08b4767757f0534a998f35be
+DIST irqbalance-1.2.0.tar.gz 55618 SHA256 0efe5d2a0947b54d89c7196a48eca9b3b33c80bc15964e4226a0f7d3fd9535b2 SHA512 02510d0d4dc069570b5f98f3b8191384593a6ed9a88c65c87f5a4261f375c291d95c401b01c03ef9d80834925dd124a088f56ac90c5f290815e26337d4f61c1b WHIRLPOOL 32cdb9d91310012f729f45643b4d105a9840fb88fa55533d48b9a93848a6f3e7f273f9aa9957add8b5ddf4444f5d620da9accb9d79ad237126029176942a37cc
diff --git a/sys-apps/irqbalance/files/irqbalance-1.2.0-tinfo.patch b/sys-apps/irqbalance/files/irqbalance-1.2.0-tinfo.patch
new file mode 100644 (file)
index 0000000..2071654
--- /dev/null
@@ -0,0 +1,32 @@
+From 287d50594fe624bdb4400611d0dbecec6ff38a41 Mon Sep 17 00:00:00 2001
+From: Lars Wendler <polynomial-c@gentoo.org>
+Date: Wed, 1 Mar 2017 17:11:42 +0100
+Subject: [PATCH] Prefer pkgconfig to check for ncursesw.
+
+That way we take possible separate tinfo lib into account.
+---
+ configure.ac | 8 +++++++-
+ 1 file changed, 7 insertions(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index 17b879a..77d8aa4 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -26,7 +26,13 @@ AC_CHECK_FUNCS(getopt_long)
+ AC_CHECK_LIB(numa, numa_available)
+ AC_CHECK_LIB(m, floor)
+-AC_CHECK_LIB(curses, mvprintw)
++PKG_CHECK_MODULES([NCURSESW], [ncursesw], [has_ncursesw=yes], [AC_CHECK_LIB(curses, mvprintw)])
++AS_IF([test "x$has_ncursesw" = "xyes"], [
++  AC_SUBST([NCURSESW_CFLAGS])
++  AC_SUBST([NCURSESW_LIBS])
++  LIBS="$LIBS $NCURSESW_LIBS"
++  AC_SUBST([LIBS])
++])
+ AC_C_CONST
+ AC_C_INLINE
+-- 
+2.12.0
+
diff --git a/sys-apps/irqbalance/files/irqbalance.init.4 b/sys-apps/irqbalance/files/irqbalance.init.4
new file mode 100644 (file)
index 0000000..1fb9eeb
--- /dev/null
@@ -0,0 +1,20 @@
+#!/sbin/openrc-run
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License, v2 or later
+
+depend() {
+       need localmount
+       after bootmisc
+}
+
+command="/usr/sbin/irqbalance"
+command_args="${IRQBALANCE_OPTS}"
+
+start_pre() {
+       if grep -q MSI /proc/interrupts 2>/dev/null && \
+       test -z "$(find /sys/devices -type d -name msi_irqs 2>/dev/null)"; then
+               eerror "MSI interrupts found in /proc/interrupts but none found in sysfs."
+               eerror "You need to update your kernel."
+               return 1
+       fi
+}
diff --git a/sys-apps/irqbalance/irqbalance-1.2.0.ebuild b/sys-apps/irqbalance/irqbalance-1.2.0.ebuild
new file mode 100644 (file)
index 0000000..5a86070
--- /dev/null
@@ -0,0 +1,63 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils systemd linux-info
+
+DESCRIPTION="Distribute hardware interrupts across processors on a multiprocessor system"
+HOMEPAGE="https://github.com/Irqbalance/irqbalance"
+SRC_URI="https://github.com/Irqbalance/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="caps +numa selinux"
+
+CDEPEND="
+       dev-libs/glib:2
+       sys-libs/ncurses:0=[unicode]
+       caps? ( sys-libs/libcap-ng )
+       numa? ( sys-process/numactl )
+"
+DEPEND="${CDEPEND}
+       virtual/pkgconfig
+"
+RDEPEND="${CDEPEND}
+       selinux? ( sec-policy/selinux-irqbalance )
+"
+
+PATCHES=(
+       "${FILESDIR}/${P}-tinfo.patch"
+)
+
+pkg_setup() {
+       CONFIG_CHECK="~PCI_MSI"
+       linux-info_pkg_setup
+}
+
+src_prepare() {
+       # Follow systemd policies
+       # https://wiki.gentoo.org/wiki/Project:Systemd/Ebuild_policy
+       sed \
+               -e 's/ $IRQBALANCE_ARGS//' \
+               -e '/EnvironmentFile/d' \
+               -i misc/irqbalance.service || die
+       autotools-utils_src_prepare
+}
+
+src_configure() {
+       local myeconfargs=(
+               $(use_with caps libcap-ng)
+               $(use_enable numa)
+               )
+       autotools-utils_src_configure
+}
+
+src_install() {
+       autotools-utils_src_install
+       newinitd "${FILESDIR}"/irqbalance.init.4 irqbalance
+       newconfd "${FILESDIR}"/irqbalance.confd-1 irqbalance
+       systemd_dounit misc/irqbalance.service
+}