dev-ros/monocam_settler: Initial import. Ebuild by me.
authorAlexis Ballier <aballier@gentoo.org>
Sun, 11 Oct 2015 12:19:47 +0000 (14:19 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Sun, 11 Oct 2015 14:34:21 +0000 (16:34 +0200)
Package-Manager: portage-2.2.23

dev-ros/monocam_settler/Manifest [new file with mode: 0644]
dev-ros/monocam_settler/metadata.xml [new file with mode: 0644]
dev-ros/monocam_settler/monocam_settler-0.10.13.ebuild [new file with mode: 0644]
dev-ros/monocam_settler/monocam_settler-9999.ebuild [new file with mode: 0644]

diff --git a/dev-ros/monocam_settler/Manifest b/dev-ros/monocam_settler/Manifest
new file mode 100644 (file)
index 0000000..3890704
--- /dev/null
@@ -0,0 +1 @@
+DIST calibration-0.10.13.tar.gz 112305 SHA256 935755f9428e6b998d1a9ce10fcf11f3c119953ebe0b65eda855804ec8b8aea8 SHA512 95b5ea28428ea9726b6b1a8f24cd4c7cb84992e680761357c1a13dd92c362149a0a6104f6a44dbefad503db1a9c7a53135d9756b1ceea3a739b1baa14f9474eb WHIRLPOOL 94423d70268b053daee1da1b324582d2f8316c6feaa5c9291715b1861520cb2e67654daaa2156e8d15cd59ecb566bdd3cb76d42c7202b85680888bac3532002c
diff --git a/dev-ros/monocam_settler/metadata.xml b/dev-ros/monocam_settler/metadata.xml
new file mode 100644 (file)
index 0000000..c42ea5b
--- /dev/null
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>
diff --git a/dev-ros/monocam_settler/monocam_settler-0.10.13.ebuild b/dev-ros/monocam_settler/monocam_settler-0.10.13.ebuild
new file mode 100644 (file)
index 0000000..b413582
--- /dev/null
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/calibration"
+CATKIN_HAS_MESSAGES=yes
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/actionlib_msgs dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Listens on a ImageFeatures topic, and waits for the data to settle"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       dev-ros/actionlib[${PYTHON_USEDEP}]
+       dev-ros/rosconsole
+       dev-ros/roscpp_serialization
+       dev-ros/settlerlib
+       dev-libs/boost:=[threads]
+"
+DEPEND="${RDEPEND}
+       test? ( dev-cpp/gtest )"
diff --git a/dev-ros/monocam_settler/monocam_settler-9999.ebuild b/dev-ros/monocam_settler/monocam_settler-9999.ebuild
new file mode 100644 (file)
index 0000000..b413582
--- /dev/null
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/calibration"
+CATKIN_HAS_MESSAGES=yes
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/actionlib_msgs dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Listens on a ImageFeatures topic, and waits for the data to settle"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       dev-ros/actionlib[${PYTHON_USEDEP}]
+       dev-ros/rosconsole
+       dev-ros/roscpp_serialization
+       dev-ros/settlerlib
+       dev-libs/boost:=[threads]
+"
+DEPEND="${RDEPEND}
+       test? ( dev-cpp/gtest )"