sys-cluster/neutron: clean up kernel config checks
authorMatthew Thode <prometheanfire@gentoo.org>
Mon, 30 Mar 2020 03:02:55 +0000 (22:02 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Mon, 30 Mar 2020 03:03:16 +0000 (22:03 -0500)
Closes: https://bugs.gentoo.org/713656
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
sys-cluster/neutron/neutron-2019.2.9999.ebuild

index 518d9465fd1a854d54912e0e1b05e3b607d337cb..0e69504690478c4f0c977fd2c67835a21c439789 100644 (file)
@@ -128,8 +128,8 @@ RDEPEND="
 pkg_pretend() {
        linux-info_pkg_setup
        CONFIG_CHECK_MODULES="VLAN_8021Q IP6_NF_FILTER IP6_NF_IPTABLES IP_NF_TARGET_REJECT \
-       IP_NF_MANGLE IP_NF_TARGET_MASQUERADE NF_NAT_IPV4 NF_CONNTRACK_IPV4 NF_DEFRAG_IPV4 \
-       NF_NAT_IPV4 NF_NAT NF_CONNTRACK IP_NF_FILTER IP_NF_IPTABLES NETFILTER_XTABLES"
+       IP_NF_MANGLE IP_NF_TARGET_MASQUERADE NF_NAT_IPV4 NF_DEFRAG_IPV4 NF_NAT NF_CONNTRACK \
+       IP_NF_FILTER IP_NF_IPTABLES NETFILTER_XTABLES"
        if linux_config_exists; then
                for module in ${CONFIG_CHECK_MODULES}; do
                        linux_chkconfig_present ${module} || ewarn "${module} needs to be enabled in kernel"