media-libs/gstreamer: correctly fix bug #577312
authorAnthony G. Basile <blueness@gentoo.org>
Wed, 11 May 2016 00:27:45 +0000 (20:27 -0400)
committerAnthony G. Basile <blueness@gentoo.org>
Wed, 11 May 2016 00:27:45 +0000 (20:27 -0400)
Package-Manager: portage-2.2.26

media-libs/gstreamer/files/gstreamer-1.6.3-fix-strsignal.patch [new file with mode: 0644]
media-libs/gstreamer/gstreamer-1.6.3.ebuild

diff --git a/media-libs/gstreamer/files/gstreamer-1.6.3-fix-strsignal.patch b/media-libs/gstreamer/files/gstreamer-1.6.3-fix-strsignal.patch
new file mode 100644 (file)
index 0000000..9d717e8
--- /dev/null
@@ -0,0 +1,32 @@
+Upstream split this one commit into two: c9da8b0 and d6e25dd because
+of some confusion.  I've recombined it here.  See:
+
+https://bugzilla.gnome.org/show_bug.cgi?id=763567
+https://bugs.gentoo.org/show_bug.cgi?id=577312
+
+diff --git a/libs/gst/check/libcheck/strsignal.c b/libs/gst/check/libcheck/strsignal.c
+index b79409b..57e71cd 100644
+--- a/libs/gst/check/libcheck/strsignal.c
++++ b/libs/gst/check/libcheck/strsignal.c
+@@ -1,6 +1,6 @@
+ #include "libcompat.h"
+-const char *
++char *
+ strsignal (int sig)
+ {
+   static char signame[40];
+
+diff --git a/libs/gst/check/libcheck/libcompat.h b/libs/gst/check/libcheck/libcompat.h
+index 32f944c..f09289b 100644
+--- a/libs/gst/check/libcheck/libcompat.h
++++ b/libs/gst/check/libcheck/libcompat.h
+@@ -101,7 +101,7 @@ CK_DLL_EXP char *strdup (const char *str);
+ #endif /* !HAVE_DECL_STRDUP && HAVE__STRDUP */
+ #if !HAVE_DECL_STRSIGNAL
+-CK_DLL_EXP const char *strsignal (int sig);
++CK_DLL_EXP char *strsignal (int sig);
+ #endif /* !HAVE_DECL_STRSIGNAL */
+ /*
index 3b778476c233ce5dcc9effc57248c199c125103c..63ff72f9f12c5a94c214a6afd8eb9c46b5817599 100644 (file)
@@ -30,6 +30,10 @@ DEPEND="${RDEPEND}
 "
 # gtk-doc-am to install API docs
 
+src_prepare() {
+       epatch "${FILESDIR}"/${P}-fix-strsignal.patch #577312
+}
+
 src_configure() {
        if [[ ${CHOST} == *-interix* ]] ; then
                export ac_cv_lib_dl_dladdr=no