games-emulation/snes9x: remove unused patches
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>
Sat, 9 May 2020 17:48:33 +0000 (19:48 +0200)
committerJames Le Cuirot <chewi@gentoo.org>
Sat, 9 May 2020 20:07:20 +0000 (21:07 +0100)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Michael Mair-Keimberger <m.mairkeimberger@gmail.com>
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
games-emulation/snes9x/files/snes9x-1.58-build-system.patch [deleted file]
games-emulation/snes9x/files/snes9x-1.58-without-screenshot_build_fix.patch [deleted file]

diff --git a/games-emulation/snes9x/files/snes9x-1.58-build-system.patch b/games-emulation/snes9x/files/snes9x-1.58-build-system.patch
deleted file mode 100644 (file)
index 8a15e0a..0000000
+++ /dev/null
@@ -1,53 +0,0 @@
---- snes9x-1.58/gtk/configure.ac
-+++ snes9x-1.58/gtk/configure.ac
-@@ -33,8 +33,8 @@
- AM_GNU_GETTEXT([external])
- AM_GNU_GETTEXT_VERSION([0.19.2])
--snes9xlocaledir='${prefix}/share/locale'
--snes9xdatadir='${prefix}/share/snes9x'
-+snes9xlocaledir='$(localedir)'
-+snes9xdatadir='$(datadir)/snes9x'
- AC_SUBST(snes9xlocaledir)
- AC_SUBST(snes9xdatadir)
---- snes9x-1.58/unix/configure.ac
-+++ snes9x-1.58/unix/configure.ac
-@@ -56,37 +56,6 @@
- # *** Execution begins here ***
- # *****************************
--# Test what compiler flags we should use.
--
--AC_ARG_ENABLE([debug],
--      [AS_HELP_STRING([--enable-debug],
--              [leave debug information in the final binary (default: no)])],
--      [], [enable_debug="no"])
--
--if test "x$enable_debug" = "xyes"; then
--      AC_S9X_COMPILER_FLAG([-g],  [g])
--      AC_S9X_COMPILER_FLAG([-O0], [o0])
--else
--      AC_S9X_COMPILER_FLAG([-O3], [o3], [
--              AC_S9X_COMPILER_FLAG([-O2], [o2], [
--                      AC_S9X_COMPILER_FLAG([-O1], [o1])])])
--      AC_S9X_COMPILER_FLAG([-fomit-frame-pointer], [omit_frame_pointer])
--fi
--
--AC_ARG_ENABLE([mtune],
--      [AS_HELP_STRING([--enable-mtune],
--              [use the specified value for the -mtune/-mcpu flag (default: no)])],
--      [], [enable_mtune="no"])
--
--if test "x$enable_mtune" != "xno"; then
--      AC_S9X_COMPILER_FLAG([-mtune="$enable_mtune"], [mtune],
--      [
--              AC_MSG_WARN([-mtune failed, trying -mcpu...])
--              AC_S9X_COMPILER_FLAG([-mcpu="$enable_mtune"], [mcpu],
--                      [AC_MSG_ERROR([Please specify a working value for --enable-mtune.])])
--      ])
--fi
--
- AC_S9X_COMPILER_FLAG([-fno-exceptions],       [no_exceptions])
- AC_S9X_COMPILER_FLAG([-fno-rtti],             [no_rtti])
- AC_S9X_COMPILER_FLAG([-pedantic],             [pedantic])
diff --git a/games-emulation/snes9x/files/snes9x-1.58-without-screenshot_build_fix.patch b/games-emulation/snes9x/files/snes9x-1.58-without-screenshot_build_fix.patch
deleted file mode 100644 (file)
index 7af1e9e..0000000
+++ /dev/null
@@ -1,31 +0,0 @@
-From 51909e0cb44ee8de346f3edfb2a6c4a8bb97ea1d Mon Sep 17 00:00:00 2001
-From: Brandon Wright <bearoso@gmail.com>
-Date: Fri, 4 Jan 2019 10:52:11 -0600
-Subject: [PATCH] Fix PNG usage without preprocessor check.
-
----
- shaders/shader_helpers.cpp | 4 ++++
- 1 file changed, 4 insertions(+)
-
-diff --git a/shaders/shader_helpers.cpp b/shaders/shader_helpers.cpp
-index b84e6291..a589d39b 100644
---- a/shaders/shader_helpers.cpp
-+++ b/shaders/shader_helpers.cpp
-@@ -93,6 +93,7 @@ bool loadPngImage(const char* name,
-     bool& outHasAlpha,
-     GLubyte** outData)
- {
-+#ifdef HAVE_LIBPNG
-     png_structp png_ptr;
-     png_infop info_ptr;
-     unsigned int sig_read = 0;
-@@ -211,6 +212,9 @@ bool loadPngImage(const char* name,
-     /* That's it */
-     return true;
-+#else
-+    return false;
-+#endif
- }
- bool loadTGA(const char* filename, STGA& tgaFile)