dev-util/lxqt-build-tools: version bump to 0.5.0
authorRobert Förster <Dessa@gmake.de>
Wed, 23 May 2018 08:17:20 +0000 (10:17 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Wed, 27 Jun 2018 19:00:22 +0000 (21:00 +0200)
Package-Manager: Portage-2.3.38, Repoman-2.3.9
Closes: https://github.com/gentoo/gentoo/pull/8531

dev-util/lxqt-build-tools/Manifest
dev-util/lxqt-build-tools/lxqt-build-tools-0.5.0.ebuild [new file with mode: 0644]

index 349973ddbe5e14296add5e4e74f42c0f5e9beb87..2b1864fcd372f04c11cef709c881a0921ac08c05 100644 (file)
@@ -1,2 +1,3 @@
 DIST lxqt-build-tools-0.2.0.tar.xz 15552 BLAKE2B 558e1c9f43e09e51a720460592309f3f52fb7832a121ae40c8d9945ed135d6220190182a6d2311bfb9e9971f68a60f0ab7d5dcf2055301fa683dfc483170b3c6 SHA512 40349710a20d3f06761c57b5d40aa05cb194fa4b50d1e41e4bd7e6adf1beb5c7209f3d4965869a301369df17ec1d75f55aede7ab0fe88a55d692cd56d72121de
 DIST lxqt-build-tools-0.4.0.tar.xz 19988 BLAKE2B 119f2907062c08996b26170b519b9c4ce0308d6bc65dc1363fd81e064084ebe7305de7e66225e2ea3bcea899c2eaac49dcf7651b72a4f3a9d565ce4fd1d5a756 SHA512 d84cfce5db9520725e24855f99fb3125f19ff5dbac12ec6d283e9c4483497c675b32061cdea2eda533e57857be4a6eb6020049ae4f593ea61a321b2708604638
+DIST lxqt-build-tools-0.5.0.tar.xz 23392 BLAKE2B 1f28ae093af772ed2b6f75a7933b76a2c608171bf15e0c8483477d7f3b702dec79f41af70bb38863c3b17ff9d52a8f2acabd4ed2347bb7f421d2074b8767e96c SHA512 6802f3d5e3d622b136cf312ad929353aac1f42355c00ac9e3fb7a9d46c63dba1f87a0a4fd11185289c4e7222d5b0d30b8829dacd38c88de45901ff0559639e90
diff --git a/dev-util/lxqt-build-tools/lxqt-build-tools-0.5.0.ebuild b/dev-util/lxqt-build-tools/lxqt-build-tools-0.5.0.ebuild
new file mode 100644 (file)
index 0000000..97c50c2
--- /dev/null
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit cmake-utils
+
+DESCRIPTION="LXQt Build tools"
+HOMEPAGE="https://lxqt.org/"
+
+if [[ ${PV} = *9999* ]]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+       SRC_URI="https://downloads.lxqt.org/downloads/${PN}/${PV}/${P}.tar.xz"
+       KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND="
+       >=dev-libs/glib-2.50.0
+       dev-qt/qtcore:5
+"
+DEPEND="${RDEPEND}"