dev-python/parso: Disable failing error tests
authorMichał Górny <mgorny@gentoo.org>
Fri, 28 Feb 2020 05:56:47 +0000 (06:56 +0100)
committerMichał Górny <mgorny@gentoo.org>
Fri, 28 Feb 2020 05:56:47 +0000 (06:56 +0100)
Disable error tests that started failing with Python 3.8.2 as they
depend on exact exception messages.

Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/parso/parso-0.6.1.ebuild

index d33ced31acc557cbbe73bf379ec7c47403c2cae0..d9dff2d95d495947efc9894bec22ae6d7050470f 100644 (file)
@@ -19,3 +19,11 @@ RESTRICT="!test? ( test )"
 
 distutils_enable_sphinx docs
 distutils_enable_tests pytest
+
+src_prepare() {
+       # tests rely on specific exception messages and fail occasionally
+       # upstream suggested skipping them
+       rm test/test_python_errors.py || die
+
+       distutils-r1_src_prepare
+}