dev-ml/ocamlnet: Clean up old.
authorPatrice Clement <monsieurp@gentoo.org>
Mon, 27 Jun 2016 19:56:26 +0000 (19:56 +0000)
committerPatrice Clement <monsieurp@gentoo.org>
Mon, 27 Jun 2016 20:05:23 +0000 (20:05 +0000)
Package-Manager: portage-2.2.28

dev-ml/ocamlnet/Manifest
dev-ml/ocamlnet/ocamlnet-3.7.7.ebuild [deleted file]
dev-ml/ocamlnet/ocamlnet-4.0.4.ebuild [deleted file]
dev-ml/ocamlnet/ocamlnet-4.1.1.ebuild [deleted file]

index 5a7ab746ff7e18efa50689b86b918d56a2e3ca80..ae3ae742c7332e76c7ee898aa4371ec79a7ae275 100644 (file)
@@ -1,4 +1 @@
-DIST ocamlnet-3.7.7.tar.gz 3357674 SHA256 5b8e464a874018c5e48fc1edc752b83e014061f19316b5b14df8422d939e7609 SHA512 b500a92e6c5dc4d96ac26352923d78cb3a8b555deda038c41860aecbd20ee9ccbcfee949014c91f1266c937ae03fadd72c322e3cbe6456d23fd20b871114df6a WHIRLPOOL ceb4a9fc5d43fe89487589ae14c4bdf58d6c3d99d3a9ebc07fa722e894106899a2ae2aca91a47338d8004017fdd0d23632e187d96ec51479b43955daddbbb893
-DIST ocamlnet-4.0.4.tar.gz 4336176 SHA256 becaa6c2b0c1ae6a3fb05139928442e5d4a685ea5033017060a86d70114e5f72 SHA512 f3bce94d43161e46bf0973bfbe0d9d5d7232136a24a27b987ae371a7aab129720df35bd0d6ef75126d587ee1fde56fe29d05bc44840724adf3be50ac250e7c85 WHIRLPOOL 34985fa9a49a60d6e671645a73533d6284b87205d63956265e631195ab117afdc6b41347e72f92d8cab711aef35db0c78a8989c955507dac66e8174ec6cb0242
-DIST ocamlnet-4.1.1.tar.gz 4561784 SHA256 61e5c280e96f7fd5a7d1e63391f60da6704e16f3816b45acaed17dd7042912fc SHA512 cd10f7fe622bed3208cc5ad66d65911c1c0992bdc6f4d1bc10d6e7ef197fe157226e6b8ca7857b91cd1c6d6103ac9c3d586d39f3cb32a9ccb9ab83e00bf4444d WHIRLPOOL c39fbb5e37c6eb71f8899f703913a9869e5f4995418195f68f7dbc53314c12d15ca941b35b00eff78ba9a088af079578db7a3e1ffee1467a027479e38c8bff2d
 DIST ocamlnet-4.1.2.tar.gz 4623183 SHA256 918c3921529cfe545e206b3535a58f43f665165044dd3548f685b583e94f14d8 SHA512 69f42042a54efd662db2217224da53513fc7e72c7b2313d4a4a1128f1b4624f4f6298434f5b19f354b832119ff151abc81e85eb0108d6eb24f30f82d176e0b4d WHIRLPOOL 27e1a8eb24361cadb8b2fb2b61bc6e93d71be8290873ca5bb1eebe16b9c9b1db69eae3b20c8deb3f6656aa79171a817b15acae53159d80ff8f4c946c201de173
diff --git a/dev-ml/ocamlnet/ocamlnet-3.7.7.ebuild b/dev-ml/ocamlnet/ocamlnet-3.7.7.ebuild
deleted file mode 100644 (file)
index 779f710..0000000
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-
-inherit eutils findlib
-
-MY_P=${P/_beta/test}
-DESCRIPTION="Modules for OCaml application-level Internet protocols"
-HOMEPAGE="http://projects.camlcity.org/projects/ocamlnet.html"
-SRC_URI="http://download.camlcity.org/download/${MY_P}.tar.gz"
-
-LICENSE="ZLIB GPL-2+"
-SLOT="0/${PV}"
-KEYWORDS="amd64 ppc x86 ~x86-fbsd"
-IUSE="cryptokit gtk ssl tk httpd +ocamlopt +pcre zip"
-RESTRICT="installsources"
-
-# the auth-dh compile flag has been disabled as well, since it depends on
-# ocaml-cryptgps, which is not available.
-
-DEPEND=">=dev-ml/findlib-1.0
-               pcre? ( >=dev-ml/pcre-ocaml-5:= )
-               >=dev-lang/ocaml-3.10.2:=[ocamlopt?]
-               tk? ( || ( dev-ml/labltk:= <dev-lang/ocaml-4.02[tk] ) )
-               cryptokit? ( dev-ml/cryptokit:= )
-               gtk? ( >=dev-ml/lablgtk-2:= )
-               ssl? ( >=dev-ml/ocaml-ssl-0.4:= )
-               zip? ( dev-ml/camlzip:= )
-               "
-RDEPEND="${DEPEND}"
-
-S=${WORKDIR}/${MY_P}
-
-ocamlnet_use_with() {
-       if use $1; then
-               echo "-with-$2"
-       else
-               echo "-without-$2"
-       fi
-}
-
-ocamlnet_use_enable() {
-       if use $1; then
-               echo "-enable-$2"
-       else
-               echo "-disable-$2"
-       fi
-}
-
-src_configure() {
-       ./configure \
-               -bindir /usr/bin \
-               -datadir /usr/share/${PN} \
-               $(ocamlnet_use_enable cryptokit crypto) \
-               $(ocamlnet_use_enable gtk gtk2) \
-               $(ocamlnet_use_enable pcre pcre) \
-               $(ocamlnet_use_enable ssl ssl) \
-               $(ocamlnet_use_enable tk tcl) \
-               $(ocamlnet_use_enable zip zip) \
-               $(ocamlnet_use_with httpd nethttpd) \
-               || die "Error : econf failed!"
-}
-
-src_compile() {
-       emake -j1 all
-       if use ocamlopt; then
-               emake -j1 opt
-       fi
-}
-
-src_install() {
-       export STRIP_MASK="*/bin/*"
-       findlib_src_install
-}
diff --git a/dev-ml/ocamlnet/ocamlnet-4.0.4.ebuild b/dev-ml/ocamlnet/ocamlnet-4.0.4.ebuild
deleted file mode 100644 (file)
index 5fe2f7a..0000000
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-
-inherit eutils findlib
-
-MY_P=${P/_beta/test}
-DESCRIPTION="Modules for OCaml application-level Internet protocols"
-HOMEPAGE="http://projects.camlcity.org/projects/ocamlnet.html"
-SRC_URI="http://download.camlcity.org/download/${MY_P}.tar.gz"
-
-LICENSE="ZLIB GPL-2+"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
-IUSE="gtk kerberos tk httpd +ocamlopt +pcre ssl zip"
-RESTRICT="installsources"
-
-# the auth-dh compile flag has been disabled as well, since it depends on
-# ocaml-cryptgps, which is not available.
-
-RDEPEND=">=dev-ml/findlib-1.0
-               pcre? ( >=dev-ml/pcre-ocaml-5:= )
-               >=dev-lang/ocaml-3.10.2:=[ocamlopt?]
-               tk? ( || ( dev-ml/labltk:= <dev-lang/ocaml-4.02[tk] ) )
-               ssl? ( net-libs/gnutls:= )
-               gtk? ( >=dev-ml/lablgtk-2:= )
-               kerberos? ( virtual/krb5 )
-               zip? ( dev-ml/camlzip:= )
-               "
-DEPEND="${RDEPEND}
-       virtual/pkgconfig
-"
-
-S=${WORKDIR}/${MY_P}
-
-ocamlnet_use_with() {
-       if use $1; then
-               echo "-with-$2"
-       else
-               echo "-without-$2"
-       fi
-}
-
-ocamlnet_use_enable() {
-       if use $1; then
-               echo "-enable-$2"
-       else
-               echo "-disable-$2"
-       fi
-}
-
-src_configure() {
-       ./configure \
-               -bindir /usr/bin \
-               -datadir /usr/share/${PN} \
-               $(ocamlnet_use_enable ssl gnutls) \
-               $(ocamlnet_use_enable gtk gtk2) \
-               $(ocamlnet_use_enable kerberos gssapi) \
-               $(ocamlnet_use_enable pcre pcre) \
-               $(ocamlnet_use_enable tk tcl) \
-               $(ocamlnet_use_enable zip zip) \
-               $(ocamlnet_use_with httpd nethttpd) \
-               || die "Error : econf failed!"
-}
-
-src_compile() {
-       emake -j1 all
-       if use ocamlopt; then
-               emake -j1 opt
-       fi
-}
-
-src_install() {
-       export STRIP_MASK="*/bin/*"
-       findlib_src_install
-}
diff --git a/dev-ml/ocamlnet/ocamlnet-4.1.1.ebuild b/dev-ml/ocamlnet/ocamlnet-4.1.1.ebuild
deleted file mode 100644 (file)
index 5c042a3..0000000
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-
-inherit eutils findlib
-
-MY_P=${P/_beta/test}
-DESCRIPTION="Modules for OCaml application-level Internet protocols"
-HOMEPAGE="http://projects.camlcity.org/projects/ocamlnet.html"
-SRC_URI="http://download.camlcity.org/download/${MY_P}.tar.gz"
-
-LICENSE="ZLIB GPL-2+"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
-IUSE="gtk kerberos tk httpd +ocamlopt +pcre ssl zip"
-RESTRICT="installsources"
-
-# the auth-dh compile flag has been disabled as well, since it depends on
-# ocaml-cryptgps, which is not available.
-
-RDEPEND=">=dev-ml/findlib-1.0
-               pcre? ( >=dev-ml/pcre-ocaml-5:= )
-               >=dev-lang/ocaml-3.10.2:=[ocamlopt?]
-               tk? ( || ( dev-ml/labltk:= <dev-lang/ocaml-4.02[tk] ) )
-               ssl? ( net-libs/gnutls:= )
-               gtk? ( >=dev-ml/lablgtk-2:= )
-               kerberos? ( virtual/krb5 )
-               zip? ( dev-ml/camlzip:= )
-               "
-DEPEND="${RDEPEND}
-       virtual/pkgconfig
-"
-
-S=${WORKDIR}/${MY_P}
-
-src_prepare() {
-       has_version '>=dev-lang/ocaml-4.03' && epatch "${FILESDIR}/oc43.patch"
-}
-
-ocamlnet_use_with() {
-       if use $1; then
-               echo "-with-$2"
-       else
-               echo "-without-$2"
-       fi
-}
-
-ocamlnet_use_enable() {
-       if use $1; then
-               echo "-enable-$2"
-       else
-               echo "-disable-$2"
-       fi
-}
-
-src_configure() {
-       ./configure \
-               -bindir /usr/bin \
-               -datadir /usr/share/${PN} \
-               $(ocamlnet_use_enable ssl gnutls) \
-               $(ocamlnet_use_enable gtk gtk2) \
-               $(ocamlnet_use_enable kerberos gssapi) \
-               $(ocamlnet_use_enable pcre pcre) \
-               $(ocamlnet_use_enable tk tcl) \
-               $(ocamlnet_use_enable zip zip) \
-               $(ocamlnet_use_with httpd nethttpd) \
-               || die "Error : econf failed!"
-}
-
-src_compile() {
-       emake -j1 all
-       if use ocamlopt; then
-               emake -j1 opt
-       fi
-}
-
-src_install() {
-       export STRIP_MASK="*/bin/*"
-       findlib_src_install
-}