sys-cluster/torque: use integer comparison, bug #705278
authorSergei Trofimovich <slyfox@gentoo.org>
Fri, 22 May 2020 18:50:31 +0000 (19:50 +0100)
committerSergei Trofimovich <slyfox@gentoo.org>
Fri, 22 May 2020 18:50:37 +0000 (19:50 +0100)
Use integer comparison instead of lexicographical one.

Bug: https://bugs.gentoo.org/705278
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
sys-cluster/torque/torque-4.2.10-r1.ebuild

index bf8705f64b418149806c1aa47ec94b8a60478ca7..c992fb2b62ce2d35f5429d7b0bfaca5049755b1f 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -184,7 +184,7 @@ pkg_postinst() {
                        fi
                done
        fi
-       if [[ ${showmessage} > 0 ]]; then
+       if [[ ${showmessage} -gt 0 ]]; then
                elog "Important v4.x changes:"
                elog "  - The on-wire protocol version has been changed."
                elog "    Versions of Torque before 4.0.0 are no longer able to communicate."