games-puzzle/pathological: Drop old
authorPacho Ramos <pacho@gentoo.org>
Wed, 25 Dec 2019 19:59:15 +0000 (20:59 +0100)
committerPacho Ramos <pacho@gentoo.org>
Wed, 25 Dec 2019 19:59:26 +0000 (20:59 +0100)
Package-Manager: Portage-2.3.82, Repoman-2.3.20
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
games-puzzle/pathological/files/pathological-1.1.3-build.patch [deleted file]
games-puzzle/pathological/files/pathological-1.1.3-music-py.patch [deleted file]
games-puzzle/pathological/pathological-1.1.3-r3.ebuild [deleted file]

diff --git a/games-puzzle/pathological/files/pathological-1.1.3-build.patch b/games-puzzle/pathological/files/pathological-1.1.3-build.patch
deleted file mode 100644 (file)
index d8793a6..0000000
+++ /dev/null
@@ -1,27 +0,0 @@
-Use implicit rules to build write-highscores so we dont have to worry
-about CC/CFLAGS/LDFLAGS/etc...
-
-Include stdlib.h to get exit() prototype
-
---- write-highscores.c
-+++ write-highscores.c
-@@ -25,6 +25,7 @@
- #include <sys/stat.h>
- #include <unistd.h>
- #include <fcntl.h>
-+#include <stdlib.h>
- #define BUFFER_SIZE 1024
---- Makefile
-+++ Makefile
-@@ -4,9 +4,6 @@
- all: write-highscores html/wheel.png
--write-highscores: write-highscores.c
--      gcc -s -o write-highscores write-highscores.c
--
- html/wheel.png:
-       ./makehtml
diff --git a/games-puzzle/pathological/files/pathological-1.1.3-music-py.patch b/games-puzzle/pathological/files/pathological-1.1.3-music-py.patch
deleted file mode 100644 (file)
index 9d67085..0000000
+++ /dev/null
@@ -1,23 +0,0 @@
-Make sure music_pending_song is defined before we try using it
-
-http://bugs.gentoo.org/109272
-
---- pathological.py
-+++ pathological.py
-@@ -28,6 +28,7 @@
- colorblind = 0
- sound_on = 1
- music_on = 1
-+music_pending_song = 0
- for arg in sys.argv[1:]:
-       if arg == '-s':
-               screenshot = 1
-@@ -194,7 +195,7 @@
-       sound_on = sound_on ^ 1
- def toggle_music():
--      global music_on
-+      global music_pending_song, music_on
-       music_on = music_on ^ 1
-       if music_on:
-               if music_pending_song:
diff --git a/games-puzzle/pathological/pathological-1.1.3-r3.ebuild b/games-puzzle/pathological/pathological-1.1.3-r3.ebuild
deleted file mode 100644 (file)
index 88e3d60..0000000
+++ /dev/null
@@ -1,95 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-inherit eutils python-single-r1 games
-
-DESCRIPTION="An enriched clone of the game 'Logical' by Rainbow Arts"
-HOMEPAGE="http://pathological.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="${PYTHON_DEPS}
-       app-shells/bash
-       >=dev-python/pygame-1.5.5[${PYTHON_USEDEP}]"
-DEPEND="${PYTHON_DEPS}
-       doc? ( media-libs/netpbm )"
-
-pkg_setup() {
-       games_pkg_setup
-       python-single-r1_pkg_setup
-}
-
-src_unpack() {
-       unpack ${A}
-       cd "${S}" || die
-       unpack ./${PN}.6.gz
-}
-
-src_prepare() {
-       epatch \
-               "${FILESDIR}"/${P}-build.patch \
-               "${FILESDIR}"/${P}-music-py.patch
-
-       if use doc ; then
-               sed -i -e '5,$ s/=/ /g' makehtml || die
-       else
-               echo "#!/bin/sh" > makehtml
-       fi
-
-       sed -i \
-               -e "s:/usr/share/games:${GAMES_DATADIR}:" \
-               -e "s:/var/games:${GAMES_STATEDIR}:" \
-               -e "s:exec:exec ${EPYTHON}:" \
-               ${PN} || die
-
-       sed -i \
-               -e 's:\xa9:(C):' \
-               -e "s:/usr/lib/${PN}/bin:$(games_get_libdir)/${PN}:" \
-               ${PN}.py || die
-
-       python_fix_shebang ${PN}.py
-}
-
-src_install() {
-       dogamesbin ${PN}
-
-       exeinto "$(games_get_libdir)"/${PN}
-       doexe write-highscores
-
-       insinto "${GAMES_DATADIR}"/${PN}
-       doins -r circuits graphics music sounds ${PN}.py
-
-       insinto "${GAMES_STATEDIR}"
-       doins ${PN}_scores
-       fperms 660 "${GAMES_STATEDIR}"/${PN}_scores
-
-       dodoc changelog README TODO
-       doman ${PN}.6
-       use doc && dohtml -r html/*
-
-       doicon ${PN}.xpm
-       make_desktop_entry ${PN} Pathological ${PN}
-
-       # remove some unneeded resource files
-       rm -f "${D}/${GAMES_DATADIR}"/${PN}/graphics/*.xcf
-       prepgamesdirs
-}
-
-pkg_postinst() {
-       games_pkg_postinst
-       if ! has_version "media-libs/sdl-mixer[mod]" ; then
-               echo
-               elog "Since you have turned off the 'mod' use flag for media-libs/sdl-mixer"
-               elog "no background music will be played."
-               echo
-       fi
-
-}