games-action/0verkill: remove deprecated games eclass
authorAustin English <wizardedit@gentoo.org>
Fri, 1 Jul 2016 18:57:16 +0000 (13:57 -0500)
committerAustin English <wizardedit@gentoo.org>
Fri, 1 Jul 2016 18:57:16 +0000 (13:57 -0500)
Also update to EAPI 6

Gentoo-Bug: https://bugs.gentoo.org/574082

Package-Manager: portage-2.2.28

games-action/0verkill/0verkill-0.16-r4.ebuild [new file with mode: 0644]
games-action/0verkill/files/0verkill-0.16-CC.patch
games-action/0verkill/files/0verkill-0.16-gentoo-paths.patch
games-action/0verkill/files/0verkill-0.16-home-overflow.patch
games-action/0verkill/files/0verkill-0.16-ovflfix.patch

diff --git a/games-action/0verkill/0verkill-0.16-r4.ebuild b/games-action/0verkill/0verkill-0.16-r4.ebuild
new file mode 100644 (file)
index 0000000..5eb0dc1
--- /dev/null
@@ -0,0 +1,63 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit autotools eutils
+
+DESCRIPTION="a bloody 2D action deathmatch-like game in ASCII-ART"
+HOMEPAGE="http://artax.karlin.mff.cuni.cz/~brain/0verkill/"
+SRC_URI="http://artax.karlin.mff.cuni.cz/~brain/0verkill/release/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="X"
+
+DEPEND="X? ( x11-libs/libXpm )"
+RDEPEND=${DEPEND}
+
+PATCHES=(
+               "${FILESDIR}"/${P}-docs.patch
+               "${FILESDIR}"/${P}-home-overflow.patch
+               "${FILESDIR}"/${P}-segv.patch
+               "${FILESDIR}"/${P}-gentoo-paths.patch
+               "${FILESDIR}"/${P}-ovflfix.patch
+               "${FILESDIR}"/${P}-CC.patch
+               "${FILESDIR}"/${P}-underflow-check.patch #136222
+)
+
+src_prepare() {
+       default
+       sed -i \
+               -e "s:data/:/usr/share/${PN}/data/:" cfg.h || die
+       sed -i \
+               -e "s:@CFLAGS@ -O3 :@CFLAGS@ :" Makefile.in || die
+       sed -i \
+               -e "/gettimeofday/s/getopt/getopt calloc/" configure.in || die
+       eautoreconf
+}
+
+src_configure() {
+       econf $(use_with X x)
+}
+
+src_install() {
+       local x
+       dobin 0verkill
+       for x in avi bot editor server test_server ; do
+               newbin ${x} 0verkill-${x}
+       done
+       if use X ; then
+               dobin x0verkill
+               for x in avi editor ; do
+                       newbin ${x} 0verkill-${x}
+               done
+       fi
+
+       insinto "/usr/share/${PN}"
+       doins -r data grx
+
+       rm doc/README.OS2 doc/Readme\ Win32.txt doc/COPYING
+       dodoc -r doc/
+}
index b2ba0f014d8691829d4b691ecbd59381c4227cfb..568f8a4aa6f2ddbaa3109ec6277e0a50122be6e4 100644 (file)
@@ -1,5 +1,5 @@
---- Makefile.in.orig   2010-11-08 13:30:42.060916323 -0500
-+++ Makefile.in        2010-11-08 13:31:03.199940471 -0500
+--- a/Makefile.in      2010-11-08 13:30:42.060916323 -0500
++++ b/Makefile.in      2010-11-08 13:31:03.199940471 -0500
 @@ -24,7 +24,7 @@
  server.o: server.c server.h net.h data.h hash.h cfg.h time.h math.h config.h error.h
  client.o: client.c data.h sprite.h cfg.h net.h hash.h time.h math.h console.h help.h blit.h config.h error.h
index a5ecaec0168480e2c98511a06b5093cf6af24cdd..d48b758c9e537591d7e10dcc7aae59c0a3542317 100644 (file)
@@ -1,5 +1,5 @@
---- sprite.c.orig      2007-11-15 18:26:30.000000000 -0500
-+++ sprite.c   2007-11-15 18:26:57.000000000 -0500
+--- a/sprite.c 2007-11-15 18:26:30.000000000 -0500
++++ b/sprite.c 2007-11-15 18:26:57.000000000 -0500
 @@ -2,6 +2,7 @@
  #include <ctype.h>
  #include <stdlib.h>
index ec9b7efb36e73592f349a4ee4a8c3c3cd735a6a7..63bfb5fa7a6a1d5a9865767582369170d7e46e16 100644 (file)
@@ -1,5 +1,5 @@
---- client.c.orig      2001-12-16 04:26:38.000000000 -0500
-+++ client.c   2003-11-17 15:12:52.850772508 -0500
+--- a/client.c 2001-12-16 04:26:38.000000000 -0500
++++ b/client.c 2003-11-17 15:12:52.850772508 -0500
 @@ -191,9 +191,9 @@
        unsigned char txt[256];
  
index 3df8a0789545019b7332ca26fca7d6ec3d2d5375..a8a832e19619b618347853ca58e767e0dc754924 100644 (file)
@@ -1,5 +1,5 @@
---- server.c.old       2010-11-08 11:53:18.000000000 +0100
-+++ server.c   2010-11-08 11:53:43.000000000 +0100
+--- a/server.c 2010-11-08 11:53:18.000000000 +0100
++++ b/server.c 2010-11-08 11:53:43.000000000 +0100
 @@ -905,8 +905,8 @@
        int len;
  
@@ -11,8 +11,8 @@
        send_chunk_packet_to_player(packet,len,player);
  }
  
---- console.c.old      2010-11-08 11:53:26.000000000 +0100
-+++ console.c  2010-11-08 11:54:44.000000000 +0100
+--- a/console.c        2010-11-08 11:53:26.000000000 +0100
++++ b/console.c        2010-11-08 11:54:44.000000000 +0100
 @@ -206,7 +206,7 @@
  void c_setcolor_3b(unsigned char a)
  {