net-libs/libsrtp: fix building with gcc-10
authorStephan Hartmann <stha09@googlemail.com>
Mon, 27 Jan 2020 09:19:51 +0000 (10:19 +0100)
committerMike Gilbert <floppym@gentoo.org>
Tue, 28 Jan 2020 14:09:28 +0000 (09:09 -0500)
Closes: https://bugs.gentoo.org/706608
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Stephan Hartmann <stha09@googlemail.com>
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Closes: https://github.com/gentoo/gentoo/pull/14470

net-libs/libsrtp/files/libsrtp-2.2.0-gcc-10.patch [new file with mode: 0644]
net-libs/libsrtp/libsrtp-2.2.0.ebuild

diff --git a/net-libs/libsrtp/files/libsrtp-2.2.0-gcc-10.patch b/net-libs/libsrtp/files/libsrtp-2.2.0-gcc-10.patch
new file mode 100644 (file)
index 0000000..771ae0f
--- /dev/null
@@ -0,0 +1,26 @@
+diff --git a/crypto/math/datatypes.c b/crypto/math/datatypes.c
+index c0dfece..ec2fe6d 100644
+--- a/crypto/math/datatypes.c
++++ b/crypto/math/datatypes.c
+@@ -79,7 +79,7 @@ int octet_get_weight(uint8_t octet)
+ /* the value MAX_PRINT_STRING_LEN is defined in datatypes.h */
+-char bit_string[MAX_PRINT_STRING_LEN];
++static char bit_string[MAX_PRINT_STRING_LEN];
+ uint8_t srtp_nibble_to_hex_char(uint8_t nibble)
+ {
+diff --git a/test/util.c b/test/util.c
+index eb203f4..04e149c 100644
+--- a/test/util.c
++++ b/test/util.c
+@@ -47,7 +47,7 @@
+ #include <string.h>
+ #include <stdint.h>
+-char bit_string[MAX_PRINT_STRING_LEN];
++static char bit_string[MAX_PRINT_STRING_LEN];
+ static inline int hex_char_to_nibble(uint8_t c)
+ {
index a6f4fc333d876f7045863090c00534fd59bf0c4f..1ee4065fcb39a4b0452847ff78d85c242020c2cf 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -25,7 +25,10 @@ DEPEND="${RDEPEND}"
 
 DOCS=( CHANGES )
 
-PATCHES=( "${FILESDIR}/${P}-pcap-automagic-r0.patch" )
+PATCHES=(
+       "${FILESDIR}/${P}-pcap-automagic-r0.patch"
+       "${FILESDIR}/${P}-gcc-10.patch"
+)
 
 src_prepare() {
        default