app-emulation/phpvirtualbox: Version bump to 5.2.1
authorBrian Evans <grknight@gentoo.org>
Wed, 23 Jan 2019 17:56:57 +0000 (12:56 -0500)
committerBrian Evans <grknight@gentoo.org>
Wed, 23 Jan 2019 18:02:30 +0000 (13:02 -0500)
Non-maintainer commit
Includes fixes and PHP 7.1 support

Closes: https://bugs.gentoo.org/651186
Package-Manager: Portage-2.3.58, Repoman-2.3.12
Signed-off-by: Brian Evans <grknight@gentoo.org>
app-emulation/phpvirtualbox/Manifest
app-emulation/phpvirtualbox/files/README.gentoo [new file with mode: 0644]
app-emulation/phpvirtualbox/phpvirtualbox-5.2.1.ebuild [new file with mode: 0644]

index ede7ee5154ad8ea2a55a077f3c4834fff1212570..c259166e99c22d5c2c939596722f3ba086acaa65 100644 (file)
@@ -2,3 +2,4 @@ DIST phpvirtualbox-4.2-7.zip 3425805 BLAKE2B c5e9bb629b346af378ee585b940c2f41cef
 DIST phpvirtualbox-4.3-0.zip 4231805 BLAKE2B 8f9c995c3c7112b6ec73a49b322f210ae2befcd711ac9459ea0eea9a7216c2e3322489ada69a91940af76a276a8c053384e0632b209250c7b3ca37291a574e57 SHA512 fd49a6a4c79d75f37fd40d74743f295a148548373ab046cf1f31ef7b982008ea6b9d2838cdad2dc37a1d266ed630cd2ddb7f7423ea62af1e0f8f9f76a12c0e9d
 DIST phpvirtualbox-5.0-3.zip 4092132 BLAKE2B c781b9d49ed20fb2748a7aa7d8685d5f2c10ba72268e6bbdb53a041873c6390605376a09bc4a7cfd5cca3de9d3045c60a2e515668ba1d5f49b623aee9e5cf568 SHA512 b632ff3be2028bd011ce27b580996638dfc89e09350c459f16bd1c8c5c3eefbab93f42d7facfb99279eb2ee1c6a38854ea999654ca2090a39c7bfa0afa7fe2d5
 DIST phpvirtualbox-5.0-5.zip 4093766 BLAKE2B 77c453a2d43558ae3db23c3b2b20d08b713731c5444c7613a2018edef77774e97d8dc25345606520df10df7802d86efedf38d73670ec0dacb48606e4785ed0cd SHA512 5478e4a5eb74786eb409a87e7c962c80df558655342f541dddceb7e4cf153a4e5f0bda9b83c2a8a921326f6210c2c3bd344c4a9ce30547f25acce5966c4d6135
+DIST phpvirtualbox-5.2-1.tar.gz 3882921 BLAKE2B 6eb76d3f4372bbd83648f4c1b1f37ec7478a1818e7dcef345bddf603d9ae51314f6fd0a448b42d7434389a364e4c8e177f4b13936f50c6c30a58e00aa0b714e7 SHA512 6805f58a3abdfdac9bb34170d3980ba3fae1118526bbb587b67a55032cc2c25923bf2d7bec01ed60439b3070f2e0668079f73e41ca29d18dd9e24abe3219830c
diff --git a/app-emulation/phpvirtualbox/files/README.gentoo b/app-emulation/phpvirtualbox/files/README.gentoo
new file mode 100644 (file)
index 0000000..45699ef
--- /dev/null
@@ -0,0 +1,16 @@
+Local or remote virtualbox hosts must be compiled with
+'vboxwebsrv' useflag and the respective init script
+must be running to use this interface:
+/etc/init.d/vboxwebsrv start
+
+To enable the automatic startup mode feature uncomment the
+following line in the config.php file:
+var $startStopConfig = true;
+
+You should also add the /etc/init.d/vboxinit-@@SLOT@@ script to the
+default runlevel on the virtualbox host:
+`rc-update add vboxinit-@@SLOT@@ default`
+If the server is on a remote host, than the script must be
+copied manually from
+@@FILESDIR@@/vboxinit-initd to
+/etc/init.d/vboxinit on the remote host.
diff --git a/app-emulation/phpvirtualbox/phpvirtualbox-5.2.1.ebuild b/app-emulation/phpvirtualbox/phpvirtualbox-5.2.1.ebuild
new file mode 100644 (file)
index 0000000..4738dfe
--- /dev/null
@@ -0,0 +1,57 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eapi7-ver webapp readme.gentoo-r1
+
+MY_PV="$(ver_rs 2 '-')"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="Web-based administration for VirtualBox in PHP"
+HOMEPAGE="https://sourceforge.net/projects/phpvirtualbox/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${MY_PV}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+       dev-lang/php:*[gd,session,soap,unicode]
+       virtual/httpd-php:*
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+
+       local DISABLE_AUTOFORMATTING="true"
+       local DOC_CONTENTS=$(sed -e "s;@@FILESDIR@@;${FILESDIR};" \
+                                -e "s;@@SLOT@@;${SLOT};" "${FILESDIR}/README.gentoo")
+
+       webapp_src_preinst
+
+       dodoc CHANGELOG.txt README.md
+       rm -f CHANGELOG.txt LICENSE.txt README.md
+
+       insinto "${MY_HTDOCSDIR}"
+       doins -r .
+
+       webapp_configfile "${MY_HTDOCSDIR}"/config.php-example
+       webapp_serverowned "${MY_HTDOCSDIR}"/config.php-example
+
+       webapp_src_install
+       if has_version app-emulation/virtualbox[vboxwebsrv] || \
+               has_version app-emulation/virtualbox-bin[vboxwebsrv]
+       then
+               newinitd "${FILESDIR}"/vboxinit-initd vboxinit-${SLOT}
+       fi
+
+       readme.gentoo_create_doc
+
+}
+
+pkg_postinst() {
+       webapp_pkg_postinst
+       readme.gentoo_print_elog
+}