dev-util/lldb: Switch to PYTHON_MULTI_USEDEP API
authorMichał Górny <mgorny@gentoo.org>
Fri, 7 Feb 2020 13:14:49 +0000 (14:14 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sun, 9 Feb 2020 16:21:43 +0000 (17:21 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-util/lldb/lldb-10.0.0.9999.ebuild
dev-util/lldb/lldb-10.0.0_rc1.ebuild
dev-util/lldb/lldb-11.0.0.9999.ebuild
dev-util/lldb/lldb-7.1.0-r1.ebuild [moved from dev-util/lldb/lldb-7.1.0.ebuild with 92% similarity]
dev-util/lldb/lldb-8.0.1-r1.ebuild [moved from dev-util/lldb/lldb-8.0.1.ebuild with 92% similarity]
dev-util/lldb/lldb-9.0.1-r1.ebuild [moved from dev-util/lldb/lldb-9.0.1.ebuild with 92% similarity]

index 332d07439b76dcfb7f40724e74c9335b8d5d6f7b..33100fdcdcc41b3ee2644f300b6929e5156b0435 100644 (file)
@@ -24,8 +24,12 @@ RDEPEND="
        libedit? ( dev-libs/libedit:0= )
        lzma? ( app-arch/xz-utils:= )
        ncurses? ( >=sys-libs/ncurses-5.9-r3:0= )
-       python? ( dev-python/six[${PYTHON_USEDEP}]
-               ${PYTHON_DEPS} )
+       python? (
+               $(python_gen_cond_dep '
+                       dev-python/six[${PYTHON_MULTI_USEDEP}]
+               ')
+               ${PYTHON_DEPS}
+       )
        ~sys-devel/clang-${PV}[xml]
        ~sys-devel/llvm-${PV}
        !<sys-devel/llvm-4.0"
@@ -33,7 +37,9 @@ DEPEND="${RDEPEND}"
 BDEPEND="
        python? ( >=dev-lang/swig-3.0.11 )
        test? (
-               ~dev-python/lit-${PV}[${PYTHON_USEDEP}]
+               $(python_gen_cond_dep "
+                       ~dev-python/lit-${PV}[\${PYTHON_MULTI_USEDEP}]
+               ")
                sys-devel/lld )
        ${PYTHON_DEPS}"
 
index 332d07439b76dcfb7f40724e74c9335b8d5d6f7b..33100fdcdcc41b3ee2644f300b6929e5156b0435 100644 (file)
@@ -24,8 +24,12 @@ RDEPEND="
        libedit? ( dev-libs/libedit:0= )
        lzma? ( app-arch/xz-utils:= )
        ncurses? ( >=sys-libs/ncurses-5.9-r3:0= )
-       python? ( dev-python/six[${PYTHON_USEDEP}]
-               ${PYTHON_DEPS} )
+       python? (
+               $(python_gen_cond_dep '
+                       dev-python/six[${PYTHON_MULTI_USEDEP}]
+               ')
+               ${PYTHON_DEPS}
+       )
        ~sys-devel/clang-${PV}[xml]
        ~sys-devel/llvm-${PV}
        !<sys-devel/llvm-4.0"
@@ -33,7 +37,9 @@ DEPEND="${RDEPEND}"
 BDEPEND="
        python? ( >=dev-lang/swig-3.0.11 )
        test? (
-               ~dev-python/lit-${PV}[${PYTHON_USEDEP}]
+               $(python_gen_cond_dep "
+                       ~dev-python/lit-${PV}[\${PYTHON_MULTI_USEDEP}]
+               ")
                sys-devel/lld )
        ${PYTHON_DEPS}"
 
index 332d07439b76dcfb7f40724e74c9335b8d5d6f7b..33100fdcdcc41b3ee2644f300b6929e5156b0435 100644 (file)
@@ -24,8 +24,12 @@ RDEPEND="
        libedit? ( dev-libs/libedit:0= )
        lzma? ( app-arch/xz-utils:= )
        ncurses? ( >=sys-libs/ncurses-5.9-r3:0= )
-       python? ( dev-python/six[${PYTHON_USEDEP}]
-               ${PYTHON_DEPS} )
+       python? (
+               $(python_gen_cond_dep '
+                       dev-python/six[${PYTHON_MULTI_USEDEP}]
+               ')
+               ${PYTHON_DEPS}
+       )
        ~sys-devel/clang-${PV}[xml]
        ~sys-devel/llvm-${PV}
        !<sys-devel/llvm-4.0"
@@ -33,7 +37,9 @@ DEPEND="${RDEPEND}"
 BDEPEND="
        python? ( >=dev-lang/swig-3.0.11 )
        test? (
-               ~dev-python/lit-${PV}[${PYTHON_USEDEP}]
+               $(python_gen_cond_dep "
+                       ~dev-python/lit-${PV}[\${PYTHON_MULTI_USEDEP}]
+               ")
                sys-devel/lld )
        ${PYTHON_DEPS}"
 
similarity index 92%
rename from dev-util/lldb/lldb-7.1.0.ebuild
rename to dev-util/lldb/lldb-7.1.0-r1.ebuild
index a2c3d26a6531dc0eb3a2658b5b2a7fe1d7d56766..a1d46a8630975cb2f6626bffb77e725538ce602b 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -30,14 +30,22 @@ RESTRICT="test"
 RDEPEND="
        libedit? ( dev-libs/libedit:0= )
        ncurses? ( >=sys-libs/ncurses-5.9-r3:0= )
-       python? ( dev-python/six[${PYTHON_USEDEP}]
-               ${PYTHON_DEPS} )
+       python? (
+               $(python_gen_cond_dep '
+                       dev-python/six[${PYTHON_MULTI_USEDEP}]
+               ')
+               ${PYTHON_DEPS}
+       )
        ~sys-devel/clang-${PV}[xml]
        ~sys-devel/llvm-${PV}
        !<sys-devel/llvm-4.0"
 DEPEND="${RDEPEND}
        python? ( >=dev-lang/swig-3.0.11 )
-       test? ( ~dev-python/lit-${PV}[${PYTHON_USEDEP}] )
+       test? (
+               $(python_gen_cond_dep "
+                       ~dev-python/lit-${PV}[\${PYTHON_MULTI_USEDEP}]
+               ")
+       )
        ${PYTHON_DEPS}"
 
 REQUIRED_USE=${PYTHON_REQUIRED_USE}
similarity index 92%
rename from dev-util/lldb/lldb-8.0.1.ebuild
rename to dev-util/lldb/lldb-8.0.1-r1.ebuild
index 2adb8cdb9ad3f5c0089ebeb044af6e8ab481dced..fa7d98390e6ec9ebf6189aebe4619e951355889c 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -28,14 +28,22 @@ RESTRICT="!test? ( test )"
 RDEPEND="
        libedit? ( dev-libs/libedit:0= )
        ncurses? ( >=sys-libs/ncurses-5.9-r3:0= )
-       python? ( dev-python/six[${PYTHON_USEDEP}]
-               ${PYTHON_DEPS} )
+       python? (
+               $(python_gen_cond_dep '
+                       dev-python/six[${PYTHON_MULTI_USEDEP}]
+               ')
+               ${PYTHON_DEPS}
+       )
        ~sys-devel/clang-${PV}[xml]
        ~sys-devel/llvm-${PV}
        !<sys-devel/llvm-4.0"
 DEPEND="${RDEPEND}
        python? ( >=dev-lang/swig-3.0.11 )
-       test? ( ~dev-python/lit-${PV}[${PYTHON_USEDEP}] )
+       test? (
+               $(python_gen_cond_dep "
+                       ~dev-python/lit-${PV}[\${PYTHON_MULTI_USEDEP}]
+               ")
+       )
        ${PYTHON_DEPS}"
 
 REQUIRED_USE=${PYTHON_REQUIRED_USE}
similarity index 92%
rename from dev-util/lldb/lldb-9.0.1.ebuild
rename to dev-util/lldb/lldb-9.0.1-r1.ebuild
index 20d744e17b96a748732baae5a5b6daf671aa952a..2afd2452347eba8338f4e7252feabf67c9ef58b1 100644 (file)
@@ -23,8 +23,12 @@ RESTRICT="!test? ( test )"
 RDEPEND="
        libedit? ( dev-libs/libedit:0= )
        ncurses? ( >=sys-libs/ncurses-5.9-r3:0= )
-       python? ( dev-python/six[${PYTHON_USEDEP}]
-               ${PYTHON_DEPS} )
+       python? (
+               $(python_gen_cond_dep '
+                       dev-python/six[${PYTHON_MULTI_USEDEP}]
+               ')
+               ${PYTHON_DEPS}
+       )
        ~sys-devel/clang-${PV}[xml]
        ~sys-devel/llvm-${PV}
        !<sys-devel/llvm-4.0"
@@ -32,7 +36,9 @@ DEPEND="${RDEPEND}"
 BDEPEND="
        python? ( >=dev-lang/swig-3.0.11 )
        test? (
-               ~dev-python/lit-${PV}[${PYTHON_USEDEP}]
+               $(python_gen_cond_dep "
+                       ~dev-python/lit-${PV}[\${PYTHON_MULTI_USEDEP}]
+               ")
                sys-devel/lld )
        ${PYTHON_DEPS}"