games-sports/torcs: Fix building with GCC-7
authorPeter Levine <plevine457@gmail.com>
Sat, 31 Mar 2018 00:25:35 +0000 (20:25 -0400)
committerAndreas Sturmlechner <asturm@gentoo.org>
Wed, 4 Apr 2018 21:33:40 +0000 (23:33 +0200)
Closes: https://bugs.gentoo.org/631542
Package-Manager: Portage-2.3.16, Repoman-2.3.6
Closes: https://github.com/gentoo/gentoo/pull/7728

games-sports/torcs/files/torcs-1.3.6-gcc7.patch [new file with mode: 0644]
games-sports/torcs/torcs-1.3.6-r1.ebuild

diff --git a/games-sports/torcs/files/torcs-1.3.6-gcc7.patch b/games-sports/torcs/files/torcs-1.3.6-gcc7.patch
new file mode 100644 (file)
index 0000000..af139ad
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/src/libs/musicplayer/OpenALMusicPlayer.cpp
++++ b/src/libs/musicplayer/OpenALMusicPlayer.cpp
+@@ -161,7 +161,7 @@
+ {
+       char pcm[BUFFERSIZE];
+       int size = 0;
+-      const char* error = '\0';
++      const char* error = "";
+       
+       if (!stream->read(pcm, BUFFERSIZE, &size, &error)) {
+               GfError("OpenALMusicPlayer: Stream read error: %s\n", error);
index c92083f6cbc03a22366c78ccda53453c5db477e3..6b7ba9ad57851e251d61406e25c1528779940c21 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -34,6 +34,7 @@ PATCHES=(
        "${FILESDIR}"/${P}-format.patch
        "${FILESDIR}"/${P}-noXmuXt.patch
        "${FILESDIR}"/${P}-gcc6.patch
+       "${FILESDIR}"/${P}-gcc7.patch
 )
 
 src_prepare() {