net-misc/dhcp: Fix build with gcc-10
authorLars Wendler <polynomial-c@gentoo.org>
Tue, 21 Apr 2020 09:28:39 +0000 (11:28 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Tue, 21 Apr 2020 09:28:48 +0000 (11:28 +0200)
Bug: https://bugs.gentoo.org/710194
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
net-misc/dhcp/dhcp-4.4.2-r2.ebuild
net-misc/dhcp/files/dhcp-4.4.2-fno-common.patch [new file with mode: 0644]

index 650a485d9d6f75841c142a39823d1a3d20913e10..8adf530720e38e27065d6836de773f0551bb21e0 100644 (file)
@@ -67,6 +67,9 @@ PATCHES=(
        "${FILESDIR}/${PN}-4.3.6-iproute2-path.patch" #480636
        "${FILESDIR}/${PN}-4.2.5-bindtodevice-inet6.patch" #471142
        "${FILESDIR}/${PN}-4.3.3-ldap-ipv6-client-id.patch" #559832
+
+       # Possible upstream candidates
+       "${FILESDIR}/${PN}-4.4.2-fno-common.patch" #710194
 )
 
 src_prepare() {
diff --git a/net-misc/dhcp/files/dhcp-4.4.2-fno-common.patch b/net-misc/dhcp/files/dhcp-4.4.2-fno-common.patch
new file mode 100644 (file)
index 0000000..5d0b7bd
--- /dev/null
@@ -0,0 +1,34 @@
+--- a/client/dhclient.c
++++ b/client/dhclient.c
+@@ -83,8 +83,6 @@
+ static const char url [] = "For info, please visit https://www.isc.org/software/dhcp/";
+ #endif /* UNIT_TEST */
+-u_int16_t local_port = 0;
+-u_int16_t remote_port = 0;
+ #if defined(DHCPv6) && defined(DHCP4o6)
+ int dhcp4o6_state = -1; /* -1 = stopped, 0 = polling, 1 = started */
+ #endif
+--- a/relay/dhcrelay.c
++++ b/relay/dhcrelay.c
+@@ -95,9 +95,6 @@
+        forward_untouched,     /* Forward without changes. */
+        discard } agent_relay_mode = forward_and_replace;
+-u_int16_t local_port;
+-u_int16_t remote_port;
+-
+ /* Relay agent server list. */
+ struct server_list {
+       struct server_list *next;
+--- a/server/mdb.c
++++ b/server/mdb.c
+@@ -67,8 +67,6 @@
+ int numclasseswritten;
+-omapi_object_type_t *dhcp_type_host;
+-
+ isc_result_t enter_class(cd, dynamicp, commit)
+       struct class *cd;
+       int dynamicp;