net-vpn/openvpn: Version 2.4.5.
authorJeroen Roovers <jer@gentoo.org>
Sat, 10 Mar 2018 11:43:56 +0000 (12:43 +0100)
committerJeroen Roovers <jer@gentoo.org>
Sat, 10 Mar 2018 11:46:11 +0000 (12:46 +0100)
Package-Manager: Portage-2.3.24, Repoman-2.3.6

net-vpn/openvpn/Manifest
net-vpn/openvpn/openvpn-2.4.5.ebuild [new file with mode: 0644]

index 5bf231075b85f20910074b5279543f78cb9156bf..19826301dce6c868068126f9f317ec1829084aad 100644 (file)
@@ -1,3 +1,4 @@
 DIST mock_msg.h 1356 BLAKE2B da7585cfeee89c0a4d3aa6326de6e2324804ed2a57a0e8bf7c2e51b25a91a8e1fcf9d29bba90fe58e40bf0197793a76fc1e83d8b6d677228cdc5e5333253b1a3 SHA512 930775a5837bc7f97a26817ea028782d555e0e71ba06b04c39941f4c01bbc3ca0a5dc63bcf19dc694e0e746b3a382f22daf6a6373a3443c5afd7398cbaaef6ea
 DIST openvpn-2.4.3.tar.gz 1422692 BLAKE2B 0058689b94de8ad651b20ed7f8aa2924ea8c114ba3f7efa70ff3dd29908fa5ca25d9e97cc4168750b0fe26bd982ccbbed80dc1c680a2814cf036deb5083b33c8 SHA512 1d1f9afa6d0858fa32f73b2a51ed7652beac52ef974b104b51b521e6d8e872b8f5659c55ec1ef442fed3b6c6b058627b0af73e765a1261871b1cd96c8acd657e
 DIST openvpn-2.4.4.tar.gz 1390194 BLAKE2B 52aa5b9d301b4b5a14acf685f4d4c520d5ec1aa06755262a8504a4c3bb5ee1b8435f68eb4278f25b900f9ae182f31688ef36e4e839ec7a211ad6aba0f76a897a SHA512 3c3cb77397569e21c5af52b065b081714ce53e2dd0b890c881de8e57220dc23d97cd61eaf5a6bf8e5e89186414c4c93da22a3ab65f4b61f80b04d862b4116e76
+DIST openvpn-2.4.5.tar.gz 1430930 BLAKE2B 3ff1324b18fdc24109085a4958401e6d5636b5dc47d30e21392c17410625215bb20473409410ed74995a1b4bb2650ed62217b64b9184805a15ac1ff64a7a8a73 SHA512 a2e3e23bb5374e26d5af393f75686af1962980838c46aee062bc65cc9ffb6f1d20c2c261d1f9abae56ff84a5d22da4a5edb21e39943b33f4a205f809190383c6
diff --git a/net-vpn/openvpn/openvpn-2.4.5.ebuild b/net-vpn/openvpn/openvpn-2.4.5.ebuild
new file mode 100644 (file)
index 0000000..7143fb1
--- /dev/null
@@ -0,0 +1,162 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools flag-o-matic user systemd linux-info
+
+DESCRIPTION="Robust and highly flexible tunneling application compatible with many OSes"
+SRC_URI="http://swupdate.openvpn.net/community/releases/${P}.tar.gz
+       test? ( https://raw.githubusercontent.com/OpenVPN/${PN}/v${PV}/tests/unit_tests/${PN}/mock_msg.h )"
+HOMEPAGE="http://openvpn.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~x86-macos"
+
+IUSE="down-root examples inotify iproute2 libressl lz4 +lzo mbedtls pam"
+IUSE+=" pkcs11 +plugins selinux +ssl static systemd test userland_BSD"
+
+REQUIRED_USE="static? ( !plugins !pkcs11 )
+       mbedtls? ( ssl !libressl )
+       pkcs11? ( ssl )
+       !plugins? ( !pam !down-root )
+       inotify? ( plugins )"
+
+CDEPEND="
+       kernel_linux? (
+               iproute2? ( sys-apps/iproute2[-minimal] )
+               !iproute2? ( >=sys-apps/net-tools-1.60_p20160215155418 )
+       )
+       pam? ( virtual/pam )
+       ssl? (
+               !mbedtls? (
+                       !libressl? ( >=dev-libs/openssl-0.9.8:* )
+                       libressl? ( dev-libs/libressl )
+               )
+               mbedtls? ( net-libs/mbedtls )
+       )
+       lz4? ( app-arch/lz4 )
+       lzo? ( >=dev-libs/lzo-1.07 )
+       pkcs11? ( >=dev-libs/pkcs11-helper-1.11 )
+       systemd? ( sys-apps/systemd )"
+DEPEND="${CDEPEND}
+       test? ( dev-util/cmocka )"
+RDEPEND="${CDEPEND}
+       selinux? ( sec-policy/selinux-openvpn )"
+
+CONFIG_CHECK="~TUN"
+
+PATCHES=(
+       "${FILESDIR}/${PN}-external-cmocka.patch"
+)
+
+pkg_setup()  {
+       linux-info_pkg_setup
+}
+
+src_prepare() {
+       default
+       eautoreconf
+
+       if use test; then
+               cp "${DISTDIR}/mock_msg.h" tests/unit_tests/${PN} || die
+       fi
+}
+
+src_configure() {
+       use static && append-ldflags -Xcompiler -static
+       SYSTEMD_UNIT_DIR=$(systemd_get_systemunitdir) \
+       TMPFILES_DIR="/usr/lib/tmpfiles.d" \
+       IFCONFIG=/bin/ifconfig \
+       ROUTE=/bin/route \
+       econf \
+               $(usex mbedtls '--with-crypto-library=mbedtls' '') \
+               $(use_enable inotify async-push) \
+               $(use_enable ssl crypto) \
+               $(use_enable lz4) \
+               $(use_enable lzo) \
+               $(use_enable pkcs11) \
+               $(use_enable plugins) \
+               $(use_enable iproute2) \
+               $(use_enable pam plugin-auth-pam) \
+               $(use_enable down-root plugin-down-root) \
+               $(use_enable test tests) \
+               $(use_enable systemd)
+}
+
+src_test() {
+       make check || die "top-level tests failed"
+       pushd tests/unit_tests > /dev/null || die
+       make check || die "unit tests failed"
+       popd > /dev/null || die
+}
+
+src_install() {
+       default
+       find "${ED}/usr" -name '*.la' -delete
+       # install documentation
+       dodoc AUTHORS ChangeLog PORTS README README.IPv6
+
+       # Install some helper scripts
+       keepdir /etc/openvpn
+       exeinto /etc/openvpn
+       doexe "${FILESDIR}/up.sh"
+       doexe "${FILESDIR}/down.sh"
+
+       # Install the init script and config file
+       newinitd "${FILESDIR}/${PN}-2.1.init" openvpn
+       newconfd "${FILESDIR}/${PN}-2.1.conf" openvpn
+
+       # install examples, controlled by the respective useflag
+       if use examples ; then
+               # dodoc does not supportly support directory traversal, #15193
+               insinto /usr/share/doc/${PF}/examples
+               doins -r sample contrib
+       fi
+}
+
+pkg_postinst() {
+       # Add openvpn user so openvpn servers can drop privs
+       # Clients should run as root so they can change ip addresses,
+       # dns information and other such things.
+       enewgroup openvpn
+       enewuser openvpn "" "" "" openvpn
+
+       if path_exists -o "${EROOT%/}"/etc/openvpn/*/local.conf ; then
+               ewarn "WARNING: The openvpn init script has changed"
+               ewarn ""
+       fi
+
+       if use x64-macos; then
+               elog "You might want to install tuntaposx for TAP interface support:"
+               elog "http://tuntaposx.sourceforge.net"
+       fi
+
+       elog "The openvpn init script expects to find the configuration file"
+       elog "openvpn.conf in /etc/openvpn along with any extra files it may need."
+       elog ""
+       elog "To create more VPNs, simply create a new .conf file for it and"
+       elog "then create a symlink to the openvpn init script from a link called"
+       elog "openvpn.newconfname - like so"
+       elog "   cd /etc/openvpn"
+       elog "   ${EDITOR##*/} foo.conf"
+       elog "   cd /etc/init.d"
+       elog "   ln -s openvpn openvpn.foo"
+       elog ""
+       elog "You can then treat openvpn.foo as any other service, so you can"
+       elog "stop one vpn and start another if you need to."
+
+       if grep -Eq "^[ \t]*(up|down)[ \t].*" "${ROOT}/etc/openvpn"/*.conf 2>/dev/null ; then
+               ewarn ""
+               ewarn "WARNING: If you use the remote keyword then you are deemed to be"
+               ewarn "a client by our init script and as such we force up,down scripts."
+               ewarn "These scripts call /etc/openvpn/\$SVCNAME-{up,down}.sh where you"
+               ewarn "can move your scripts to."
+       fi
+
+       if use plugins ; then
+               einfo ""
+               einfo "plugins have been installed into /usr/$(get_libdir)/${PN}/plugins"
+       fi
+}