app-crypt/certbot-nginx: Version bump to 0.10.1
authorManuel Rüger <mrueg@gentoo.org>
Sun, 22 Jan 2017 16:17:56 +0000 (17:17 +0100)
committerManuel Rüger <mrueg@gentoo.org>
Sun, 22 Jan 2017 16:18:12 +0000 (17:18 +0100)
Package-Manager: portage-2.3.3

app-crypt/certbot-nginx/Manifest [new file with mode: 0644]
app-crypt/certbot-nginx/certbot-nginx-0.10.1.ebuild [new file with mode: 0644]

diff --git a/app-crypt/certbot-nginx/Manifest b/app-crypt/certbot-nginx/Manifest
new file mode 100644 (file)
index 0000000..1da3440
--- /dev/null
@@ -0,0 +1 @@
+DIST certbot-nginx-0.10.1.tar.gz 823669 SHA256 c91b5fddb50dfd46545c12c1e96d1bb5e2794652c11421a6f5d9dad2bbca4d52 SHA512 4e45280b9cb6db3f8dcecfbf0cf64c990ea58d8607ed1aea9853c7248f8830301cc8685126eeb0d0c2ef0e23298c9070b291110d733e72867967bc9506900702 WHIRLPOOL ae08a9236adf69915c4a141106aa104563b1298f9fd3a32491ed8c45fddc9f32243154ba5bde9af7a8b74a95a1d2b7d337e4cbcc37f35ba997a7a50eb2f15200
diff --git a/app-crypt/certbot-nginx/certbot-nginx-0.10.1.ebuild b/app-crypt/certbot-nginx/certbot-nginx-0.10.1.ebuild
new file mode 100644 (file)
index 0000000..babe1c8
--- /dev/null
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=(python2_7)
+
+if [[ ${PV} == 9999* ]]; then
+       EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+       inherit git-r3
+       S=${WORKDIR}/${P}/${PN}
+else
+       SRC_URI="https://github.com/${PN%-nginx}/${PN%-nginx}/archive/v${PV}.tar.gz -> ${PN%-ngin}-${PV}.tar.gz"
+       KEYWORDS="~amd64"
+       S=${WORKDIR}/${PN%-nginx}-${PV}/${PN}
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="Nginx plugin for certbot (Let's Encrypt Client)"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="test"
+
+CDEPEND=">=dev-python/setuptools-1.0[${PYTHON_USEDEP}]"
+RDEPEND="${CDEPEND}
+       ~app-crypt/certbot-${PV}[${PYTHON_USEDEP}]
+       ~app-crypt/acme-${PV}[${PYTHON_USEDEP}]
+       dev-python/mock[${PYTHON_USEDEP}]
+       dev-python/pyopenssl[${PYTHON_USEDEP}]
+       dev-python/pyparsing[${PYTHON_USEDEP}]
+       dev-python/zope-interface[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}"