dev-python/python-distutils-extra: Remove redundant versions
authorMichał Górny <mgorny@gentoo.org>
Sat, 28 Mar 2020 20:54:59 +0000 (21:54 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sat, 28 Mar 2020 21:10:58 +0000 (22:10 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/python-distutils-extra/Manifest
dev-python/python-distutils-extra/python-distutils-extra-2.38.ebuild [deleted file]
dev-python/python-distutils-extra/python-distutils-extra-2.39.ebuild [deleted file]
dev-python/python-distutils-extra/python-distutils-extra-2.42.ebuild [deleted file]

index e1bb79db7e37ce9551c004aa65162d7e366f8a23..5de44833a32a09307c58e33b9e5ccbc399760142 100644 (file)
@@ -1,3 +1 @@
-DIST python-distutils-extra-2.38.tar.gz 27748 BLAKE2B 5f47e27dc639a6259a812bd618d35c4bc0a39362f3b7bf1a2e35331dfbd06b6b16a3030e125a8f5869770324a8df6eb446a5855639ed1b83379297509ea48891 SHA512 bbaea59a8f251f354e6cf3799b67c12225095cc869c7c4e299e719ad7bcfd1292cff99f95ab25f04fb9c3e2432da5ea614ee76154781388c47960fdf2c90a3d7
-DIST python-distutils-extra-2.39.tar.gz 27389 BLAKE2B 06deca885aa283e0a52e38c89f71637573d45d73dfbace5a06b4bbfa04098a7fa4fde1c2891bde5cc5ed3a3a65e31d243feaa8465a4fddb4623435e7a47c902e SHA512 e3b4d1ed22767fb4c6dbbdccef960865b6fda01d18dc38cb8f9357c09c7eabb78466fce053e407a196eca257d07d57c5c1ef47f358a5979c7f22e4b11775124e
 DIST python-distutils-extra_2.42.tar.xz 37996 BLAKE2B dee4cc950bb34027b60dcf58e173bae502a7090062e3c2218fd2ec562d6350f5872ed5c0865b89f1463bd35be0f365f23e05bb0220f70a944181af40df42ee60 SHA512 ff0df0a25a29504bec89970dbbf24d0b618e9f2d5d07a037f67778b86c92e880eafee86dd102b4ada4f280abd3102de9f4a4e47dbc68c1eaaa05fb492cbbae29
diff --git a/dev-python/python-distutils-extra/python-distutils-extra-2.38.ebuild b/dev-python/python-distutils-extra/python-distutils-extra-2.38.ebuild
deleted file mode 100644 (file)
index 35c8e55..0000000
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="Gettext support, themed icons and scrollkeeper-based documentation in distutils"
-HOMEPAGE="https://launchpad.net/python-distutils-extra"
-SRC_URI="https://launchpad.net/python-distutils-extra/trunk/${PV}/+download/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-IUSE=""
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}"
-
-DOCS=( doc/{FAQ,README,setup.cfg.example,setup.py.example} )
-
-DISTUTILS_IN_SOURCE_BUILD=1
-
-python_prepare_all() {
-       # Disable broken tests.
-       sed \
-               -e "s/test_desktop/_&/" -e "s/test_po(/_&/" \
-               -e "s/test_policykit/_&/" -e "s/test_requires_provides/_&/" \
-               -i test/auto.py || die
-
-       distutils-r1_python_prepare_all
-}
-
-python_test() {
-       # 5 tests fail with disabled byte-compilation (they rely on exact
-       # output from python).
-       local -x PYTHONDONTWRITEBYTECODE
-       "${PYTHON}" test/auto.py || die "Tests fail with ${EPYTHON}"
-}
diff --git a/dev-python/python-distutils-extra/python-distutils-extra-2.39.ebuild b/dev-python/python-distutils-extra/python-distutils-extra-2.39.ebuild
deleted file mode 100644 (file)
index d361314..0000000
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_6} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Gettext support, themed icons and scrollkeeper-based documentation in distutils"
-HOMEPAGE="https://launchpad.net/python-distutils-extra"
-SRC_URI="https://launchpad.net/python-distutils-extra/trunk/${PV}/+download/${P}.tar.gz"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? (
-               dev-python/pytest[${PYTHON_USEDEP}]
-       )
-"
-
-DOCS=( doc/{README,FAQ} )
-
-python_prepare_all() {
-       # This line is run when the file is imported
-       # https://bugs.launchpad.net/python-distutils-extra/+bug/1657919
-       sed -i '/^unittest.main()$/d' test/auto.py || die
-
-       distutils-r1_python_prepare_all
-}
-
-python_test() {
-       # 5 tests fail with disabled byte-compilation (they rely on exact
-       # output from python).
-       # The other 4 are broken.
-       pytest -vv -k "not (test_pot_manual or test_pot_auto_explicit or \
-               test_pot_auto or test_modules or test_packages) and not \
-               (test_desktop or test_po or test_policykit or \
-               test_requires_provides)" test/auto.py || \
-               die "tests failed with ${EPYTHON}"
-}
-
-python_install_all() {
-       distutils-r1_python_install_all
-
-       docinto examples
-       dodoc doc/{setup.cfg.example,setup.py.example}
-       docompress -x /usr/share/doc/${PF}/examples
-}
diff --git a/dev-python/python-distutils-extra/python-distutils-extra-2.42.ebuild b/dev-python/python-distutils-extra/python-distutils-extra-2.42.ebuild
deleted file mode 100644 (file)
index d41bb49..0000000
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python{2_7,3_6,3_7} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Gettext support, themed icons and scrollkeeper-based documentation in distutils"
-HOMEPAGE="https://launchpad.net/python-distutils-extra"
-SRC_URI="mirror://ubuntu/pool/universe/p/${PN}/${PN}_${PV}.tar.xz"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-
-BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-
-DOCS=( doc/{README,FAQ} )
-
-python_prepare_all() {
-       # This line is run when the file is imported
-       # https://bugs.launchpad.net/python-distutils-extra/+bug/1657919
-       sed -i '/^unittest.main()$/d' test/auto.py || die
-
-       distutils-r1_python_prepare_all
-}
-
-python_test() {
-       # 5 tests fail with disabled byte-compilation (they rely on exact
-       # output from python).
-       # The other 4 are broken.
-       pytest -vv -k "not (test_pot_manual or test_pot_auto_explicit or \
-               test_pot_auto or test_modules or test_packages) and not \
-               (test_desktop or test_po or test_policykit or \
-               test_requires_provides)" test/auto.py || \
-               die "tests failed with ${EPYTHON}"
-}
-
-python_install_all() {
-       distutils-r1_python_install_all
-
-       docinto examples
-       dodoc doc/{setup.cfg.example,setup.py.example}
-       docompress -x /usr/share/doc/${PF}/examples
-}