Drop deprecated usage of DISTUTILS_NO_PARALLEL_BUILD
authorJustin Lecher <jlec@gentoo.org>
Thu, 22 Oct 2015 11:08:49 +0000 (13:08 +0200)
committerJustin Lecher <jlec@gentoo.org>
Thu, 22 Oct 2015 11:09:19 +0000 (13:09 +0200)
Signed-off-by: Justin Lecher <jlec@gentoo.org>
39 files changed:
dev-python/behave/behave-1.2.4.ebuild
dev-python/bokeh/bokeh-0.7.1.ebuild
dev-python/dogpile-cache/dogpile-cache-0.5.2.ebuild
dev-python/dogpile-cache/dogpile-cache-0.5.4.ebuild
dev-python/egenix-mx-base/egenix-mx-base-3.2.5.ebuild
dev-python/flask-testing/flask-testing-0.4.1.ebuild
dev-python/httpretty/httpretty-0.7.0.ebuild
dev-python/mamba/mamba-0.6.ebuild
dev-python/mamba/mamba-0.8.4.ebuild
dev-python/oslotest/oslotest-1.3.0.ebuild
dev-python/python-ldap/python-ldap-9999.ebuild
dev-python/rdflib/rdflib-3.2.3-r1.ebuild
dev-python/rdflib/rdflib-4.1.2.ebuild
dev-python/reportlab/reportlab-2.6.ebuild
dev-python/reportlab/reportlab-3.1.44-r1.ebuild
dev-python/requests-mock/requests-mock-0.5.1.ebuild
dev-python/requests-mock/requests-mock-0.6.0.ebuild
dev-python/sqlalchemy/sqlalchemy-0.7.10.ebuild
gnome-extra/zeitgeist-explorer/zeitgeist-explorer-0.2-r1.ebuild
media-radio/radiotray/radiotray-9999.ebuild
net-misc/polly/polly-0.93.11.ebuild
net-misc/polly/polly-0.93.12.ebuild
net-news/rawdog/rawdog-2.19.ebuild
net-news/rawdog/rawdog-2.20.ebuild
sci-libs/scikits_learn/scikits_learn-0.13.1.ebuild
sci-libs/scikits_learn/scikits_learn-0.14.1.ebuild
sci-libs/scikits_learn/scikits_learn-0.15.1.ebuild
sci-libs/scikits_learn/scikits_learn-0.15.2.ebuild
sys-cluster/neutron/neutron-2015.1.1-r1.ebuild
sys-cluster/neutron/neutron-2015.1.2.ebuild
sys-cluster/neutron/neutron-2015.1.9999.ebuild
sys-cluster/neutron/neutron-2015.2.9999.ebuild
sys-cluster/neutron/neutron-7.0.0.ebuild
sys-cluster/nova/nova-12.0.0.ebuild
sys-cluster/nova/nova-2015.1.1-r3.ebuild
sys-cluster/nova/nova-2015.1.2.ebuild
sys-cluster/nova/nova-2015.1.9999.ebuild
sys-cluster/nova/nova-2015.2.9999.ebuild
x11-terms/terminator/terminator-0.97-r1.ebuild

index 5fc06dfd8a60f0e8d61c271753759e0f300b4774..af692e7840f09e90c151b0dc5378abe1b3fd9aac 100644 (file)
@@ -40,8 +40,6 @@ python_compile_all() {
 python_test() {
        nosetests || die "nosetests failed under ${EPYTHON}"
 
-       local DISTUTILS_NO_PARALLEL_BUILD=TRUE
-
        rm -f "${HOME}"/.pydistutils.cfg || die "Couldn't remove pydistutils.cfg"
 
        distutils_install_for_testing
index 06993090ae636f2ba9de5db5d7dbe2a5e92b1079..cf10e0e50192bb7ac1263fb7f85d3438d6da6cd8 100644 (file)
@@ -60,8 +60,6 @@ DOCS=( CHANGELOG QUICKSTART.md README.md )
 
 PATCHES=( "${FILESDIR}"/${P}-setup.patch )
 
-DISTUTILS_NO_PARALLEL_BUILD=1
-
 python_prepare_all() {
        DOC_CONTENTS="websockets work only with python2_7"
 
index 280e6fe8bb4fc15a414fa1e1a7343d4f5eb2ae0a..dedf7eb4c4e2d48ee27e7c99d6c5f7b4f2560c2b 100644 (file)
@@ -23,8 +23,6 @@ DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
                                dev-python/nose[${PYTHON_USEDEP}]
                                >=dev-python/dogpile-core-0.4.1[${PYTHON_USEDEP}] )"
 
-# for testsuite
-DISTUTILS_NO_PARALLEL_BUILD=1
 # This time half the doc files are missing; Do you want them? toss a coin
 
 python_test() {
index ab2ca0440e340edb3ed5cb20ed64883248ff7c8a..bf9d347ffe7e016ef267fcd926ad6f0ec6381131 100644 (file)
@@ -24,8 +24,6 @@ DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
                                dev-python/mako[${PYTHON_USEDEP}]
                                >=dev-python/dogpile-core-0.4.1[${PYTHON_USEDEP}] )"
 
-# for testsuite
-DISTUTILS_NO_PARALLEL_BUILD=1
 # This time half the doc files are missing; Do you want them? toss a coin
 
 python_test() {
index 578b6883f78286ca96cba22f3b661b100acc305f..5585376451137ebd943295cc488d9eb5d33540e3 100644 (file)
@@ -19,7 +19,6 @@ IUSE=""
 # distutils.command.config writes to CWD, bug #450516
 # mxSetup.py is broken with --build-lib
 #DISTUTILS_IN_SOURCE_BUILD=1
-DISTUTILS_NO_PARALLEL_BUILD=1
 
 python_prepare_all() {
        # Don't install documentation in site-packages directories.
index 981b65aaca5832df226ee98c02ce8e386352dcb4..b2f393400eeba506cef511bde7738e48363b2ee5 100644 (file)
@@ -29,7 +29,6 @@ DEPEND="${RDEPEND}
        )"
 
 S="${WORKDIR}/${MY_P}"
-DISTUTILS_NO_PARALLEL_BUILD=1
 
 python_test() {
        nosetests || die "Testing failed with ${EPYTHON}"
index 0f0aef593dfd606c5dfe17006483f970e8d39422..bfa5322829f9fb04a71c33ee336691ca486245ee 100644 (file)
@@ -29,7 +29,6 @@ RDEPEND="dev-python/urllib3[${PYTHON_USEDEP}]
 # I believe we don't need unpackaged package markment
 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
        test? ( ${RDEPEND} )"
-DISTUTILS_NO_PARALLEL_BUILD=1
 
 PATCHES=( "${FILESDIR}"/${P}-deps.patch )
 
index bb85f66ee45925c6a7a89fe8ead2562a49cddd03..f48b226a70241167fd6cccbde412ad1e9c7e3862 100644 (file)
@@ -44,8 +44,6 @@ python_prepare_all() {
 }
 
 python_test() {
-       local DISTUTILS_NO_PARALLEL_BUILD=TRUE
-
        rm -f "${HOME}"/.pydistutils.cfg || die "Couldn't remove pydistutils.cfg"
 
        distutils_install_for_testing
index 72dd8a4455a919655572cef79420f16129dc2c6d..525c7fbabb9fc28691b9b9f96c8717700229bb15 100644 (file)
@@ -45,8 +45,6 @@ python_prepare_all() {
 }
 
 python_test() {
-       local DISTUTILS_NO_PARALLEL_BUILD=TRUE
-
        rm -f "${HOME}"/.pydistutils.cfg || die "Couldn't remove pydistutils.cfg"
 
        distutils_install_for_testing
index 7c26156ec7fc458a7432d8ecabfd685c3b2a38ca..31caf8acb008d3c54616ac6094740942deeb6711 100644 (file)
@@ -52,8 +52,6 @@ python_compile_all() {
 }
 
 python_test() {
-       local DISTUTILS_NO_PARALLEL_BUILD=TRUE
-
        rm -rf .testrepository || die "coudln't remove '.testrepository' under ${EPYTHON}"
 
        testr init || die "testr init failed under ${EPYTHON}"
index 78856a7c547841ac85ab761bc1f01959019aae17..7aef3ea99882d88a3270169c844bad0f0cdea037 100644 (file)
@@ -7,7 +7,6 @@ EAPI=5
 # pypy: bug #458558 (wrong linker options due to not respecting CC)
 PYTHON_COMPAT=( python2_7 )
 DISTUTILS_IN_SOURCE_BUILD=1
-DISTUTILS_NO_PARALLEL_BUILD=1
 
 inherit distutils-r1 git-2 multilib
 
index d5c7fc80340aa08e49fba43e01ba720654e98811..1a4e73004f53860272acea3a832caee098826d03 100644 (file)
@@ -6,7 +6,6 @@ EAPI=5
 
 PYTHON_COMPAT=( python{2_7,3_3} )
 PYTHON_REQ_USE="sqlite?"
-DISTUTILS_NO_PARALLEL_BUILD=true
 
 inherit distutils-r1
 
index 594989ce49ed863651d6ea91439bbf852a386406..1a24551a2c4bf3bbd0bfd9ea0331d3bd5c9bbaca 100644 (file)
@@ -6,7 +6,6 @@ EAPI=5
 
 PYTHON_COMPAT=( python{2_7,3_3,3_4} )
 PYTHON_REQ_USE="sqlite?"
-DISTUTILS_NO_PARALLEL_BUILD=true
 # The usual required for tests
 DISTUTILS_IN_SOURCE_BUILD=1
 
index a08bbb62ae8284002f5bcf1c5dc5c54ad1742240..1606664c3ebe09824f29e7903ae6df2ef8dc502c 100644 (file)
@@ -25,8 +25,6 @@ RDEPEND="virtual/python-imaging
 DEPEND="${RDEPEND}
        app-arch/unzip"
 
-DISTUTILS_NO_PARALLEL_BUILD=1
-
 src_unpack() {
        unpack ${P}.tar.gz
        cd ${P}/src/reportlab/fonts || die
index ab1363217e91fa0493368afda4118b36c55e8497..4028999f391b32de54633e67cdd38fb31374e286 100644 (file)
@@ -32,8 +32,6 @@ DEPEND="${RDEPEND}
        app-arch/unzip
 "
 
-DISTUTILS_NO_PARALLEL_BUILD=1
-
 src_unpack() {
        unpack ${P}.tar.gz
        cd ${P}/src/reportlab/fonts || die
index dd11a40202df5baa21bde8c2a8a90803c54a2e34..f4f89c81e48e45542377787cd4ff852fe6912adb 100644 (file)
@@ -32,8 +32,6 @@ RDEPEND="
 "
 
 python_test() {
-       local DISTUTILS_NO_PARALLEL_BUILD=TRUE
-
        rm -rf .testrepository || die "couldn't remove '.testrepository' under ${EPYTHON}"
 
        testr init || die "testr init failed under ${EPYTHON}"
index 93b1c01cefb30cff2f81ac978b304be2c9e3f25a..b00b333a6d76272fa298eb077db818cf7b9e84ae 100644 (file)
@@ -33,8 +33,6 @@ RDEPEND="
 "
 
 python_test() {
-       local DISTUTILS_NO_PARALLEL_BUILD=TRUE
-
        rm -rf .testrepository || die "couldn't remove '.testrepository' under ${EPYTHON}"
 
        testr init || die "testr init failed under ${EPYTHON}"
index 3a8ad7e160d7ebe482239d97030d87d78d89e075..282cce2e3d51a1500141aa26e3e4a5dcc5b2751a 100644 (file)
@@ -33,8 +33,6 @@ DEPEND="${RDEPEND}
                >=dev-python/nose-0.10.4[${PYTHON_USEDEP}]
        )"
 
-# py26 tests needs
-DISTUTILS_NO_PARALLEL_BUILD=1
 S="${WORKDIR}/${MY_P}"
 
 PATCHES=( "${FILESDIR}/${PN}-0.7-logging.handlers.patch" )
index fd5b53f880205e8bdda152f595b3eecee07593a2..f7e7554b23648ca54c46f1ae279b48cd29018522 100644 (file)
@@ -25,5 +25,3 @@ RDEPEND="
        x11-libs/gtk+:3[introspection]"
 DEPEND="${RDEPEND}
        dev-python/python-distutils-extra[${PYTHON_USEDEP}]"
-
-DISTUTILS_NO_PARALLEL_BUILD=true
index 96553be270c1132eb4b5b516f7ab44f6842c52ff..f0f87bc0e103593734cffddea128812a55bd9e72 100644 (file)
@@ -5,8 +5,6 @@
 EAPI=5
 PYTHON_COMPAT=( python2_7 )
 
-DISTUTILS_NO_PARALLEL_BUILD=1
-
 inherit distutils-r1 mercurial
 
 DESCRIPTION="Online radio streaming player"
index 7c0089c7f218bedc587121a213e9046597116204..b725ca40bb583e927afd0d05b429cbc17a4cee21 100644 (file)
@@ -6,7 +6,6 @@ EAPI=5
 
 PYTHON_COMPAT=( python2_7 )
 PYTHON_REQ_USE=( gdbm )
-DISTUTILS_NO_PARALLEL_BUILD=1
 
 inherit distutils-r1 gnome2-utils vcs-snapshot
 
index 13fbe9e6aa92b8a9f67153d94e634c879a34cda3..804022a13ac3c717f34df4cf211820f03b770638 100644 (file)
@@ -6,7 +6,6 @@ EAPI=5
 
 PYTHON_COMPAT=( python2_7 )
 PYTHON_REQ_USE=( gdbm )
-DISTUTILS_NO_PARALLEL_BUILD=1
 
 inherit distutils-r1 gnome2-utils vcs-snapshot
 
index 1942f76538768f47d2ba55c48b1d235da4324edf..84c69bc7a5606943f928ecb34071d27cde0c04ee 100644 (file)
@@ -18,8 +18,6 @@ IUSE=""
 
 DEPEND="dev-python/feedparser[${PYTHON_USEDEP}]"
 RDEPEND=""
-# Test run fails under multi threading
-DISTUTILS_NO_PARALLEL_BUILD=1
 
 python_test() {
        # pypy fails half way through; meh
index ab66cbabc7d5db25965b8fd68ac683e3235a6183..a2bc717fff673f0dff820799172182f0a1bb1c81 100644 (file)
@@ -18,8 +18,6 @@ IUSE=""
 
 DEPEND="dev-python/feedparser[${PYTHON_USEDEP}]"
 RDEPEND=""
-# Test run fails under multi threading
-DISTUTILS_NO_PARALLEL_BUILD=1
 
 python_test() {
        # pypy fails half way through; meh
index 37782aa7557680b9775e226ff38f2490af4267ce..0554e1cf5db8a9764772c0d0211c8cbb5968f7c7 100644 (file)
@@ -5,7 +5,6 @@
 EAPI=5
 
 PYTHON_COMPAT=( python2_7 )
-DISTUTILS_NO_PARALLEL_BUILD=true
 
 inherit distutils-r1 multilib flag-o-matic
 
index d9eb124c96875251efc187a4b25260e21e27b2e9..0fc4c83bea1f203701b2afc66007b42e234aa40e 100644 (file)
@@ -5,7 +5,6 @@
 EAPI=5
 
 PYTHON_COMPAT=( python{2_7,3_3} )
-DISTUTILS_NO_PARALLEL_BUILD=true
 
 inherit distutils-r1 eutils multilib flag-o-matic
 
index e6c0f8bdd0468bb6822678d1c48d26441f102aec..76b1f1a2a8391e9551ade07dfe879e2dccab986d 100644 (file)
@@ -5,7 +5,6 @@
 EAPI=5
 
 PYTHON_COMPAT=( python{2_7,3_3,3_4} )
-DISTUTILS_NO_PARALLEL_BUILD=true
 
 inherit distutils-r1 eutils multilib flag-o-matic
 
index e6c0f8bdd0468bb6822678d1c48d26441f102aec..76b1f1a2a8391e9551ade07dfe879e2dccab986d 100644 (file)
@@ -5,7 +5,6 @@
 EAPI=5
 
 PYTHON_COMPAT=( python{2_7,3_3,3_4} )
-DISTUTILS_NO_PARALLEL_BUILD=true
 
 inherit distutils-r1 eutils multilib flag-o-matic
 
index bf60b1a63cb5df6b77d31d2a9582e2cbe5e6e410..aa3c007ca3cea780ef629e29134f52b677fb9ead 100644 (file)
@@ -169,8 +169,6 @@ python_test() {
        # https://bugs.launchpad.net/neutron/+bug/1234857
        # https://bugs.launchpad.net/swift/+bug/1249727
        # https://bugs.launchpad.net/neutron/+bug/1251657
-       # turn multiprocessing off, testr will use it --parallel
-       local DISTUTILS_NO_PARALLEL_BUILD=1
        # Move tests out that attempt net connection, have failures
        mv $(find . -name test_ovs_tunnel.py) . || die
        sed -e 's:test_app_using_ipv6_and_ssl:_&:' \
index 4df2cc23785399a5caf3e20aa94ba07c6a8f1c47..06847188c432747cddbc172e749970bba4c9d639 100644 (file)
@@ -169,8 +169,6 @@ python_test() {
        # https://bugs.launchpad.net/neutron/+bug/1234857
        # https://bugs.launchpad.net/swift/+bug/1249727
        # https://bugs.launchpad.net/neutron/+bug/1251657
-       # turn multiprocessing off, testr will use it --parallel
-       local DISTUTILS_NO_PARALLEL_BUILD=1
        # Move tests out that attempt net connection, have failures
        mv $(find . -name test_ovs_tunnel.py) . || die
        sed -e 's:test_app_using_ipv6_and_ssl:_&:' \
index 2e45923f2ae8f1062246116f230c271ba95cc874..85888ed14d85c98e62192109047e62f768e02f19 100644 (file)
@@ -170,8 +170,6 @@ python_test() {
        # https://bugs.launchpad.net/neutron/+bug/1234857
        # https://bugs.launchpad.net/swift/+bug/1249727
        # https://bugs.launchpad.net/neutron/+bug/1251657
-       # turn multiprocessing off, testr will use it --parallel
-       local DISTUTILS_NO_PARALLEL_BUILD=1
        # Move tests out that attempt net connection, have failures
        mv $(find . -name test_ovs_tunnel.py) . || die
        sed -e 's:test_app_using_ipv6_and_ssl:_&:' \
index 90b8455166ea8d489bca00bffbd776b00872756e..c5cca91bff02d97b54e31745655a932fdd2475fd 100644 (file)
@@ -203,8 +203,6 @@ python_test() {
        # https://bugs.launchpad.net/neutron/+bug/1234857
        # https://bugs.launchpad.net/swift/+bug/1249727
        # https://bugs.launchpad.net/neutron/+bug/1251657
-       # turn multiprocessing off, testr will use it --parallel
-       local DISTUTILS_NO_PARALLEL_BUILD=1
        # Move tests out that attempt net connection, have failures
        mv $(find . -name test_ovs_tunnel.py) . || die
        sed -e 's:test_app_using_ipv6_and_ssl:_&:' \
index b1f7a38bfa7bccc79a6f68c15c0025ca8989ef6b..68bd9abe6c5e905f07178834d00a2e97263871c1 100644 (file)
@@ -202,8 +202,6 @@ python_test() {
        # https://bugs.launchpad.net/neutron/+bug/1234857
        # https://bugs.launchpad.net/swift/+bug/1249727
        # https://bugs.launchpad.net/neutron/+bug/1251657
-       # turn multiprocessing off, testr will use it --parallel
-       local DISTUTILS_NO_PARALLEL_BUILD=1
        # Move tests out that attempt net connection, have failures
        mv $(find . -name test_ovs_tunnel.py) . || die
        sed -e 's:test_app_using_ipv6_and_ssl:_&:' \
index 5aec32f7cd1815642b5256c220577b905048f317..070facff76d8ed402c1317b51e50b6d520db32db 100644 (file)
@@ -230,8 +230,6 @@ python_prepare_all() {
 }
 
 python_test() {
-       # turn multiprocessing off, testr will use it --parallel
-       local DISTUTILS_NO_PARALLEL_BUILD=1
        testr init
        testr run --parallel || die "failed testsuite under python2.7"
 }
index e5f49c9db2e719d3891d88c0c2ea3eed45dabfba..71c40c861bd24ed03cf770206e02a9f0d3d64d47 100644 (file)
@@ -193,8 +193,6 @@ python_compile() {
 }
 
 python_test() {
-       # turn multiprocessing off, testr will use it --parallel
-       local DISTUTILS_NO_PARALLEL_BUILD=1
        testr init
        testr run --parallel || die "failed testsuite under python2.7"
 }
index ca2055030ed0aeb7fd1936978d854702f1de8ee2..a7c01895b6ebfa1c7c4cde06e400889030418953 100644 (file)
@@ -193,8 +193,6 @@ python_compile() {
 }
 
 python_test() {
-       # turn multiprocessing off, testr will use it --parallel
-       local DISTUTILS_NO_PARALLEL_BUILD=1
        testr init
        testr run --parallel || die "failed testsuite under python2.7"
 }
index 2ba0bf9daa34f862b924c68456dbba0ce166de6c..4ea159cc988444befb474eb0dbc8f1c88ab04970 100644 (file)
@@ -194,8 +194,6 @@ python_compile() {
 }
 
 python_test() {
-       # turn multiprocessing off, testr will use it --parallel
-       local DISTUTILS_NO_PARALLEL_BUILD=1
        testr init
        testr run --parallel || die "failed testsuite under python2.7"
 }
index ae955f707418de070c822f27c33d67378c30eb00..1d514cc3a88c82e0d5ad1d9198ca57f59ae98b72 100644 (file)
@@ -231,8 +231,6 @@ python_prepare_all() {
 }
 
 python_test() {
-       # turn multiprocessing off, testr will use it --parallel
-       local DISTUTILS_NO_PARALLEL_BUILD=1
        testr init
        testr run --parallel || die "failed testsuite under python2.7"
 }
index fd5aa782a27ef689515f9583866f673e1148d9cc..4ab7225899e3098fbb1d3ff9fd22bc116fcba996 100644 (file)
@@ -5,7 +5,6 @@
 EAPI=5
 
 PYTHON_COMPAT=( python2_7 )
-DISTUTILS_NO_PARALLEL_BUILD=true
 
 inherit gnome2 distutils-r1