mail-filter/opendkim: fix building against BerkeleyDB.
authorMichael Orlitzky <mjo@gentoo.org>
Fri, 14 Jun 2019 13:28:33 +0000 (09:28 -0400)
committerMichael Orlitzky <mjo@gentoo.org>
Fri, 14 Jun 2019 13:33:49 +0000 (09:33 -0400)
Our ebuild was doing something strange with USE=berkdb set, and as a
result, the ./configure script for OpenDKIM was not being passed the
correct location for the BerkeleyDB headers. This seems like a simple
fix; to set

  --with-db-incdir="$(db_includedir)"

in the ebuild. I've made that change in a new revision, and tested
that the OpenDKIM build system can pick up the right version of
BerkeleyDB:

  checking for BerkeleyDB db.h... /usr/include/db6.0

Seems to work.

Closes: https://bugs.gentoo.org/684958
Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Package-Manager: Portage-2.3.66, Repoman-2.3.11

mail-filter/opendkim/opendkim-2.10.3-r14.ebuild [moved from mail-filter/opendkim/opendkim-2.10.3-r13.ebuild with 99% similarity]

similarity index 99%
rename from mail-filter/opendkim/opendkim-2.10.3-r13.ebuild
rename to mail-filter/opendkim/opendkim-2.10.3-r14.ebuild
index 037a1b0f98cd4d05a5fa3a464f874bbc60316356..ff45f1dac4db35b6fbae79fb98bb37469df56620 100644 (file)
@@ -68,8 +68,7 @@ src_configure() {
        local myconf=()
        if use berkdb ; then
                myconf+=(
-                       $(db_includedir)
-                       --with-db-incdir=${myconf#-I}
+                       --with-db-incdir=$(db_includedir)
                        --enable-popauth
                        --enable-query_cache
                        --enable-stats