x11-libs/libxkbcommon: Version bump to 0.9.0
authorMatt Turner <mattst88@gentoo.org>
Sun, 20 Oct 2019 19:43:50 +0000 (12:43 -0700)
committerMatt Turner <mattst88@gentoo.org>
Sun, 20 Oct 2019 20:17:29 +0000 (13:17 -0700)
Signed-off-by: Matt Turner <mattst88@gentoo.org>
x11-libs/libxkbcommon/Manifest
x11-libs/libxkbcommon/libxkbcommon-0.9.0.ebuild [new file with mode: 0644]

index d673e2160f998f1307b5268b61b313ea20ed1bf5..74b4fa16dca0c0ceb08bba65e77866f797269508 100644 (file)
@@ -1 +1,2 @@
 DIST libxkbcommon-0.8.4.tar.xz 648592 BLAKE2B 6205ca08f1ccb6d85320428317e9d023e2f2a56dcaa77e34a9f9ea42bbf67c9ee27a3123dd8e880ead3fa92c4cd7718bde55a255c52f16fef8d33c395c2511a9 SHA512 dbd441d0d7d5ba4fb352d64d150d163d4cdcf8340059457c291dc1fc69d1606ff6589732cb41a7fcfe106af0192977b243d7d68c4d95b90ece7abb620df360e3
+DIST libxkbcommon-0.9.0.tar.xz 376160 BLAKE2B 9a349a7ce9dcd1e9475f4a3b2365c11e91dcf4833d53c99b7231c1a757a410b4e347f90c77013d2a3a2a724765c1f2187d8c1fe96ad4441d34772f62ec081620 SHA512 7e3b03f1fa5abca31574c02e8308be9d5a6e2bdd369e808faeaa62e63a3d3592158cc695df55828275fc10219d79e1915e4f7331f1967aed0c9c54025272e9c4
diff --git a/x11-libs/libxkbcommon/libxkbcommon-0.9.0.ebuild b/x11-libs/libxkbcommon/libxkbcommon-0.9.0.ebuild
new file mode 100644 (file)
index 0000000..8f50a19
--- /dev/null
@@ -0,0 +1,53 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} = *9999* ]]; then
+       GIT_ECLASS="git-r3"
+       EGIT_REPO_URI="https://github.com/xkbcommon/${PN}"
+else
+       SRC_URI="https://xkbcommon.org/download/${P}.tar.xz"
+       KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+fi
+
+inherit meson multilib-minimal ${GIT_ECLASS}
+
+DESCRIPTION="keymap handling library for toolkits and window systems"
+HOMEPAGE="https://xkbcommon.org/ https://github.com/xkbcommon/libxkbcommon/"
+IUSE="X doc test"
+SLOT="0"
+
+BDEPEND="
+       sys-devel/bison
+       doc? ( app-doc/doxygen )"
+RDEPEND="X? ( >=x11-libs/libxcb-1.10:=[${MULTILIB_USEDEP},xkb] )"
+DEPEND="${RDEPEND}
+       X? ( x11-base/xorg-proto )"
+
+src_unpack() {
+       default
+       [[ $PV = 9999* ]] && git-r3_src_unpack
+}
+
+multilib_src_configure() {
+       local emesonargs=(
+               -Dxkb-config-root="${EPREFIX}/usr/share/X11/xkb"
+               -Denable-wayland=false # Demo applications
+               $(meson_use X enable-x11)
+               $(meson_use doc enable-docs)
+       )
+       meson_src_configure
+}
+
+multilib_src_compile() {
+       meson_src_compile
+}
+
+multilib_src_test() {
+       meson_src_test
+}
+
+multilib_src_install() {
+       meson_src_install
+}