net-libs/loudmouth: add new revision 1.5.3-r3
authorAndrey Utkin <andrey_utkin@gentoo.org>
Mon, 28 Jan 2019 00:25:05 +0000 (00:25 +0000)
committerAndrey Utkin <andrey_utkin@gentoo.org>
Thu, 31 Jan 2019 10:38:37 +0000 (10:38 +0000)
Cloned from -r2 verbatim, for further changes.

Package-Manager: Portage-2.3.49, Repoman-2.3.12
Signed-off-by: Andrey Utkin <andrey_utkin@gentoo.org>
net-libs/loudmouth/loudmouth-1.5.3-r3.ebuild [new file with mode: 0644]

diff --git a/net-libs/loudmouth/loudmouth-1.5.3-r3.ebuild b/net-libs/loudmouth/loudmouth-1.5.3-r3.ebuild
new file mode 100644 (file)
index 0000000..f4cbcca
--- /dev/null
@@ -0,0 +1,60 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools
+
+DESCRIPTION="Lightweight C Jabber library"
+HOMEPAGE="https://github.com/mcabber/loudmouth"
+SRC_URI="https://github.com/mcabber/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~ppc-macos"
+
+IUSE="asyncns ssl openssl static-libs test"
+
+# Automagic libidn dependency
+RDEPEND="
+       >=dev-libs/glib-2.16:2
+       net-dns/libidn:=
+       ssl? (
+               !openssl? ( >=net-libs/gnutls-1.4.0:0= )
+               openssl? ( dev-libs/openssl:0= )
+       )
+       asyncns? ( >=net-libs/libasyncns-0.3 )
+"
+DEPEND="${RDEPEND}
+       dev-util/glib-utils
+       test? ( dev-libs/check )
+       virtual/pkgconfig
+"
+
+PATCHES=(
+       "${FILESDIR}"/${P}-gcc7.patch
+       "${FILESDIR}"/${P}-skip-gtk-doc.patch
+)
+
+src_prepare() {
+       default
+       eautoreconf
+}
+
+src_configure() {
+       local myconf
+
+       if use ssl; then
+               if ! use openssl; then
+                       myconf="${myconf} --with-ssl=gnutls"
+               else
+                       myconf="${myconf} --with-ssl=openssl"
+               fi
+       else
+               myconf="${myconf} --with-ssl=no"
+       fi
+
+       econf \
+               $(use_enable static-libs static) \
+               $(use_with asyncns) \
+               ${myconf}
+}