sys-libs/libunwind: drop old
authorSergei Trofimovich <slyfox@gentoo.org>
Sat, 2 May 2020 17:34:27 +0000 (18:34 +0100)
committerSergei Trofimovich <slyfox@gentoo.org>
Sat, 2 May 2020 17:51:20 +0000 (18:51 +0100)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
sys-libs/libunwind/Manifest
sys-libs/libunwind/libunwind-1.3.1.ebuild [deleted file]

index cbe3b9a89e6afb71c28d38b655db7805dd33ac11..db6eb99143fcda325948f724785d27817d3f53aa 100644 (file)
@@ -1,3 +1,2 @@
 DIST libunwind-1.2.1.tar.gz 780774 BLAKE2B a5be4142e1e4932231023bdec2ab3ecd6b707faf2d32d2b571239252a1d0fb6a273a6a46c4a107db63f74f7b54c0c54cf252b8b79ad53216333ba7bcf63147a1 SHA512 af7c280d2a963779a4a2711887618bc96383011e4e5d52e4085aa7fb351e55e357468f6ff85e66a216f1c6826538f498335a917a5970575c93be74c96316319b
-DIST libunwind-1.3.1.tar.gz 801262 BLAKE2B 4dfcd5e170ef0f7626aa966672f3302b4d8f231fcda37c72fbddb9ab913e82b45bb613b22c5ead8bbd5b09fa92bc0db1c32a744b11e40fd736c3a1412ad3d842 SHA512 3110d0aed4f5c781ef1ff72c9337e59793c02c42066209a4ac44f50eff1c0b0e02a5ff9f66891e62016de14af065a47975763970b839b700c0ff2e9f415c8def
 DIST libunwind-1.4.0.tar.gz 872941 BLAKE2B 39628dd46151d2748372c8f1dfa3cd39114770b85e890b048304f8395b2778a22da4cc468eb6fe1e2357a41bed5a6067e12992634859dabe30addd0fd39b4269 SHA512 60bce1e840f071d3a48cfa8e2acff988977956f659c5c04ce83f00751348fbbeddbfc54e8c9bd6ebc9073423ca5ee1816655dc5aa59fefd0a8edc9c3f7f3b913
diff --git a/sys-libs/libunwind/libunwind-1.3.1.ebuild b/sys-libs/libunwind/libunwind-1.3.1.ebuild
deleted file mode 100644 (file)
index 527b3b9..0000000
+++ /dev/null
@@ -1,103 +0,0 @@
-# Copyright 2005-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-MY_PV=${PV/_/-}
-MY_P=${PN}-${MY_PV}
-inherit autotools flag-o-matic libtool multilib-minimal
-
-DESCRIPTION="Portable and efficient API to determine the call-chain of a program"
-HOMEPAGE="https://savannah.nongnu.org/projects/libunwind"
-SRC_URI="mirror://nongnu/libunwind/${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0/8" # libunwind.so.8
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 -sparc ~x86 ~amd64-linux ~x86-linux"
-IUSE="debug debug-frame doc libatomic lzma +static-libs"
-
-RESTRICT="test" # half of tests are broken (toolchain version dependent)
-
-# We just use the header from libatomic.
-RDEPEND="lzma? ( app-arch/xz-utils[static-libs?,${MULTILIB_USEDEP}] )"
-DEPEND="${RDEPEND}
-       libatomic? ( dev-libs/libatomic_ops[${MULTILIB_USEDEP}] )"
-
-S="${WORKDIR}/${MY_P}"
-
-MULTILIB_WRAPPED_HEADERS=(
-       /usr/include/libunwind.h
-
-       # see libunwind.h for the full list of arch-specific headers
-       /usr/include/libunwind-aarch64.h
-       /usr/include/libunwind-arm.h
-       /usr/include/libunwind-hppa.h
-       /usr/include/libunwind-ia64.h
-       /usr/include/libunwind-mips.h
-       /usr/include/libunwind-ppc32.h
-       /usr/include/libunwind-ppc64.h
-       /usr/include/libunwind-sh.h
-       /usr/include/libunwind-tilegx.h
-       /usr/include/libunwind-x86.h
-       /usr/include/libunwind-x86_64.h
-)
-
-PATCHES=(
-       "${FILESDIR}"/${PN}-1.2-coredump-regs.patch #586092
-       "${FILESDIR}"/${PN}-1.2-ia64-ptrace-coredump.patch
-       "${FILESDIR}"/${PN}-1.2-ia64-missing.patch
-       "${FILESDIR}"/${PN}-1.2.1-only-include-execinfo_h-if-avaliable.patch
-)
-
-src_prepare() {
-       default
-       chmod +x src/ia64/mk_cursor_i || die
-       # Since we have tests disabled via RESTRICT, disable building in the subdir
-       # entirely.  This works around some build errors too. #484846
-       sed -i -e '/^SUBDIRS/s:tests::' Makefile.in || die
-
-       elibtoolize
-       eautoreconf
-
-       # Let's wait for proper fix upstream in https://github.com/libunwind/libunwind/issues/154
-       # Meanwhile workaround for gcc-10 with -fcommon, bug #706560
-       append-cflags -fcommon
-}
-
-multilib_src_configure() {
-       # --enable-cxx-exceptions: always enable it, headers provide the interface
-       # and on some archs it is disabled by default causing a mismatch between the
-       # API and the ABI, bug #418253
-       # conservative-checks: validate memory addresses before use; as of 1.0.1,
-       # only x86_64 supports this, yet may be useful for debugging, couple it with
-       # debug useflag.
-       ECONF_SOURCE="${S}" \
-       ac_cv_header_atomic_ops_h=$(usex libatomic) \
-       econf \
-               --enable-cxx-exceptions \
-               --enable-coredump \
-               --enable-ptrace \
-               --enable-setjmp \
-               $(use_enable debug-frame) \
-               $(use_enable doc documentation) \
-               $(use_enable lzma minidebuginfo) \
-               $(use_enable static-libs static) \
-               $(use_enable debug conservative_checks) \
-               $(use_enable debug)
-}
-
-multilib_src_compile() {
-       # Bug 586208
-       CCACHE_NODIRECT=1 default
-}
-
-multilib_src_test() {
-       # Explicitly allow parallel build of tests.
-       # Sandbox causes some tests to freak out.
-       SANDBOX_ON=0 emake check
-}
-
-multilib_src_install() {
-       default
-       use static-libs || find "${ED}"/usr -name 'libunwind*.la' -delete
-}