app-office/abiword: Replace 'nullptr' by 'NULL'
authorDavid Seifert <soap@gentoo.org>
Sun, 13 Nov 2016 09:34:40 +0000 (10:34 +0100)
committerDavid Seifert <soap@gentoo.org>
Sun, 13 Nov 2016 09:38:47 +0000 (10:38 +0100)
Gentoo-bug: 599618

Package-Manager: portage-2.3.2

app-office/abiword/abiword-3.0.2.ebuild
app-office/abiword/files/abiword-3.0.2-fix-nullptr-c++98.patch [new file with mode: 0644]

index f84d0cda180f4fc3bc63c215ad1c05a5d4bf9102..346ca4ab2cafd4543017b9950133465fbdde53fb 100644 (file)
@@ -73,6 +73,7 @@ PATCHES=(
        "${FILESDIR}"/${PN}-3.0.1-libwps-0.4.patch
        "${FILESDIR}"/${PN}-3.0.1-fixwps.patch
        "${FILESDIR}"/${PN}-3.0.2-fix-installing-readme.patch
+       "${FILESDIR}"/${PN}-3.0.2-fix-nullptr-c++98.patch
 )
 
 src_prepare() {
diff --git a/app-office/abiword/files/abiword-3.0.2-fix-nullptr-c++98.patch b/app-office/abiword/files/abiword-3.0.2-fix-nullptr-c++98.patch
new file mode 100644 (file)
index 0000000..f093196
--- /dev/null
@@ -0,0 +1,34 @@
+Replace 'nullptr' by NULL in order to allow compiling in C++98 mode.
+See also: https://bugs.gentoo.org/show_bug.cgi?id=599618
+
+--- a/src/af/gr/gtk/gr_UnixCairoGraphics.cpp
++++ b/src/af/gr/gtk/gr_UnixCairoGraphics.cpp
+@@ -180,7 +180,7 @@
+       if (m_styleBg) {
+               g_object_unref(m_styleBg);
+       }
+-      m_styleBg = XAP_GtkStyle_get_style(nullptr, "GtkButton"); // "button"
++      m_styleBg = XAP_GtkStyle_get_style(NULL, "GtkButton"); // "button"
+       // guess colours
+       // WHITE
+       GdkRGBA rgba2;
+@@ -627,7 +627,7 @@
+               _setProps();
+               cairo_save (m_cr);
+-              GtkStyleContext *context = nullptr;
++              GtkStyleContext *context = NULL;
+               switch(c) {
+               case GR_Graphics::CLR3D_Background:
+                       context = m_styleBg;
+--- a/src/wp/ap/xp/ap_Dialog_Spell.cpp
++++ b/src/wp/ap/xp/ap_Dialog_Spell.cpp
+@@ -251,7 +251,7 @@
+                                       UT_return_val_if_fail (m_Suggestions, false);
+                                       // get suggestions from spelling engine
+-                                      const UT_GenericVector<UT_UCSChar*> *cpvEngineSuggestions = nullptr;
++                                      const UT_GenericVector<UT_UCSChar*> *cpvEngineSuggestions = NULL;
+                                       if (checker->checkWord(m_pWord, m_iWordLength) == SpellChecker::LOOKUP_FAILED)
+                                       {