mail-client/mutt: fix curses/slang usage and wc-funcs on Solaris for arrows
authorFabian Groffen <grobian@gentoo.org>
Sat, 5 Sep 2015 08:13:25 +0000 (10:13 +0200)
committerFabian Groffen <grobian@gentoo.org>
Sat, 5 Sep 2015 08:15:20 +0000 (10:15 +0200)
Package-Manager: portage-2.2.20-prefix

mail-client/mutt/mutt-1.5.24.ebuild

index c2c1ed326b142439944a95840100f19ea64be1ce..a2a25381da903117a0d68e13d72b4238b25a98a3 100644 (file)
@@ -140,12 +140,12 @@ src_configure() {
                $(use_enable smtp) \
                $(use_with idn) \
                $(use_with kerberos gss) \
-               $(use slang && echo --with-slang) \
+               $(use slang && echo --with-slang=${EPREFIX}/usr) \
+               $(use !slang && echo --with-curses=${EPREFIX}/usr) \
                --enable-compressed \
                --enable-external-dotlock \
                --enable-nfs-fix \
                --sysconfdir=${EPREFIX}/etc/${PN} \
-               --with-curses \
                --with-docdir=${EPREFIX}/usr/share/doc/${PN}-${PVR} \
                --with-regex \
                --with-exec-shell=${EPREFIX}/bin/sh"
@@ -153,10 +153,12 @@ src_configure() {
        case $CHOST in
                *-solaris*)
                        # Solaris has no flock in the standard headers
-                       myconf="${myconf} --enable-fcntl --disable-flock"
+                       myconf+=" --enable-fcntl --disable-flock"
+                       # wchar_t depends on locale
+                       myconf+=" --without-wc-funcs"
                ;;
                *)
-                       myconf="${myconf} --disable-fcntl --enable-flock"
+                       myconf+=" --disable-fcntl --enable-flock"
                ;;
        esac