sys-libs/gdbm: tweak for gcc-10, bug #705898
authorSergei Trofimovich <slyfox@gentoo.org>
Sat, 2 May 2020 11:45:49 +0000 (12:45 +0100)
committerSergei Trofimovich <slyfox@gentoo.org>
Sat, 2 May 2020 11:46:04 +0000 (12:46 +0100)
Closes: https://bugs.gentoo.org/705898
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
sys-libs/gdbm/files/gdbm-1.18.1-gcc-10.patch [new file with mode: 0644]
sys-libs/gdbm/gdbm-1.18.1.ebuild

diff --git a/sys-libs/gdbm/files/gdbm-1.18.1-gcc-10.patch b/sys-libs/gdbm/files/gdbm-1.18.1-gcc-10.patch
new file mode 100644 (file)
index 0000000..9b3e3d7
--- /dev/null
@@ -0,0 +1,40 @@
+From ab05ea727942b5c1469e2e86548581264c6e2de4 Mon Sep 17 00:00:00 2001
+From: Sergei Trofimovich <slyfox@gentoo.org>
+Date: Sat, 2 May 2020 12:39:39 +0100
+Subject: [PATCH] gdbm: fix link failure against gcc-10
+
+Before the change on gcc-10 link failed as:
+```
+  CCLD     gdbmtool
+ld: ./libgdbmapp.a(parseopt.o):(.bss+0x8): multiple definition of `parseopt_program_args';
+  gdbmtool.o:(.data.rel.local+0x260): first defined here
+ld: ./libgdbmapp.a(parseopt.o):(.bss+0x10): multiple definition of `parseopt_program_doc';
+  gdbmtool.o:(.data.rel.local+0x268): first defined here
+```
+
+gcc-10 will change the default from -fcommon to fno-common:
+    https://gcc.gnu.org/PR85678.
+
+The fix is to avoid multiple definition and rely on
+declarations only.
+
+Bug: https://bugs.gentoo.org/705898
+Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
+---
+ src/parseopt.c | 2 --
+ 1 file changed, 2 deletions(-)
+
+--- a/src/parseopt.c
++++ b/src/parseopt.c
+@@ -255,8 +255,6 @@ print_option_descr (const char *descr, size_t lmargin, size_t rmargin)
+ }
\f
+ char *parseopt_program_name;
+-char *parseopt_program_doc;
+-char *parseopt_program_args;
+ const char *program_bug_address = "<" PACKAGE_BUGREPORT ">";
+ void (*parseopt_help_hook) (FILE *stream);
\f
+-- 
+2.26.2
+
index 5ed06c5121397ad0f5f4b759d47e820ad22d888d..5b38687c43c974f7928da5bd01cc53ed80a2d869 100644 (file)
@@ -19,6 +19,8 @@ DEPEND="
 "
 RDEPEND="${DEPEND}"
 
+PATCHES=("${FILESDIR}"/${PN}-1.18.1-gcc-10.patch)
+
 src_prepare() {
        default
        eautoreconf