x11-apps/xvfb-run: 1.17.2_p2
authorSebastian Pipping <sping@gentoo.org>
Mon, 14 Sep 2015 21:27:00 +0000 (23:27 +0200)
committerSebastian Pipping <sping@gentoo.org>
Mon, 14 Sep 2015 21:50:13 +0000 (23:50 +0200)
x11-apps/xvfb-run/Manifest [new file with mode: 0644]
x11-apps/xvfb-run/metadata.xml [new file with mode: 0644]
x11-apps/xvfb-run/xvfb-run-1.17.2_p2.ebuild [new file with mode: 0644]

diff --git a/x11-apps/xvfb-run/Manifest b/x11-apps/xvfb-run/Manifest
new file mode 100644 (file)
index 0000000..7c60663
--- /dev/null
@@ -0,0 +1 @@
+DIST xorg-server_1.17.2-2.diff.gz 151519 SHA256 7e63c1be87793ed66e3bd7086d991b4e4bc4020bd91e7328c1b0a97c351fa83b SHA512 471820ea8e5c7faa91035a665203e39c4109a708d0b7ccaf132f7d2f08bbf5989cfce85f5bf1005b44190fd78cb18d8a1205ba28c519992a249b2e1cd6222b5f WHIRLPOOL 89da68ad7c15509c07434e09c1a4552f840f97af65a086f49d68558ad810c1ecfde0de2ff5114a45b3a7f6a46228356af2974b200c0c0805ac1a20b035472fb2
diff --git a/x11-apps/xvfb-run/metadata.xml b/x11-apps/xvfb-run/metadata.xml
new file mode 100644 (file)
index 0000000..16bcc9f
--- /dev/null
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer>
+               <email>sping@gentoo.org</email>
+               <name>Sebastian Pipping</name>
+       </maintainer>
+</pkgmetadata>
diff --git a/x11-apps/xvfb-run/xvfb-run-1.17.2_p2.ebuild b/x11-apps/xvfb-run/xvfb-run-1.17.2_p2.ebuild
new file mode 100644 (file)
index 0000000..4ff0cce
--- /dev/null
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+MY_PN=xorg-server
+MY_PV=${PV/_p/-}
+DESCRIPTION="Run a command in a virtual X server environment"
+HOMEPAGE="https://packages.debian.org/sid/xvfb"
+SRC_URI="mirror://debian/pool/main/${MY_PN:0:1}/${MY_PN}/${MY_PN}_${MY_PV}.diff.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-util/patchutils"
+RDEPEND="x11-apps/xauth
+       x11-base/xorg-server[xvfb]"
+
+S="${WORKDIR}"/
+
+src_prepare() {
+       # Not in src_unpack to silence warning "'patch' call should be moved to src_prepare"
+       filterdiff --include='*xvfb-run*' ${MY_PN}_${MY_PV}.diff | patch || die
+}
+
+src_install() {
+       doman ${PN}.1
+       dobin ${PN}
+}