net-firewall/pglinux: version bump to 2.3.0
authorJulian Ospald <hasufell@gentoo.org>
Sat, 15 Aug 2015 19:44:57 +0000 (21:44 +0200)
committerJulian Ospald <hasufell@gentoo.org>
Sat, 15 Aug 2015 19:45:21 +0000 (21:45 +0200)
Gentoo-Bug: 538890

net-firewall/pglinux/Manifest
net-firewall/pglinux/pglinux-2.3.0.ebuild [new file with mode: 0644]

index 07a835f9a5ee58bc4d54534b375b48fd82723c01..d57ec923972f6e4774731b0fa764083ab68fef35 100644 (file)
@@ -1 +1,2 @@
 DIST pgl-2.2.4.tar.gz 608622 SHA256 26e91cb085a9da7faa643f9364192c0e3eeec64ccae56d0bb62de5174e185866 SHA512 d6daad259a904647917388e586d4bd7d6a73b078bf61974a5682b6eec2d8d2abb02760483838f23fefa13ae761b4bd40765ddb13e6d820d0b6e3ee65b0815f58 WHIRLPOOL 59de9ad6a3c95e2f9f553e7c311be948b488825bfe8db7e2fc78610d46d98c0cbef4ce4846a659b01b2a0b6548dfed13dde27c55ffc22cb37418b97cde0c0ca8
+DIST pgl-2.3.0.tar.gz 604284 SHA256 4183386a674e4778225f13165b0e9390eded89d9bc9445d4207a9c50078d0752 SHA512 535f13d6b17bbea099e415e9dd463ebf4e2ffa9af4d8ae96c7ace2667c84380f506018aca2b6b6a6d4ca1e2afd24fc6eaf9544eb00710645d562f2aa1fa5a1a7 WHIRLPOOL 959ed95aa89271c2632997d050031d97354fdc59ed33de527fffbcfb6a05d89dea1b2d03d35394af48b2342cc46c4dfe3180c65d727291c4df66b37d0f1519b9
diff --git a/net-firewall/pglinux/pglinux-2.3.0.ebuild b/net-firewall/pglinux/pglinux-2.3.0.ebuild
new file mode 100644 (file)
index 0000000..0f048b0
--- /dev/null
@@ -0,0 +1,98 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils gnome2-utils linux-info systemd
+
+MY_P="pgl-${PV}"
+
+DESCRIPTION="Privacy oriented firewall application"
+HOMEPAGE="https://sourceforge.net/projects/peerguardian/"
+SRC_URI="mirror://sourceforge/peerguardian/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="cron dbus logrotate networkmanager qt4 zlib"
+
+COMMON_DEPEND="
+       net-libs/libnetfilter_queue
+       net-libs/libnfnetlink
+       dbus? ( sys-apps/dbus )
+       zlib? ( sys-libs/zlib )
+       qt4? ( sys-auth/polkit-qt[qt4(+)]
+               dev-qt/qtcore:4
+               dev-qt/qtdbus:4
+               dev-qt/qtgui:4
+               || ( kde-apps/kdesu x11-libs/gksu x11-misc/ktsuss )
+       )"
+DEPEND="${COMMON_DEPEND}
+       virtual/pkgconfig
+       sys-devel/libtool:2"
+RDEPEND="${COMMON_DEPEND}
+       net-firewall/iptables
+       sys-apps/sysvinit
+       cron? ( virtual/cron )
+       logrotate? ( app-admin/logrotate )
+       networkmanager? ( net-misc/networkmanager )"
+
+REQUIRED_USE="qt4? ( dbus )"
+
+CONFIG_CHECK="~NETFILTER_NETLINK
+       ~NETFILTER_NETLINK_QUEUE
+       ~NETFILTER_XTABLES
+       ~NETFILTER_XT_TARGET_NFQUEUE
+       ~NETFILTER_XT_MATCH_IPRANGE
+       ~NETFILTER_XT_MARK
+       ~NETFILTER_XT_MATCH_MULTIPORT
+       ~NETFILTER_XT_MATCH_STATE
+       ~NF_CONNTRACK
+       ~NF_CONNTRACK_IPV4
+       ~NF_DEFRAG_IPV4
+       ~IP_NF_FILTER
+       ~IP_NF_IPTABLES
+       ~IP_NF_TARGET_REJECT"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+       econf \
+               --localstatedir=/var \
+               --docdir=/usr/share/doc/${PF} \
+               $(use_enable logrotate) \
+               $(use_enable cron) \
+               $(use_enable networkmanager) \
+               $(use_enable zlib) \
+               $(use_enable dbus) \
+               --disable-lowmem \
+               --with-iconsdir=/usr/share/icons/hicolor/128x128/apps \
+               --with-gentoo-init \
+               $(use_with qt4) \
+               --with-systemd="$(systemd_get_unitdir)"
+}
+
+src_install() {
+       default
+       keepdir /var/{lib,log,spool}/pgl
+       rm -rf "${ED%/}"/tmp
+}
+
+pkg_preinst() {
+       gnome2_icon_savelist
+}
+
+pkg_postinst() {
+       elog "optional dependencies:"
+       elog "  app-arch/p7zip (needed for blocklists packed as .7z)"
+       elog "  app-arch/unzip (needed for blocklists packed as .zip)"
+       elog "  virtual/mta (needed to send informational (blocklist updates) and"
+       elog "    warning mails (if pglcmd.wd detects a problem.))"
+
+       gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+       gnome2_icon_cache_update
+}