dev-libs/libtommath: Remove old
authorDavid Seifert <soap@gentoo.org>
Sun, 9 Feb 2020 23:04:58 +0000 (00:04 +0100)
committerDavid Seifert <soap@gentoo.org>
Sun, 9 Feb 2020 23:04:58 +0000 (00:04 +0100)
Package-Manager: Portage-2.3.88, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
dev-libs/libtommath/Manifest
dev-libs/libtommath/files/libtommath-0.42.0-makefile.patch [deleted file]
dev-libs/libtommath/libtommath-0.42.0-r1.ebuild [deleted file]
dev-libs/libtommath/libtommath-1.0.1.ebuild [deleted file]

index 252e843e5fdb3b8f41e59192b471228567e74a55..f9af84786c53cae431774379e2c9e3e6ed5ca9f4 100644 (file)
@@ -1,3 +1 @@
-DIST libtommath-0.42.0.tar.gz 1732144 BLAKE2B 624697bfa0bab0244783c3d2c92df2a1c0418611dc7f25989d038a5689beae325a426d8de38967ec856bd1e6f2d9413615333eebbf9316add838deda5b122de3 SHA512 d26e7737e5750530a7b96432502f0d458931e67af528872c46ad8dfc921b8f6ef4b3e05cb07d22bd13a8b24db65812928ae4c381250a4df95f6ca55efc3dae23
-DIST ltm-1.0.1.tar.xz 2210120 BLAKE2B e616f0359a1fffe8e1280dc24df1a83eb568d55f9f8acd0e4016fdd63b8ef10d939a8acbd4d49d70a69adf0e492ea5127200798f02af6af1c30e2e1f57870e3a SHA512 f98f7b0f91268e898803478fd52f578f476d378d096a25e48fa2e291159dc89bd1a6dc7d8c5c2254df840c731e5d009ec9728b72190318b6d1ba2916f5c66fb6
 DIST ltm-1.1.0.tar.xz 2125456 BLAKE2B 3aca7993704341f6a81e7fbef35389ac8ecd957dd78b5d576f0305d37493c3ddc32462cd787de2fb67d8e165417b18fcfde70accf991cd9433ff87591d8265ac SHA512 6d1b8b09d5b975a2b84ef6ab9cb1cc63db2f0503a906e499cb9d7eaba3f487be6e7f69bf692b188f888418c61ea563aa7e2411638d8979eac426b3d603ad1b91
diff --git a/dev-libs/libtommath/files/libtommath-0.42.0-makefile.patch b/dev-libs/libtommath/files/libtommath-0.42.0-makefile.patch
deleted file mode 100644 (file)
index b3f1ed6..0000000
+++ /dev/null
@@ -1,47 +0,0 @@
---- makefile.shared
-+++ makefile.shared
-@@ -3,7 +3,8 @@
- #Tom St Denis
- VERSION=0:41
--CC = libtool --mode=compile --tag=CC gcc
-+LT    ?= libtool
-+LTCOMPILE = $(LT) --mode=compile --tag=CC $(CC)
- CFLAGS  +=  -I./ -Wall -W -Wshadow -Wsign-compare
-@@ -82,21 +83,24 @@
- objs: $(OBJECTS)
-+%.lo: %.c
-+      $(LTCOMPILE) $(CFLAGS) $(CPPFLAGS) -o $@ -c $<
-+
--$(LIBNAME):  $(OBJECTS)
--      libtool --mode=link gcc *.lo -o $(LIBNAME) -rpath $(LIBPATH) -version-info $(VERSION)
-+$(LIBNAME):  $(OBJECTS:.o=.lo)
-+      $(LT) --mode=link --tag=CC $(CC) $(CFLAGS) $(LDFLAGS) *.lo -o $(LIBNAME) -rpath $(LIBPATH) -version-info $(VERSION)
- install: $(LIBNAME)
--      install -d -g $(GROUP) -o $(USER) $(DESTDIR)$(LIBPATH)
--      libtool --mode=install install -c $(LIBNAME) $(DESTDIR)$(LIBPATH)/$(LIBNAME)
--      install -d -g $(GROUP) -o $(USER) $(DESTDIR)$(INCPATH)
--      install -g $(GROUP) -o $(USER) $(HEADERS) $(DESTDIR)$(INCPATH)
-+      install -d $(DESTDIR)$(LIBPATH)
-+      $(LT) --mode=install install -c $(LIBNAME) $(DESTDIR)$(LIBPATH)/$(LIBNAME)
-+      install -d $(DESTDIR)$(INCPATH)
-+      install -m 644 $(HEADERS) $(DESTDIR)$(INCPATH)
- test: $(LIBNAME) demo/demo.o
--      gcc $(CFLAGS) -c demo/demo.c -o demo/demo.o
--      libtool --mode=link gcc -o test demo/demo.o $(LIBNAME_S)
-+      $(CC) $(CFLAGS) $(CPPFLAGS) -c demo/demo.c -o demo/demo.o
-+      $(LT) --mode=link $(CC) $(CFLAGS) $(LDFLAGS) -o test demo/demo.o $(LIBNAME_S)
-       
- mtest: test   
--      cd mtest ; gcc $(CFLAGS) mtest.c -o mtest
-+      cd mtest ; $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) mtest.c -o mtest
-         
- timing: $(LIBNAME)
--      gcc $(CFLAGS) -DTIMER demo/timing.c $(LIBNAME_S) -o ltmtest
-+      $(LT) --mode=link $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -DTIMER demo/timing.c $(LIBNAME_S) -o ltmtest
diff --git a/dev-libs/libtommath/libtommath-0.42.0-r1.ebuild b/dev-libs/libtommath/libtommath-0.42.0-r1.ebuild
deleted file mode 100644 (file)
index a1596d8..0000000
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-
-inherit autotools eutils multilib toolchain-funcs
-
-DESCRIPTION="Optimized and portable routines for integer theoretic applications"
-HOMEPAGE="https://github.com/libtom/libtommath"
-SRC_URI="https://github.com/libtom/libtommath/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="WTFPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE="doc examples static-libs"
-
-DEPEND="sys-devel/libtool"
-RDEPEND=""
-
-src_prepare() {
-       epatch "${FILESDIR}"/${P}-makefile.patch
-
-       # need libtool for cross compilation. Bug #376643
-       cat <<-EOF > configure.ac
-       AC_INIT(libtommath, 0)
-       AM_INIT_AUTOMAKE
-       LT_INIT
-       AC_CONFIG_FILES(Makefile)
-       AC_OUTPUT
-       EOF
-       touch NEWS README AUTHORS ChangeLog Makefile.am
-       eautoreconf
-       export LT="${S}"/libtool
-}
-
-src_configure() {
-       econf $(use_enable static-libs static)
-}
-
-_emake() {
-       emake CC="$(tc-getCC)" -f makefile.shared \
-               IGNORE_SPEED=1 \
-               LIBPATH="${EPREFIX}/usr/$(get_libdir)" \
-               INCPATH="${EPREFIX}/usr/include" \
-               "$@"
-}
-
-src_compile() {
-       _emake
-}
-
-src_install() {
-       _emake DESTDIR="${ED}" install
-       # We only link against -lc, so drop the .la file.
-       find "${ED}" -name '*.la' -delete
-
-       dodoc changes.txt
-
-       use doc && dodoc *.pdf
-
-       if use examples ; then
-               docinto demo
-               dodoc demo/*.c
-       fi
-}
diff --git a/dev-libs/libtommath/libtommath-1.0.1.ebuild b/dev-libs/libtommath/libtommath-1.0.1.ebuild
deleted file mode 100644 (file)
index 8f04224..0000000
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools eutils multilib toolchain-funcs
-
-DESCRIPTION="Optimized and portable routines for integer theoretic applications"
-HOMEPAGE="http://www.libtom.net/"
-SRC_URI="https://github.com/libtom/libtommath/releases/download/v${PV}/ltm-${PV}.tar.xz"
-
-LICENSE="WTFPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE="doc examples static-libs"
-
-DEPEND="sys-devel/libtool"
-
-src_prepare() {
-       default
-       # need libtool for cross compilation. Bug #376643
-       cat <<-EOF > configure.ac
-       AC_INIT(libtommath, 0)
-       AM_INIT_AUTOMAKE
-       LT_INIT
-       AC_CONFIG_FILES(Makefile)
-       AC_OUTPUT
-       EOF
-       touch NEWS README AUTHORS ChangeLog Makefile.am
-       eautoreconf
-       export LT="${S}"/libtool
-}
-
-src_configure() {
-       econf $(use_enable static-libs static)
-}
-
-_emake() {
-       emake \
-               CC="$(tc-getCC)" \
-               AR="$(tc-getAR)" \
-               RANLIB="$(tc-getRANLIB)" \
-               -f makefile.shared \
-               IGNORE_SPEED=1 \
-               LIBPATH="${EPREFIX}/usr/$(get_libdir)" \
-               INCPATH="${EPREFIX}/usr/include" \
-               "$@"
-}
-
-src_compile() {
-       _emake
-}
-
-src_test() {
-       _emake test_standalone
-       ./test || die
-}
-
-src_install() {
-       _emake DESTDIR="${D}" install
-       # We only link against -lc, so drop the .la file.
-       find "${ED}" -name '*.la' -delete
-
-       dodoc changes.txt
-
-       use doc && dodoc *.pdf
-
-       if use examples ; then
-               docinto demo
-               dodoc demo/*.c
-       fi
-}