dev-python/django: Remove 1*
authorMichał Górny <mgorny@gentoo.org>
Thu, 5 Mar 2020 18:53:33 +0000 (19:53 +0100)
committerMichał Górny <mgorny@gentoo.org>
Thu, 5 Mar 2020 19:07:51 +0000 (20:07 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/django/Manifest
dev-python/django/django-1.11.20.ebuild [deleted file]
dev-python/django/django-1.11.21.ebuild [deleted file]
dev-python/django/files/django-1.9-bashcomp.patch [deleted file]

index 86e9ef6d1a0cbf43b3708bdbf911a8c6bc0e1396..a24eca6d3aa774baa6f34e8489acb895962da949 100644 (file)
@@ -1,5 +1,3 @@
-DIST Django-1.11.20.tar.gz 7846576 BLAKE2B 11423edda7f2f08cc894957da65c746c99ce7ce5399ff236972cce627e347cbc4a43c7ff75282318fac2ac8f65fc4db691ac9fe8e04059b0de4f1bfe31278382 SHA512 5a0fff6c9b90a08e98dee6d4d090047adb900a8f6a061f98e685e8998bfe3d97fe7a90aa7d4d2feae67026fb6e4441393d50cb5ab295604ed362a080b987f062
-DIST Django-1.11.21.tar.gz 7847136 BLAKE2B 940734dc980901cb13fd90ef38815556d41e94a9fb1ac3a0e36e786b4a8df549ec2bce8a114ffbff1133a066ee8423c7beaccc7c774985df0aa1def1ebab58c1 SHA512 c91a1189b6b8fbbb1470f870b09c1c553e860d3b8c0977240399524a830d5403929f14b4e4b689354080748aab1c70587ad56e265f4ac0b3bdc2714d01adbbc4
 DIST Django-2.1.8.tar.gz 8613572 BLAKE2B 543e41f1b4031b624f903f075e95af7e010510f4c265aebd35a5f6b3f074703b3a4b54bc7f2a9752e717ac99d20c42d6e34e556ca619a531cf8c66622ce1419a SHA512 f84fcdf919091a9db6289f25da601ce447382f79118a99f8f316b2479a9325d629f725edb4618300f76e23bd68ae45ff4c6b6576988f109d1a7ba715c73327c3
 DIST Django-2.1.9.tar.gz 8608747 BLAKE2B d5ef1aacc30067dfe5369655eb23ea67788f22edcf8ba070944c0fb4fdf2fc3628a364d480a3d47bae0339255fb66a3bc27f11eb5f07280812ab5f57b4367c64 SHA512 1f6ad122012d898da52ce44465700d2492ef9002d5c327b25e3edfe2116b8a1143feab79751a581029664311452d52d96fe116d8817edb0ef7d7dbddfc0a5ec7
 DIST Django-2.2.1.tar.gz 8973889 BLAKE2B 890ab092807a587dbaba69fb6da7a4c53c8e976d3a4c29003549d72dd69c374640df280885a62845dda0d00f432e398747b9ed652aebbd7e3434c07e71d9a80f SHA512 661ed7352847d2167f8d3410b476cb585a269ef5d3afe0cb59cf0c9a2ea22f0572f12825368bc222f33f8c6d4c71767adade97e25b69f5a619795ccb670773e2
diff --git a/dev-python/django/django-1.11.20.ebuild b/dev-python/django/django-1.11.20.ebuild
deleted file mode 100644 (file)
index 63eb7b8..0000000
+++ /dev/null
@@ -1,113 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{6,7} )
-PYTHON_REQ_USE='sqlite?,threads(+)'
-WEBAPP_NO_AUTO_INSTALL="yes"
-
-inherit bash-completion-r1 distutils-r1 eutils eapi7-ver webapp
-
-MY_PN="Django"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="High-level Python web framework"
-HOMEPAGE="https://www.djangoproject.com/ https://pypi.org/project/Django/"
-SRC_URI="
-       https://www.djangoproject.com/m/releases/$(ver_cut 1-2)/${MY_P}.tar.gz
-       mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz
-       "
-
-LICENSE="BSD"
-# admin fonts: Roboto (media-fonts/roboto)
-LICENSE+=" Apache-2.0"
-# admin icons, jquery, xregexp.js
-LICENSE+=" MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc sqlite test"
-RESTRICT="!test? ( test )"
-
-RDEPEND=""
-DEPEND="${RDEPEND}
-       dev-python/pytz[${PYTHON_USEDEP}]
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       doc? ( >=dev-python/sphinx-1.0.7[${PYTHON_USEDEP}] )
-       test? (
-               $(python_gen_impl_dep sqlite)
-               dev-python/docutils[${PYTHON_USEDEP}]
-               dev-python/numpy[$(python_gen_usedep 'python*')]
-               dev-python/pillow[${PYTHON_USEDEP}]
-               dev-python/pyyaml[${PYTHON_USEDEP}]
-               dev-python/mock[${PYTHON_USEDEP}]
-               virtual/python-enum34[${PYTHON_USEDEP}]
-               )"
-
-S="${WORKDIR}/${MY_P}"
-
-WEBAPP_MANUAL_SLOT="yes"
-
-PATCHES=(
-       "${FILESDIR}"/${PN}-1.9-bashcomp.patch
-)
-
-pkg_setup() {
-       webapp_pkg_setup
-}
-
-python_prepare_all() {
-       # Prevent d'loading in the doc build
-       sed -e '/^    "sphinx.ext.intersphinx",/d' -i docs/conf.py || die
-
-       distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
-       use doc && emake -C docs html
-}
-
-python_test() {
-       # Tests have non-standard assumptions about PYTHONPATH,
-       # and don't work with ${BUILD_DIR}/lib.
-       PYTHONPATH=. "${PYTHON}" tests/runtests.py --settings=test_sqlite -v2 --parallel 1 \
-               || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
-       newbashcomp extras/django_bash_completion ${PN}-admin
-       bashcomp_alias ${PN}-admin django-admin.py
-
-       if use doc; then
-               rm -fr docs/_build/html/_sources || die
-               local HTML_DOCS=( docs/_build/html/. )
-       fi
-
-       insinto "${MY_HTDOCSDIR#${EPREFIX}}"
-       doins -r django/contrib/admin/static/admin/.
-       distutils-r1_python_install_all
-}
-
-src_install() {
-       distutils-r1_src_install
-       webapp_src_install
-}
-
-pkg_postinst() {
-       elog "Additional Backend support can be enabled via"
-       optfeature "MySQL backend support in python 2.7 only" dev-python/mysql-python
-       optfeature "MySQL backend support in python 2.7 - 3.4" dev-python/mysqlclient
-       optfeature "PostgreSQL backend support" dev-python/psycopg:2
-       echo ""
-       elog "Other features can be enhanced by"
-       optfeature "GEO Django" sci-libs/gdal[geos]
-       optfeature "Memcached support" dev-python/pylibmc dev-python/python-memcached
-       optfeature "ImageField Support" dev-python/pillow
-       optfeature "Password encryption" dev-python/bcrypt
-       optfeature "High-level abstractions for Django forms" dev-python/django-formtools
-       echo ""
-       elog "A copy of the admin media is available to webapp-config for installation in a"
-       elog "webroot, as well as the traditional location in python's site-packages dir"
-       elog "for easy development."
-       webapp_pkg_postinst
-}
diff --git a/dev-python/django/django-1.11.21.ebuild b/dev-python/django/django-1.11.21.ebuild
deleted file mode 100644 (file)
index a09c08f..0000000
+++ /dev/null
@@ -1,113 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{6,7} )
-PYTHON_REQ_USE='sqlite?,threads(+)'
-WEBAPP_NO_AUTO_INSTALL="yes"
-
-inherit bash-completion-r1 distutils-r1 eutils eapi7-ver webapp
-
-MY_PN="Django"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="High-level Python web framework"
-HOMEPAGE="https://www.djangoproject.com/ https://pypi.org/project/Django/"
-SRC_URI="
-       https://www.djangoproject.com/m/releases/$(ver_cut 1-2)/${MY_P}.tar.gz
-       mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz
-       "
-
-LICENSE="BSD"
-# admin fonts: Roboto (media-fonts/roboto)
-LICENSE+=" Apache-2.0"
-# admin icons, jquery, xregexp.js
-LICENSE+=" MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc sqlite test"
-RESTRICT="!test? ( test )"
-
-RDEPEND=""
-DEPEND="${RDEPEND}
-       dev-python/pytz[${PYTHON_USEDEP}]
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       doc? ( >=dev-python/sphinx-1.0.7[${PYTHON_USEDEP}] )
-       test? (
-               $(python_gen_impl_dep sqlite)
-               dev-python/docutils[${PYTHON_USEDEP}]
-               dev-python/numpy[$(python_gen_usedep 'python*')]
-               dev-python/pillow[${PYTHON_USEDEP}]
-               dev-python/pyyaml[${PYTHON_USEDEP}]
-               dev-python/mock[${PYTHON_USEDEP}]
-               virtual/python-enum34[${PYTHON_USEDEP}]
-               )"
-
-S="${WORKDIR}/${MY_P}"
-
-WEBAPP_MANUAL_SLOT="yes"
-
-PATCHES=(
-       "${FILESDIR}"/${PN}-1.9-bashcomp.patch
-)
-
-pkg_setup() {
-       webapp_pkg_setup
-}
-
-python_prepare_all() {
-       # Prevent d'loading in the doc build
-       sed -e '/^    "sphinx.ext.intersphinx",/d' -i docs/conf.py || die
-
-       distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
-       use doc && emake -C docs html
-}
-
-python_test() {
-       # Tests have non-standard assumptions about PYTHONPATH,
-       # and don't work with ${BUILD_DIR}/lib.
-       PYTHONPATH=. "${PYTHON}" tests/runtests.py --settings=test_sqlite -v2 --parallel 1 \
-               || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
-       newbashcomp extras/django_bash_completion ${PN}-admin
-       bashcomp_alias ${PN}-admin django-admin.py
-
-       if use doc; then
-               rm -fr docs/_build/html/_sources || die
-               local HTML_DOCS=( docs/_build/html/. )
-       fi
-
-       insinto "${MY_HTDOCSDIR#${EPREFIX}}"
-       doins -r django/contrib/admin/static/admin/.
-       distutils-r1_python_install_all
-}
-
-src_install() {
-       distutils-r1_src_install
-       webapp_src_install
-}
-
-pkg_postinst() {
-       elog "Additional Backend support can be enabled via"
-       optfeature "MySQL backend support in python 2.7 only" dev-python/mysql-python
-       optfeature "MySQL backend support in python 2.7 - 3.4" dev-python/mysqlclient
-       optfeature "PostgreSQL backend support" dev-python/psycopg:2
-       echo ""
-       elog "Other features can be enhanced by"
-       optfeature "GEO Django" sci-libs/gdal[geos]
-       optfeature "Memcached support" dev-python/pylibmc dev-python/python-memcached
-       optfeature "ImageField Support" dev-python/pillow
-       optfeature "Password encryption" dev-python/bcrypt
-       optfeature "High-level abstractions for Django forms" dev-python/django-formtools
-       echo ""
-       elog "A copy of the admin media is available to webapp-config for installation in a"
-       elog "webroot, as well as the traditional location in python's site-packages dir"
-       elog "for easy development."
-       webapp_pkg_postinst
-}
diff --git a/dev-python/django/files/django-1.9-bashcomp.patch b/dev-python/django/files/django-1.9-bashcomp.patch
deleted file mode 100644 (file)
index 8618dbe..0000000
+++ /dev/null
@@ -1,46 +0,0 @@
- extras/django_bash_completion | 35 +----------------------------------
- 1 file changed, 1 insertion(+), 34 deletions(-)
-
-diff --git a/extras/django_bash_completion b/extras/django_bash_completion
-index 06a2321..abe76e5 100755
---- a/extras/django_bash_completion
-+++ b/extras/django_bash_completion
-@@ -37,37 +37,4 @@ _django_completion()
-                    COMP_CWORD=$COMP_CWORD \
-                    DJANGO_AUTO_COMPLETE=1 $1 ) )
- }
--complete -F _django_completion -o default django-admin.py manage.py django-admin
--
--_python_django_completion()
--{
--    if [[ ${COMP_CWORD} -ge 2 ]]; then
--        local PYTHON_EXE=${COMP_WORDS[0]##*/}
--        echo $PYTHON_EXE | egrep "python([2-9]\.[0-9])?" >/dev/null 2>&1
--        if [[ $? == 0 ]]; then
--            local PYTHON_SCRIPT=${COMP_WORDS[1]##*/}
--            echo $PYTHON_SCRIPT | egrep "manage\.py|django-admin(\.py)?" >/dev/null 2>&1
--            if [[ $? == 0 ]]; then
--                COMPREPLY=( $( COMP_WORDS="${COMP_WORDS[*]:1}" \
--                               COMP_CWORD=$(( COMP_CWORD-1 )) \
--                               DJANGO_AUTO_COMPLETE=1 ${COMP_WORDS[*]} ) )
--            fi
--        fi
--    fi
--}
--
--# Support for multiple interpreters.
--unset pythons
--if command -v whereis &>/dev/null; then
--    python_interpreters=$(whereis python | cut -d " " -f 2-)
--    for python in $python_interpreters; do
--        [[ $python != *-config ]] && pythons="${pythons} ${python##*/}"
--    done
--    unset python_interpreters
--    pythons=$(echo $pythons | tr " " "\n" | sort -u | tr "\n" " ")
--else
--    pythons=python
--fi
--
--complete -F _python_django_completion -o default $pythons
--unset pythons
-+complete -F _django_completion -o default django-admin.py django-admin