net-dns/resolv_wrapper: Bump to version 1.1.6
authorLars Wendler <polynomial-c@gentoo.org>
Wed, 25 Mar 2020 08:46:05 +0000 (09:46 +0100)
committerLars Wendler <polynomial-c@gentoo.org>
Wed, 25 Mar 2020 08:46:05 +0000 (09:46 +0100)
Package-Manager: Portage-2.3.95, Repoman-2.3.21
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
net-dns/resolv_wrapper/Manifest
net-dns/resolv_wrapper/resolv_wrapper-1.1.6.ebuild [new file with mode: 0644]

index 07a49f4980128f4c7a6c4a418c674ba488d3b22b..1efec700e444607298ec20b0f32f390ab959d3bc 100644 (file)
@@ -1 +1,2 @@
 DIST resolv_wrapper-1.1.5.tar.gz 34241 BLAKE2B 7025885731a1defa79ae7a0381ca4394c37508883dc5e19aa9e29b0545cddc1c3f2b5091991a3e1599654e1a64442a6a36760f7725e54d1270c1a5b71bd3fadb SHA512 d11beff60cf935c0c12ac97ae375299ab1cd2e270d09438cf81b5c19dd94b7d430484c44ec9611171b67654d5c0f26afc4aa9d069d61293a956ef8fc59efc7a8
+DIST resolv_wrapper-1.1.6.tar.gz 38276 BLAKE2B 4b1c79a342b74f33063ba480b1706a107c53275430b3f5e1e46204265af3501394f72b6119e98ad3382e48f9a8f2511e679b3f4093446beaa11095bfaed340ce SHA512 cc379124c6104ba1330dfc038f04f9b473b71ac81b18889e481fb7812b38e71040ca6bed7bffd6eeaf77abeb8452a4d3308514ec6380811327dc832aa0381be8
diff --git a/net-dns/resolv_wrapper/resolv_wrapper-1.1.6.ebuild b/net-dns/resolv_wrapper/resolv_wrapper-1.1.6.ebuild
new file mode 100644 (file)
index 0000000..98ba5d7
--- /dev/null
@@ -0,0 +1,22 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_ECLASS=cmake
+inherit cmake-multilib
+
+DESCRIPTION="Wrapper for DNS name resolving or DNS faking"
+HOMEPAGE="https://cwrap.org/resolv_wrapper.html"
+SRC_URI="https://ftp.samba.org/pub/cwrap/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+# Work around a problem with >=dev-util/cmake-3.3.0 (bug #558340)
+# Because of this we cannot use cmake-multilib_src_configure() here.
+multilib_src_configure() {
+       local mycmakeargs=( -DCMAKE_LIBRARY_PATH=/usr/$(get_libdir) )
+       cmake_src_configure
+}