net-nds/rpcbind: Synced live ebuild.
authorLars Wendler <polynomial-c@gentoo.org>
Sun, 26 Aug 2018 18:07:05 +0000 (20:07 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Sun, 26 Aug 2018 18:07:05 +0000 (20:07 +0200)
Package-Manager: Portage-2.3.48, Repoman-2.3.10

net-nds/rpcbind/rpcbind-9999.ebuild

index 3a5262860d772a6170e93b161719e9df115be1c6..7e3bbeae8e85cbc4afc0b5c95cb1773b79b431de 100644 (file)
@@ -1,9 +1,9 @@
 # Copyright 1999-2018 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI="5"
+EAPI=6
 
-inherit eutils systemd
+inherit systemd
 
 if [[ ${PV} == "9999" ]] ; then
        EGIT_REPO_URI="git://linux-nfs.org/~steved/rpcbind.git"
@@ -18,7 +18,7 @@ HOMEPAGE="https://sourceforge.net/projects/rpcbind/"
 
 LICENSE="BSD"
 SLOT="0"
-IUSE="debug selinux systemd tcpd warmstarts"
+IUSE="debug remotecalls selinux systemd tcpd warmstarts"
 REQUIRED_USE="systemd? ( warmstarts )"
 
 CDEPEND=">=net-libs/libtirpc-0.2.3:=
@@ -30,17 +30,22 @@ RDEPEND="${CDEPEND}
        selinux? ( sec-policy/selinux-rpcbind )"
 
 src_prepare() {
+       default
        [[ ${PV} == "9999" ]] && eautoreconf
-       epatch_user
 }
 
 src_configure() {
-       econf \
-               --with-statedir="${EPREFIX}"/run/${PN} \
-               --with-systemdsystemunitdir=$(usex systemd "$(systemd_get_unitdir)" "no") \
-               $(use_enable tcpd libwrap) \
-               $(use_enable debug) \
+       local myeconfargs=(
+               --bindir="${EPREFIX}"/sbin
+               --sbindir="${EPREFIX}"/sbin
+               --with-statedir="${EPREFIX}"/run/${PN}
+               --with-systemdsystemunitdir=$(usex systemd "$(systemd_get_systemunitdir)" "no")
+               $(use_enable debug)
+               $(use_enable remotecalls rmtcalls)
                $(use_enable warmstarts)
+               $(use_enable tcpd libwrap)
+       )
+       econf "${myeconfargs[@]}"
 }
 
 src_install() {