dev-python/sphinx-notfound-page: 0.4 add for ansible
authorMatthew Thode <prometheanfire@gentoo.org>
Mon, 12 Aug 2019 18:16:41 +0000 (13:16 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Mon, 12 Aug 2019 18:23:18 +0000 (13:23 -0500)
Package-Manager: Portage-2.3.69, Repoman-2.3.17
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
dev-python/sphinx-notfound-page/Manifest [new file with mode: 0644]
dev-python/sphinx-notfound-page/metadata.xml [new file with mode: 0644]
dev-python/sphinx-notfound-page/sphinx-notfound-page-0.4.ebuild [new file with mode: 0644]

diff --git a/dev-python/sphinx-notfound-page/Manifest b/dev-python/sphinx-notfound-page/Manifest
new file mode 100644 (file)
index 0000000..9c50f6b
--- /dev/null
@@ -0,0 +1 @@
+DIST sphinx-notfound-page-0.4.tar.gz 5685 BLAKE2B 0bfc6cf98e0731a5cc95f1802dad1e7297ed764a626831b970d75d82ec0f7d6edb45c404851ea13bf38decc39aabf0e3dd6b136714a591e8ab595f11e23e67cd SHA512 56e867e6954f26da498b77e8fa43e8d62961ab33ee9c16d2084745dd54a998df51c7d882a47560196135d2fb4d473f7305ef19b31373bc205f8eaf0d3d4946f0
diff --git a/dev-python/sphinx-notfound-page/metadata.xml b/dev-python/sphinx-notfound-page/metadata.xml
new file mode 100644 (file)
index 0000000..7f94ee9
--- /dev/null
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="project">
+               <email>python@gentoo.org</email>
+       </maintainer>
+       <maintainer type="person">
+               <email>prometheanfire@gentoo.org</email>
+               <name>Matthew Thode</name>
+       </maintainer>
+       <longdescription lang="en">
+                       Create a custom 404 page with absolute URLs hardcoded.
+       </longdescription>
+</pkgmetadata>
diff --git a/dev-python/sphinx-notfound-page/sphinx-notfound-page-0.4.ebuild b/dev-python/sphinx-notfound-page/sphinx-notfound-page-0.4.ebuild
new file mode 100644 (file)
index 0000000..8c43245
--- /dev/null
@@ -0,0 +1,20 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_5 python3_6 python3_7 )
+inherit distutils-r1
+
+DESCRIPTION="Create a custom 404 page with absolute URLs hardcoded."
+HOMEPAGE="https://sphinx-notfound-page.readthedocs.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~x64-macos"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+BDEPEND=""