dev-db/pgadmin4: Bump to 4.13
authorAaron W. Swenson <titanofold@gentoo.org>
Fri, 18 Oct 2019 00:23:55 +0000 (20:23 -0400)
committerAaron W. Swenson <titanofold@gentoo.org>
Fri, 18 Oct 2019 00:24:14 +0000 (20:24 -0400)
Now require ssl on dev-qt/qtnetwork, and minimal deactivated dev-libs/libsodium.

Bug: https://bugs.gentoo.org/689708
Bug: https://bugs.gentoo.org/689678
Closes: https://bugs.gentoo.org/695970
Package-Manager: Portage-2.3.76, Repoman-2.3.16
Signed-off-by: Aaron W. Swenson <titanofold@gentoo.org>
dev-db/pgadmin4/Manifest
dev-db/pgadmin4/pgadmin4-4.13.ebuild [new file with mode: 0644]

index 58070e21f70a1e0b4572aedf9c28244088a403ea..dec6dfb5c26fa2a89ea356fa430a0a17d95bcb69 100644 (file)
@@ -1,3 +1,4 @@
 DIST pgadmin4-4.10.tar.gz 22809776 BLAKE2B 70a9857de31721b1cd5816b9e15abf325516f94ad5248f3ce5387cca5081ba96d7fca6c487265960ffac8d63c2fd09c3dea44d24a1cc9f8dbb170bd76d5de545 SHA512 b7f91d85fdc39766a294d9b66e8539f709b99f971726551d013345595161ff017e03505f05a41352575892be9d9622e86f4ccdbac76bcea435e2fb88a690b565
+DIST pgadmin4-4.13.tar.gz 25077107 BLAKE2B afbf0b6fba2f4cbbc1f47ac6c7867b7f131e5698de265a9dda53b79968f237ac591c5ff4da94dde0b74479cac1158ec825f42b14fc01aee13982043822c04443 SHA512 7eca41047e41f7bdce2dfe992260e8c2ab40f985dd232eb240ea9c0024f551f011653717aa0d5e4ccdccd4ef4936102cde1f97a32852d8382dcc222fadce7707
 DIST pgadmin4-4.5.tar.gz 22420769 BLAKE2B ae16e34c4cfce0ae78f06321ea1fc34aac0e081df4c0d5906fc4da0c82abb67e374477b8f9a9266d003579eb8887541e4224465ce6eccd86589129e1b3efff24 SHA512 835434612ac2a7ff89fab4c4bed89644e43506491ce12d2b74ffdbc25b33f2ac9ae566c95e886d4b4f8bca6499c40be5f0d776b18bfdcebd44d7ffe3b89deb5f
 DIST pgadmin4-4.8.tar.gz 22780924 BLAKE2B 7b64ef8ac3782e9c8207d5938f3638d67ddf5c86ca520afbfb296a824b39411362ca6e9d8b03920e35cca38d1303efe81750e5bfc849cfb363f370da3d25ac44 SHA512 68b35c1091435fbeb39e67c7f93038fcba95cd5ae7098434b5d3afee10595f875ef9fd997934f2bbd93c914bcd5c3c71bd43f032f788e55c5795f5ad63b57cd7
diff --git a/dev-db/pgadmin4/pgadmin4-4.13.ebuild b/dev-db/pgadmin4/pgadmin4-4.13.ebuild
new file mode 100644 (file)
index 0000000..52a6502
--- /dev/null
@@ -0,0 +1,109 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6} )
+PYTHON_REQ_USE="sqlite"
+
+inherit python-single-r1 qmake-utils
+
+DESCRIPTION="GUI administration and development platform for PostgreSQL"
+HOMEPAGE="https://www.pgadmin.org/"
+SRC_URI="https://ftp.postgresql.org/pub/pgadmin/${PN}/v${PV}/source/${P}.tar.gz"
+
+LICENSE="POSTGRESQL"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="doc"
+
+RESTRICT="test"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# libsodium dep added because of 689678
+COMMON_DEPEND="${PYTHON_DEPS}
+       dev-libs/libsodium[-minimal]
+       dev-qt/qtnetwork:5[ssl]
+       dev-qt/qtwidgets:5
+"
+
+DEPEND="${COMMON_DEPEND}
+       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+"
+
+RDEPEND="${COMMON_DEPEND}
+       >=app-text/htmlmin-0.1.12[${PYTHON_USEDEP}]
+       >=dev-python/blinker-1.4[${PYTHON_USEDEP}]
+       >=dev-python/flask-1.0.2[${PYTHON_USEDEP}]
+       >=dev-python/flask-gravatar-0.5.0[${PYTHON_USEDEP}]
+       >=dev-python/flask-htmlmin-1.5.0[${PYTHON_USEDEP}]
+       >=dev-python/flask-login-0.4.1[${PYTHON_USEDEP}]
+       >=dev-python/flask-mail-0.9.1[${PYTHON_USEDEP}]
+       >=dev-python/flask-migrate-2.4.0[${PYTHON_USEDEP}]
+       >=dev-python/flask-paranoid-0.2.0[${PYTHON_USEDEP}]
+       >=dev-python/flask-principal-0.4.0[${PYTHON_USEDEP}]
+       >=dev-python/flask-security-3.0.0[${PYTHON_USEDEP}]
+       >=dev-python/flask-sqlalchemy-2.3.2[${PYTHON_USEDEP}]
+       >=dev-python/flask-wtf-0.14.2[${PYTHON_USEDEP}]
+       >=dev-python/passlib-1.7.1[${PYTHON_USEDEP}]
+       >=dev-python/psutil-5.5.1[${PYTHON_USEDEP}]
+       >=dev-python/psycopg-2.8[${PYTHON_USEDEP}]
+       >=dev-python/python-dateutil-2.8.0[${PYTHON_USEDEP}]
+       >=dev-python/python-sqlparse-0.2.4[${PYTHON_USEDEP}]
+       >=dev-python/pytz-2018.9[${PYTHON_USEDEP}]
+       >=dev-python/simplejson-3.16.0[${PYTHON_USEDEP}]
+       >=dev-python/six-1.12.0[${PYTHON_USEDEP}]
+       >=dev-python/speaklater-1.3[${PYTHON_USEDEP}]
+       >=dev-python/sqlalchemy-1.2.18[${PYTHON_USEDEP}]
+       >=dev-python/sshtunnel-0.1.4[${PYTHON_USEDEP}]
+       >=dev-python/wtforms-2.2.1[${PYTHON_USEDEP}]
+"
+
+S="${WORKDIR}"/${P}/runtime
+
+src_prepare() {
+       cd "${WORKDIR}"/${P} || die
+       default
+}
+
+src_configure() {
+       eqmake5
+}
+
+src_compile() {
+       default
+       if use doc; then
+               cd "${WORKDIR}"/${P} || die
+               emake docs
+       fi
+}
+
+src_install() {
+       dobin pgAdmin4
+
+       cd "${WORKDIR}"/${P} || die
+
+       local APP_DIR=/usr/share/${PN}/web
+       insinto "${APP_DIR}"
+       doins -r web/*
+       cat > "${D}${APP_DIR}"/config_local.py <<-EOF
+               SERVER_MODE = False
+               UPGRADE_CHECK_ENABLED = False
+       EOF
+       python_optimize "${D}${APP_DIR}"
+
+       local CONFIG_DIR="/etc/xdg/pgadmin"
+       dodir "${CONFIG_DIR}"
+       cat > "${D}${CONFIG_DIR}"/pgadmin4.conf <<-EOF
+               [General]
+               ApplicationPath=${APP_DIR}
+               PythonPath=$(python_get_sitedir)
+       EOF
+
+       if use doc; then
+               rm -r docs/en_US/_build/html/_sources || die
+               insinto /usr/share/${PN}/docs/en_US/_build
+               doins -r docs/en_US/_build/html
+       fi
+}