xfce-base/xfdesktop: Bump to 4.12.5 (stable branch)
authorMichał Górny <mgorny@gentoo.org>
Wed, 5 Jun 2019 06:29:24 +0000 (08:29 +0200)
committerMichał Górny <mgorny@gentoo.org>
Wed, 5 Jun 2019 06:53:25 +0000 (08:53 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
xfce-base/xfdesktop/Manifest
xfce-base/xfdesktop/xfdesktop-4.12.5.ebuild [new file with mode: 0644]

index ef4f0ad1bf26121a6fd513ad038b7c22336299ea..2ae82bfbc4d6cf68694b55ca2c185afa69061c07 100644 (file)
@@ -1,2 +1,3 @@
 DIST xfdesktop-4.12.4.tar.bz2 1421623 BLAKE2B a18b891d639165d617f2701106dedb2f8577273ece5a4c93f6b5e1ef26f801304ea2014f21bd2821eb9bac9b19e02dd75cd4054a116eefd544f4d8e5d6968879 SHA512 29f170b96836298dc83e3c49650ab7e88a93c1a2fa1599d1d98f3b6c80c9c059748b76a821077eea39b5b4619998bb300ff17f06e88483a59bd5ae2b76d0605e
+DIST xfdesktop-4.12.5.tar.bz2 1442736 BLAKE2B 2f4d60fff062779123ab70b8e4d56cd67ea783b7c2aed00a39773b66e20b60fc4189e899ad3c17c70afcd1674bae72a4f574c952a11ba1f40860f35eb8e6869a SHA512 0217a220e7d6d9f95277d5a2dd047c133b65b0ccf21510cd949241b594f244a726147d0d0256e3f32d6989710e6e074710c1a63b46a88587a5ef7238cbb8a92d
 DIST xfdesktop-4.13.4.tar.bz2 1485482 BLAKE2B c0f40c448d79e3840d8708e8c5fb4a1d94658ab866c630c5a9b2cd40e3b92b3598e57377ed60621a5b28daedd7ab877aeb13b84735a23f5a302cf07434008012 SHA512 3943fc2af3ca3996a38900fea4a03004e1d3f8728a8517c988bd59744607ed8e4ba3f135d6075833af206df3c35464633f47e374c26fcbb8a20f0f1ecfdb7da6
diff --git a/xfce-base/xfdesktop/xfdesktop-4.12.5.ebuild b/xfce-base/xfdesktop/xfdesktop-4.12.5.ebuild
new file mode 100644 (file)
index 0000000..2a73585
--- /dev/null
@@ -0,0 +1,55 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="Desktop manager for the Xfce desktop environment"
+HOMEPAGE="https://www.xfce.org/projects/"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="debug libnotify +thunar"
+
+# src/xfdesktop-file-utils.c:#if GLIB_CHECK_VERSION (2, 38, 0)
+RDEPEND=">=x11-libs/cairo-1.6:=
+       >=dev-libs/dbus-glib-0.100:=
+       >=dev-libs/glib-2.20:=
+       >=x11-libs/gtk+-2.24:2=
+       >=x11-libs/libwnck-2.30:1=
+       x11-libs/libX11:=
+       <xfce-base/exo-0.12.5-r100:=
+       >=xfce-base/garcon-0.3:=
+       >=xfce-base/libxfce4ui-4.11:=
+       >=xfce-base/libxfce4util-4.11:=
+       >=xfce-base/xfconf-4.10:=
+       libnotify? ( >=x11-libs/libnotify-0.7:= )
+       thunar? (
+               >=dev-libs/glib-2.38:=
+               =xfce-base/thunar-1.6*:=[dbus]
+               )"
+DEPEND="${RDEPEND}
+       dev-util/intltool
+       sys-devel/gettext
+       virtual/pkgconfig"
+
+src_configure() {
+       local myconf=(
+               $(use_enable thunar file-icons)
+               $(use_enable thunar thunarx)
+               $(use_enable libnotify notifications)
+       )
+
+       econf "${myconf[@]}"
+}
+
+pkg_postinst() {
+       xdg_icon_cache_update
+}
+
+pkg_postrm() {
+       xdg_icon_cache_update
+}