sci-chemistry/dssp: Add missing USE dep, bug #557840 drop old patches
authorJustin Lecher <jlec@gentoo.org>
Sat, 15 Aug 2015 13:56:05 +0000 (15:56 +0200)
committerJustin Lecher <jlec@gentoo.org>
Sat, 15 Aug 2015 14:41:52 +0000 (16:41 +0200)
Package-Manager: portage-2.2.20.1
Signed-off-by: Justin Lecher <jlec@gentoo.org>
sci-chemistry/dssp/dssp-2.2.1-r1.ebuild
sci-chemistry/dssp/files/dssp-2.0.4-gcc47.patch [deleted file]
sci-chemistry/dssp/files/dssp-2.0.4-gentoo.patch [deleted file]

index 5e8b800f94889dc6b2d4ab8f6dbf708da1ef7019..28f8aced15f4a85c3807b91e30672ccb447d11a6 100644 (file)
@@ -15,7 +15,7 @@ SLOT="0"
 KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
 IUSE=""
 
-RDEPEND="dev-libs/boost:="
+RDEPEND="dev-libs/boost:=[threads]"
 DEPEND="${RDEPEND}"
 
 src_prepare() {
diff --git a/sci-chemistry/dssp/files/dssp-2.0.4-gcc47.patch b/sci-chemistry/dssp/files/dssp-2.0.4-gcc47.patch
deleted file mode 100644 (file)
index 5db1437..0000000
+++ /dev/null
@@ -1,46 +0,0 @@
- src/matrix.h          |    5 +++--
- src/primitives-3d.cpp |    1 +
- 2 files changed, 4 insertions(+), 2 deletions(-)
-
-diff --git a/src/matrix.h b/src/matrix.h
-index 1053ad9..d7dae5f 100644
---- a/src/matrix.h
-+++ b/src/matrix.h
-@@ -14,6 +14,7 @@
- #include <istream>
- #include <cassert>
- #include <stdexcept>
-+#include <unistd.h>
- // --------------------------------------------------------------------
- // uBlas compatible matrix types
-@@ -284,7 +285,7 @@ class identity_matrix : public matrix_base<T>
- template<typename T>
- matrix<T> operator*(const matrix_base<T>& lhs, const matrix_base<T>& rhs)
- {
--      matrix<T> result(min(lhs.dim_m(), rhs.dim_m()), min(lhs.dim_n(), rhs.dim_n()));
-+      matrix<T> result(std::min(lhs.dim_m(), rhs.dim_m()), std::min(lhs.dim_n(), rhs.dim_n()));
-       
-       for (uint32 i = 0; i < result.dim_m(); ++i)
-       {
-@@ -310,7 +311,7 @@ matrix<T> operator*(const matrix_base<T>& lhs, T rhs)
- template<typename T>
- matrix<T> operator-(const matrix_base<T>& lhs, const matrix_base<T>& rhs)
- {
--      matrix<T> result(min(lhs.dim_m(), rhs.dim_m()), min(lhs.dim_n(), rhs.dim_n()));
-+      matrix<T> result(std::min(lhs.dim_m(), rhs.dim_m()), std::min(lhs.dim_n(), rhs.dim_n()));
-       
-       for (uint32 i = 0; i < result.dim_m(); ++i)
-       {
-diff --git a/src/primitives-3d.cpp b/src/primitives-3d.cpp
-index b04e7c4..4532ecd 100644
---- a/src/primitives-3d.cpp
-+++ b/src/primitives-3d.cpp
-@@ -9,6 +9,7 @@
- #include <valarray>
- #include <cmath>
-+#include <unistd.h>
- #include <boost/foreach.hpp>
- #define foreach BOOST_FOREACH
diff --git a/sci-chemistry/dssp/files/dssp-2.0.4-gentoo.patch b/sci-chemistry/dssp/files/dssp-2.0.4-gentoo.patch
deleted file mode 100644 (file)
index 3db40f6..0000000
+++ /dev/null
@@ -1,70 +0,0 @@
- makefile |   24 ++++++++++++++----------
- 1 files changed, 14 insertions(+), 10 deletions(-)
-
-diff --git a/makefile b/makefile
-index df699b7..9d2167b 100644
---- a/makefile
-+++ b/makefile
-@@ -2,7 +2,7 @@
- #
- #  Copyright Maarten L. Hekkelman, Radboud University 2008-2011.
- # Distributed under the Boost Software License, Version 1.0.
--#    (See accompanying file LICENSE_1_0.txt or copy at
-+#    (See aCXXompanying file LICENSE_1_0.txt or copy at
- #          http://www.boost.org/LICENSE_1_0.txt)
- #
- # This makefile includes a file called make.config. It will create a
-@@ -24,22 +24,23 @@ BOOST_LIBS                 = thread regex filesystem program_options date_time iostreams math_
- LIBS                          = $(BOOST_LIBS:%=boost_%$(BOOST_LIB_SUFFIX)) z bz2
- DEFINES                               = USE_COMPRESSION LINUX VERSION='"$(VERSION)"'
--CC                                    = c++
-+CXX                                   ?= c++
--CFLAGS                                = $(INC_DIR:%=-I%) -iquote src -g -Wall -Wno-multichar -pthread
--LDOPTS                                = $(LIB_DIR:%=-L%) $(LIBS:%=-l%) -g -pthread
-+CPPFLAGS                              += $(INC_DIR:%=-I%) -iquote src
-+CXXFLAGS          += -Wall -Wno-multichar -pthread
-+LDOPTS                                = $(LIB_DIR:%=-L%) $(LIBS:%=-l%) -pthread
- OBJ_DIR                               = obj
- ifeq ($(DEBUG),1)
- OBJ_DIR                               := $(OBJ_DIR).dbg
--CFLAGS                                += -g3
-+CFLAGS                                += 
- else
- DEFINES                               += NDEBUG
--CFLAGS                                += -O3
-+CFLAGS                                += 
- endif
--CFLAGS                                += $(DEFINES:%=-D%)
-+CPPFLAGS                              += $(DEFINES:%=-D%)
- DIST_NAME                     = dssp-$(VERSION)
-@@ -49,17 +50,20 @@ OBJECTS = $(OBJ_DIR)/mkdssp.o $(OBJ_DIR)/dssp.o $(OBJ_DIR)/primitives-3d.o $(OBJ
- mkdssp: $(OBJECTS)
-       @ echo linking $@
--      @ $(CC) -static -o $@ $^ $(LDOPTS)
-+      $(CXX) $(LDFLAGS) -o $@ $^ $(LDOPTS)
-       @ echo OK
- include $(OBJECTS:%.o=%.d)
- $(OBJECTS:.o=.d):
--$(OBJ_DIR)/%.o: %.cpp
-+OBJ_DIR:
-       @ if [ ! -d $(OBJ_DIR) ]; then mkdir $(OBJ_DIR); fi
-+
-+
-+$(OBJ_DIR)/%.o: %.cpp OBJ_DIR
-       @ echo compiling $@
--      @ $(CC) -MD -c -o $@ $< $(CFLAGS)
-+      $(CXX) $(CPPFLAGS) $(CXXFLAGS) -MD -c -o $@ $<
- clean:
-       rm -rf $(OBJ_DIR)/* mkdssp