app-emulation/punes: new package.
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>
Fri, 12 Jan 2018 05:55:57 +0000 (10:55 +0500)
committerPatrice Clement <monsieurp@gentoo.org>
Fri, 26 Jan 2018 21:23:00 +0000 (22:23 +0100)
puNES is Nintendo Entertainment System emulator.

Package-Manager: Portage-2.3.13, Repoman-2.3.3
Closes: https://github.com/gentoo/gentoo/pull/6838

app-emulation/punes/Manifest [new file with mode: 0644]
app-emulation/punes/metadata.xml [new file with mode: 0644]
app-emulation/punes/punes-0.102.ebuild [new file with mode: 0644]

diff --git a/app-emulation/punes/Manifest b/app-emulation/punes/Manifest
new file mode 100644 (file)
index 0000000..d977104
--- /dev/null
@@ -0,0 +1 @@
+DIST punes-0.102.tar.gz 4670534 BLAKE2B 04576110e4fcd9aeaa3dfb6812ab7a21305200c82651be00defcb59b91374b155b279818f2e09d217841aa8567c41e06067252538fb68b7b907d5ab29b02c678 SHA512 dff95b25f64ed03060b6dd187d7a283acfddb6bea4168df5be4d309bd6aabdcaa5d0ea0312d0824205bf134cd0ddabf014e82a81c8a901a59258475ec24bd394
diff --git a/app-emulation/punes/metadata.xml b/app-emulation/punes/metadata.xml
new file mode 100644 (file)
index 0000000..c8d6de0
--- /dev/null
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>azamat.hackimov@gmail.com</email>
+               <name>Azamat H. Hackimov</name>
+       </maintainer>
+       <maintainer type="project">
+               <email>proxy-maint@gentoo.org</email>
+               <name>Proxy Maintainers</name>
+       </maintainer>
+       <longdescription lang="en">
+               Nintendo Entertainment System (NES) emulator
+       </longdescription>
+       <use>
+               <flag name="cg">Add support for Nvidia CG Toolkit</flag>
+       </use>
+       <upstream>
+               <remote-id type="github">punesemu/puNES</remote-id>
+       </upstream>
+</pkgmetadata>
diff --git a/app-emulation/punes/punes-0.102.ebuild b/app-emulation/punes/punes-0.102.ebuild
new file mode 100644 (file)
index 0000000..cb13a85
--- /dev/null
@@ -0,0 +1,53 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools xdg-utils
+
+DESCRIPTION="Nintendo Entertainment System (NES) emulator"
+HOMEPAGE="https://github.com/punesemu/puNES"
+SRC_URI="https://github.com/punesemu/puNES/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cg"
+
+RDEPEND="
+       dev-qt/qtcore:5
+       dev-qt/qtgui:5
+       dev-qt/qtwidgets:5
+       cg? ( media-gfx/nvidia-cg-toolkit )
+       media-libs/alsa-lib
+       media-libs/libsdl[opengl]
+       virtual/opengl"
+
+DEPEND="
+       ${RDEPEND}
+       virtual/pkgconfig"
+
+S="${WORKDIR}/puNES-${PV}"
+
+src_prepare() {
+       default
+
+       sed -i "/update-desktop-database/d" misc/Makefile.am || die
+       eautoreconf
+       # FIXME why eautoreconf can't handle this?
+       cd "src/extra/lib7zip-1.6.5" || die
+       eautoreconf
+}
+
+src_configure() {
+       econf \
+               --enable-qt5 \
+               $(use_with cg opengl-nvidia-cg)
+}
+
+pkg_postinst() {
+       xdg_desktop_database_update
+}
+
+pkg_postrm() {
+       xdg_desktop_database_update
+}