dev-python/boto: Remove py2
authorMichał Górny <mgorny@gentoo.org>
Sat, 28 Mar 2020 16:24:15 +0000 (17:24 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sat, 28 Mar 2020 16:27:50 +0000 (17:27 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/boto/boto-2.49.0.ebuild

index 2a6f4b57820eb13cd48e0c682827bbdec85dc9d1..ed057dd745cf1a665e71771b9ab6bd88d112312c 100644 (file)
@@ -2,7 +2,7 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,7} )
 
 inherit distutils-r1
 
@@ -13,42 +13,15 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
 LICENSE="MIT"
 SLOT="0"
 KEYWORDS="amd64 arm arm64 ppc sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc test"
-
-REQUIRED_USE="doc? ( || ( $(python_gen_useflags 'python2*') ) )"
+IUSE="test"
 
 DEPEND="
        dev-python/setuptools[${PYTHON_USEDEP}]
-       test? ( dev-python/nose[${PYTHON_USEDEP}] )
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+       test? ( dev-python/nose[${PYTHON_USEDEP}] )"
 
 # requires Amazon Web Services keys to pass some tests
 RESTRICT="test"
 
-pkg_setup() {
-       use doc && DISTUTILS_ALL_SUBPHASE_IMPLS=( 'python2*' )
-}
-
 python_test() {
        "${PYTHON}" tests/test.py -v || die "Tests fail with ${EPYTHON}"
 }
-
-python_prepare_all() {
-       # Prevent un-needed d'loading
-       sed -e "s/, 'sphinx.ext.intersphinx'//" -i docs/source/conf.py || die
-       distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
-       if use doc; then
-               # Appease the doc build and supply a file for _static
-               # the usual emake -C docs doesn't work under this authorship
-               cd docs && mkdir source/_static  || die
-               emake html
-       fi
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( docs/build/html/. )
-       distutils-r1_python_install_all
-}