media-sound/lmms: Synced live ebuild.
authorLars Wendler <polynomial-c@gentoo.org>
Thu, 30 Nov 2017 21:39:45 +0000 (22:39 +0100)
committerLars Wendler <polynomial-c@gentoo.org>
Thu, 30 Nov 2017 21:40:04 +0000 (22:40 +0100)
Package-Manager: Portage-2.3.16, Repoman-2.3.6

media-sound/lmms/lmms-9999.ebuild

index ee2e01679215ab4ed8487234e4ade6c91acce7c1..1782844e67f4950efa4b6665cb718758dd1caede 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=6
 
-inherit cmake-utils
+inherit cmake-utils xdg-utils
 
 DESCRIPTION="Cross-platform music production software"
 HOMEPAGE="https://lmms.io"
@@ -11,8 +11,9 @@ if [[ ${PV} == "9999" ]]; then
        EGIT_REPO_URI="https://github.com/LMMS/lmms.git"
        inherit git-r3
 else
-       SRC_URI="https://github.com/LMMS/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+       SRC_URI="https://github.com/LMMS/${PN}/archive/v${PV/_/-}.tar.gz -> ${P}.tar.gz"
        KEYWORDS="~amd64 ~x86"
+       S="${WORKDIR}/${P/_/-}"
 fi
 
 LICENSE="GPL-2 LGPL-2"
@@ -85,3 +86,13 @@ src_configure() {
        )
        cmake-utils_src_configure
 }
+
+pkg_postinst() {
+       xdg_mimeinfo_database_update
+       xdg_desktop_database_update
+}
+
+pkg_postrm() {
+       xdg_mimeinfo_database_update
+       xdg_desktop_database_update
+}