app-doc/casting-spels-emacs: Bump to EAPI 6. Update HOMEPAGE.
authorUlrich Müller <ulm@gentoo.org>
Thu, 24 Nov 2016 08:46:26 +0000 (09:46 +0100)
committerUlrich Müller <ulm@gentoo.org>
Thu, 24 Nov 2016 08:46:26 +0000 (09:46 +0100)
Package-Manager: portage-2.3.2

app-doc/casting-spels-emacs/casting-spels-emacs-19-r2.ebuild [new file with mode: 0644]

diff --git a/app-doc/casting-spels-emacs/casting-spels-emacs-19-r2.ebuild b/app-doc/casting-spels-emacs/casting-spels-emacs-19-r2.ebuild
new file mode 100644 (file)
index 0000000..9f63d93
--- /dev/null
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit elisp-common
+
+DESCRIPTION="Casting SPELs in Lisp - A Comic Book (Emacs Lisp Edition)"
+HOMEPAGE="http://www.lisperati.com/casting-spels-emacs/html/casting-spels-emacs-1.html
+       https://www.gnu.org/software/emacs/casting-spels-emacs/"
+SRC_URI="https://casting-spels-emacs.googlecode.com/files/${PN}-v${PV}.zip"
+
+LICENSE="GPL-2+ FDL-1.2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="virtual/emacs"
+DEPEND="app-arch/unzip"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+       sed -i 's/\r$//' *.txt html/*.html {lisp,test}/*.el || die
+       # needs cl extensions
+       eapply "${FILESDIR}/${P}-require-cl.patch"
+       eapply_user
+}
+
+src_install() {
+       elisp-install ${PN} lisp/*.el
+       dodoc README.txt test/walk-through-commands.el
+       docinto html
+       dodoc html/*.html
+       docinto html/images
+       dodoc images/*.jpg images/*.png
+       dosym html/images /usr/share/doc/${PF}/images
+       dosym ${SITELISP}/${PN} /usr/share/doc/${PF}/lisp
+}