dev-python/pycountry: fix tests
authorAaron Bauman <bman@gentoo.org>
Wed, 27 Nov 2019 01:47:52 +0000 (20:47 -0500)
committerAaron Bauman <bman@gentoo.org>
Wed, 27 Nov 2019 01:49:51 +0000 (20:49 -0500)
* Tests are successful on both amd64 and arm64 but pytest was leaving behind the
.pytest_cache dir causing a subsequent merge to fail.

* add the cache_dir option to pytest call so that tests are run from ${T}

Signed-off-by: Aaron Bauman <bman@gentoo.org>
dev-python/pycountry/pycountry-18.5.26.ebuild
dev-python/pycountry/pycountry-19.8.18.ebuild

index bf3621a2c76003c5e1fc531157949ea3ad6e762d..1831d0f30e7bf8011ed03936d712ed4d025157c3 100644 (file)
@@ -26,6 +26,6 @@ python_test() {
        if [[ ${EPYTHON} == pypy* ]]; then
                sed -e 's:test_locales:_&:' -i pycountry/tests/test_general.py || die
        fi
-       pytest -vv || die
+       pytest -o cache_dir="${T}" -vv || die
        popd > /dev/null || die
 }
index 99429b4ab6c961defa1514f7b05d9d0c659cb5df..4e711c93a320f72d6aa64d9b5df5a70c8cf514cb 100644 (file)
@@ -26,6 +26,6 @@ python_test() {
        if [[ ${EPYTHON} == pypy* ]]; then
                sed -e 's:test_locales:_&:' -i pycountry/tests/test_general.py || die
        fi
-       pytest -vv || die
+       pytest -o cache_dir="${T}" -vv || die
        popd > /dev/null || die
 }