DOC_DIR_SUFFIX handling was still incorrect. Should finally be fixed now.
authorWulf Krueger <philantrop@gentoo.org>
Sun, 22 Apr 2007 23:04:33 +0000 (23:04 +0000)
committerWulf Krueger <philantrop@gentoo.org>
Sun, 22 Apr 2007 23:04:33 +0000 (23:04 +0000)
eclass/kde.eclass

index 6b7eea08439c0724de1e8bbd20110be6eac477a9..4e1d91b0c9a354e391748a32a9564c7e33bf6f51 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2004 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/kde.eclass,v 1.197 2007/04/22 17:17:47 philantrop Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/kde.eclass,v 1.198 2007/04/22 23:04:33 philantrop Exp $
 #
 # Author Dan Armak <danarmak@gentoo.org>
 #
@@ -135,7 +135,7 @@ kde_src_unpack() {
                        if [[ -n ${LANGS_DOC} ]]; then
                                MAKE_DOC=$(echo $(echo "${LINGUAS} ${LANGS_DOC}" | tr ' ' '\n' | sort | uniq -d))
                                einfo "Enabling documentation for: ${MAKE_DOC}"
-                               [[ -n ${MAKE_DOC} ]] && [[ -n ${DOC_DIR_SUFFIX} ]] && MAKE_DOC="${MAKE_DOC}${DOC_DIR_SUFFIX}"
+                               [[ -n ${MAKE_DOC} ]] && [[ -n ${DOC_DIR_SUFFIX} ]] && MAKE_DOC=$(echo "${MAKE_DOC}" | tr '\n' ' ') && MAKE_DOC="${MAKE_DOC// /${DOC_DIR_SUFFIX} }"
                                sed -i -e "s:^SUBDIRS =.*:SUBDIRS = ${MAKE_DOC} ${PN}:" \
                                        "${KDE_S}/doc/Makefile.am" || die "sed for locale failed"
                                rm -f "${KDE_S}/configure"