app-portage/g-cpan: version bump to 0.17.0
authorSergiy Borodych <Sergiy.Borodych@gmail.com>
Sat, 4 Apr 2020 07:46:27 +0000 (10:46 +0300)
committerAndreas K. Hüttel <dilfridge@gentoo.org>
Fri, 10 Apr 2020 23:31:00 +0000 (02:31 +0300)
Bug: https://bugs.gentoo.org/581490
Closes: https://github.com/gentoo-perl/g-cpan/issues/26
Signed-off-by: Sergiy Borodych <Sergiy.Borodych@gmail.com>
Closes: https://github.com/gentoo/gentoo/pull/15214
Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
app-portage/g-cpan/Manifest
app-portage/g-cpan/g-cpan-0.17.0.ebuild [new file with mode: 0644]

index b27eacb0078e70d1ba17b3bab61f1ff56166fec9..137f2cdf37e266f22ad99ee21c74219fdca59c98 100644 (file)
@@ -1 +1,2 @@
 DIST g-cpan-0.16.9.tar.gz 34463 BLAKE2B 7eff6b7da75219712504ac7b9ea1833e9eaa9ba4a49f609baec6407beb16f4764baf2c35e15c779c93ca8c09bba9058e6acb6fda7f3fd2df06296724f2c3c3fc SHA512 f26d81974fedb024808fe3671ae297fd36abc37a5b04783f36f6c9e8c6000a411c675e999e91da48801a7c84fde15a59587df02fa9d7b3833ccc0916993b1783
+DIST g-cpan-0.17.0.tar.gz 38786 BLAKE2B 3f4a165920c7c075919f0eeca9554fe32bd3f72cd8010fced4d7e45aa44e80de7800fb78587d1429ac88643dd812d58725b66fbbdce305bd762db8d4ca2f0720 SHA512 80475560a00fddce31f8a92dd460bd22e0de57445a56628ad76f35ab3fc4d2f801ebd2a2a9542ed675245a994e53bb7ae842f714c35ab1f6bdbc40dd49ce2d86
diff --git a/app-portage/g-cpan/g-cpan-0.17.0.ebuild b/app-portage/g-cpan/g-cpan-0.17.0.ebuild
new file mode 100644 (file)
index 0000000..fca4209
--- /dev/null
@@ -0,0 +1,62 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit perl-module
+
+if [[ ${PV} == "9999" ]] ; then
+       EGIT_REPO_URI="https://github.com/gentoo-perl/g-cpan.git"
+       inherit git-r3
+       SRC_URI=""
+else
+       SRC_URI="https://github.com/gentoo-perl/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+fi
+
+DESCRIPTION="Autogenerate and install ebuilds for CPAN modules"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Perl/g-cpan"
+
+LICENSE="|| ( Artistic GPL-2 )"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+COMMONDEPEND="
+       dev-perl/Config-Tiny
+       virtual/perl-File-Path
+       virtual/perl-File-Spec
+       dev-perl/Log-Agent
+       virtual/perl-Memoize
+       virtual/perl-IO
+       dev-perl/Path-Tiny
+       dev-perl/Shell-EnvImporter
+       virtual/perl-Term-ANSIColor
+       >=dev-perl/YAML-0.60
+"
+RDEPEND="${COMMONDEPEND}
+       >=sys-apps/portage-2.0.0
+"
+DEPEND="${COMMONDEPEND}
+       virtual/perl-ExtUtils-MakeMaker
+       test? ( >=virtual/perl-Test-Simple-0.940.0 )
+"
+
+src_install() {
+       perl-module_src_install
+       if ! use prefix; then
+               diropts -m0775 -o portage -g portage
+       else
+               diropts -m0775
+       fi
+       dodir "/var/tmp/g-cpan"
+       dodir "/var/log/g-cpan"
+       keepdir "/var/log/g-cpan"
+}
+
+pkg_postinst() {
+       elog "If you want to use g-cpan as non root user you may wish to adjust"
+       elog "the permissions on /var/tmp/g-cpan or add users to the portage group."
+       elog "Please note that some CPAN packages need additional manual"
+       elog "parameters or tweaking, due to bugs in their build systems."
+}