dev-libs/hyperscan: Fix build for gcc9.x
authorAlexey Shvetsov <alexxy@gentoo.org>
Tue, 8 Oct 2019 11:36:14 +0000 (14:36 +0300)
committerAlexey Shvetsov <alexxy@gentoo.org>
Tue, 8 Oct 2019 14:35:20 +0000 (17:35 +0300)
Closes: https://bugs.gentoo.org/685618
Closes: https://bugs.gentoo.org/691384
Closes: https://bugs.gentoo.org/696856
Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Alexey Shvetsov <alexxy@gentoo.org>
dev-libs/hyperscan/hyperscan-5.1.1.ebuild
dev-libs/hyperscan/hyperscan-5.2.0.ebuild

index 100dba02f5a44a1faa93459423edb798623d4b06..7a0a28063f9fa11d61bbe3250003b3fe6cac02e7 100644 (file)
@@ -5,7 +5,7 @@ EAPI=6
 
 PYTHON_COMPAT=( python2_7 )
 
-inherit cmake-utils python-r1
+inherit cmake-utils python-r1 flag-o-matic
 
 DESCRIPTION="High-performance regular expression matching library"
 SRC_URI="https://github.com/01org/hyperscan/archive/v${PV}.tar.gz -> ${P}.tar.gz"
@@ -24,6 +24,12 @@ DEPEND="${RDEPEND}"
 
 REQUIRED_USE="cpu_flags_x86_ssse3 ${PYTHON_REQUIRED_USE}"
 
+src_prepare() {
+       # upstream workaround
+       append-cxxflags -Wno-redundant-move
+       cmake-utils_src_prepare
+}
+
 src_configure() {
        local mycmakeargs=(
                -DBUILD_SHARED_LIBS=$(usex static-libs OFF ON)
index 100dba02f5a44a1faa93459423edb798623d4b06..7a0a28063f9fa11d61bbe3250003b3fe6cac02e7 100644 (file)
@@ -5,7 +5,7 @@ EAPI=6
 
 PYTHON_COMPAT=( python2_7 )
 
-inherit cmake-utils python-r1
+inherit cmake-utils python-r1 flag-o-matic
 
 DESCRIPTION="High-performance regular expression matching library"
 SRC_URI="https://github.com/01org/hyperscan/archive/v${PV}.tar.gz -> ${P}.tar.gz"
@@ -24,6 +24,12 @@ DEPEND="${RDEPEND}"
 
 REQUIRED_USE="cpu_flags_x86_ssse3 ${PYTHON_REQUIRED_USE}"
 
+src_prepare() {
+       # upstream workaround
+       append-cxxflags -Wno-redundant-move
+       cmake-utils_src_prepare
+}
+
 src_configure() {
        local mycmakeargs=(
                -DBUILD_SHARED_LIBS=$(usex static-libs OFF ON)