www-servers/tornado: Replace virtuals with conditional deps
authorMichał Górny <mgorny@gentoo.org>
Mon, 16 Mar 2020 18:23:37 +0000 (19:23 +0100)
committerMichał Górny <mgorny@gentoo.org>
Mon, 16 Mar 2020 18:27:13 +0000 (19:27 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
www-servers/tornado/tornado-4.5.3.ebuild
www-servers/tornado/tornado-5.1-r1.ebuild
www-servers/tornado/tornado-6.0.3.ebuild

index 1fbfe5ab004f38404ecea3b98b15ecf8608a80b2..2daf907e25da18673b02ee3e6f5ce1264deb30df 100644 (file)
@@ -28,9 +28,11 @@ CDEPEND="
                        $(python_gen_cond_dep 'dev-python/twisted-web[${PYTHON_USEDEP}]' 'python2_7')
                )
        )
-       virtual/python-backports_abc[${PYTHON_USEDEP}]
-       virtual/python-futures[${PYTHON_USEDEP}]
-       virtual/python-singledispatch[${PYTHON_USEDEP}]
+       $(python_gen_cond_dep '
+               dev-python/backports-abc[${PYTHON_USEDEP}]
+               dev-python/futures[${PYTHON_USEDEP}]
+               dev-python/singledispatch[${PYTHON_USEDEP}]
+       ' -2)
 "
 DEPEND="
        dev-python/setuptools[${PYTHON_USEDEP}]
index 4f08262de0753f8f713ffd2c64bcbc96c306c6d0..11bf422e43d50369683d5b399c3e66549d4be60a 100644 (file)
@@ -22,9 +22,11 @@ CDEPEND="
        $(python_gen_cond_dep 'dev-python/futures[${PYTHON_USEDEP}]' 'python2_7')
        >=dev-python/pycurl-7.19.3.1[${PYTHON_USEDEP}]
        >=dev-python/twisted-16.0.0[${PYTHON_USEDEP}]
-       virtual/python-backports_abc[${PYTHON_USEDEP}]
-       virtual/python-futures[${PYTHON_USEDEP}]
-       virtual/python-singledispatch[${PYTHON_USEDEP}]
+       $(python_gen_cond_dep '
+               dev-python/backports-abc[${PYTHON_USEDEP}]
+               dev-python/futures[${PYTHON_USEDEP}]
+               dev-python/singledispatch[${PYTHON_USEDEP}]
+       ' -2)
 "
 DEPEND="
        dev-python/setuptools[${PYTHON_USEDEP}]
index 1350ccb794616f70355862e525d8dff8bc0784a5..c2f2a4a7b4ba59db4b5d3d05422842dbb7a5b2ce 100644 (file)
@@ -21,9 +21,6 @@ RESTRICT="!test? ( test )"
 CDEPEND="
        >=dev-python/pycurl-7.19.3.1[${PYTHON_USEDEP}]
        >=dev-python/twisted-16.0.0[${PYTHON_USEDEP}]
-       virtual/python-backports_abc[${PYTHON_USEDEP}]
-       virtual/python-futures[${PYTHON_USEDEP}]
-       virtual/python-singledispatch[${PYTHON_USEDEP}]
 "
 DEPEND="
        dev-python/setuptools[${PYTHON_USEDEP}]