dev-python/jinja: resurect 2.8.1
authorAlexey Shvetsov <alexxy@gentoo.org>
Tue, 11 Feb 2020 09:45:46 +0000 (12:45 +0300)
committerAlexey Shvetsov <alexxy@gentoo.org>
Tue, 11 Feb 2020 11:41:30 +0000 (14:41 +0300)
This is dep for www-apps/octoprint

Package-Manager: Portage-2.3.86, Repoman-2.3.20
Signed-off-by: Alexey Shvetsov <alexxy@gentoo.org>
dev-python/jinja/Manifest
dev-python/jinja/jinja-2.8.1.ebuild [new file with mode: 0644]

index 853323e26736736839b07dc5f92d12e7c849e919..7e4a1154e458cf155e39137226189b044ab3667d 100644 (file)
@@ -1,2 +1,3 @@
 DIST jinja-2.10.1.tar.gz 267828 BLAKE2B 0cd7e2880f1d41f3a6aafa0878343c2ff017099de6b2ad607baa3c9cba9d58c9241e1ba65cc23ea16244a1b3ea8720933f45f1061811e5f1abdcd881c4017bce SHA512 71c90be0b2aeefaa80279cba55f7827b5a42455f9dc55de9ca7e9e3e363678caa357426955267542f3c8a9b775e61aca55e439af192ed0a67f592be4ef91aff6
 DIST jinja-2.10.3.tar.gz 266316 BLAKE2B 0d8c10bb866eb887fd1c88ca5c5304f46d27930d8426587185ea72c0b79b512919bd5fa75987c26e433be049fd5764fb4ec08d42a4ec5ed00510fe8051e10f5e SHA512 566b781218b533c16b107b57e0252da5947fad262fd8d3fbb134b5916939c5e5d31c95e34bd6b14eec333d2ba3b4a6faa4168497a1ac774e7044f8220ac1b06e
+DIST jinja-2.8.1.tar.gz 397144 BLAKE2B 78e4903da05ab3e8961b6bb6047116941b4bbf59d08b8283582972590409f98b5dc1f468a988525d96c552000279fcd0a31dae3ac1e5226f609a8854c8f9ca0b SHA512 f4655f1a43c06f7651fbd5251d0538788a3a6a3ffb93d9a8c239711cf043082c43d34706b6d71a18679d957faa6590e7e0259ffb8f7cc5e3300749526417a987
diff --git a/dev-python/jinja/jinja-2.8.1.ebuild b/dev-python/jinja/jinja-2.8.1.ebuild
new file mode 100644 (file)
index 0000000..c23ba3e
--- /dev/null
@@ -0,0 +1,81 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="A full-featured template engine for Python"
+HOMEPAGE="http://jinja.pocoo.org/ https://pypi.org/project/Jinja2/"
+
+# pypi tarball is missing tests
+SRC_URI="https://github.com/pallets/jinja/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris"
+IUSE="examples test"
+RESTRICT="!test? ( test )"
+
+CDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+       !dev-python/jinja:compat"
+RDEPEND="${CDEPEND}
+       dev-python/markupsafe[${PYTHON_USEDEP}]"
+BDEPEND="${CDEPEND}"
+
+distutils_enable_sphinx docs \
+       dev-python/sphinx-issues \
+       dev-python/pallets-sphinx-themes
+distutils_enable_tests pytest
+
+# XXX: handle Babel better?
+
+wrap_opts() {
+       local mydistutilsargs=()
+
+       if [[ ${EPYTHON} == python* ]]; then
+               mydistutilargs+=( --with-debugsupport )
+       fi
+
+       "${@}"
+}
+
+src_prepare() {
+       # avoid unnecessary dep on extra sphinxcontrib modules
+       sed -i '/sphinxcontrib.log_cabinet/ d' docs/conf.py || die
+       printf "############################# SED ###############################\n"
+
+       distutils-r1_src_prepare
+}
+
+python_prepare() {
+       # async is not supported on python2
+       if ! python_is_python3; then
+               rm -f jinja2/async*.py || die "Failed to remove async from python2"
+       fi
+}
+
+python_compile() {
+       wrap_opts distutils-r1_python_compile
+}
+
+python_install_all() {
+       if use examples ; then
+               docinto examples
+               dodoc -r examples/.
+       fi
+
+       distutils-r1_python_install_all
+
+       insinto /usr/share/vim/vimfiles/syntax
+       doins ext/Vim/*
+}
+
+pkg_postinst() {
+       if ! has_version dev-python/Babel; then
+               elog "For i18n support, please emerge dev-python/Babel."
+       fi
+}