dev-util/pycharm-professional: Version bump.
authorPatrice Clement <monsieurp@gentoo.org>
Fri, 11 Sep 2015 19:35:03 +0000 (19:35 +0000)
committerPatrice Clement <monsieurp@gentoo.org>
Fri, 11 Sep 2015 19:35:40 +0000 (19:35 +0000)
dev-util/pycharm-professional/pycharm-professional-3.4.1-r1.ebuild [new file with mode: 0644]
dev-util/pycharm-professional/pycharm-professional-3.4.1.ebuild
dev-util/pycharm-professional/pycharm-professional-4.0.6-r1.ebuild [new file with mode: 0644]
dev-util/pycharm-professional/pycharm-professional-4.0.6.ebuild
dev-util/pycharm-professional/pycharm-professional-4.5.2-r1.ebuild [new file with mode: 0644]
dev-util/pycharm-professional/pycharm-professional-4.5.2.ebuild
dev-util/pycharm-professional/pycharm-professional-4.5.3-r1.ebuild [new file with mode: 0644]
dev-util/pycharm-professional/pycharm-professional-4.5.3.ebuild

diff --git a/dev-util/pycharm-professional/pycharm-professional-3.4.1-r1.ebuild b/dev-util/pycharm-professional/pycharm-professional-3.4.1-r1.ebuild
new file mode 100644 (file)
index 0000000..89beb70
--- /dev/null
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils readme.gentoo
+
+DESCRIPTION="Intelligent Python IDE with unique code assistance and analysis"
+HOMEPAGE="http://www.jetbrains.com/pycharm/"
+SRC_URI="http://download.jetbrains.com/python/${P}.tar.gz"
+
+LICENSE="PyCharm_Academic PyCharm_Classroom PyCharm PyCharm_OpenSource PyCharm_Preview"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.6
+        dev-python/pip"
+DEPEND=""
+
+RESTRICT="mirror strip"
+QA_FLAGS_IGNORED="opt/${PN}/bin/libyjpagent-linux.so
+       opt/${PN}/bin/libyjpagent-linux64.so"
+
+MY_PN=${PN/-professional/}
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_install() {
+       insinto /opt/${PN}
+       doins -r *
+
+       fperms a+x /opt/${PN}/bin/{pycharm.sh,fsnotifier{,64},inspect.sh}
+
+       dosym /opt/${PN}/bin/pycharm.sh /usr/bin/${PN}
+       newicon "bin/${MY_PN}.png" ${PN}.png
+       make_desktop_entry ${PN} "${PN}" "${PN}"
+
+       readme.gentoo_src_install
+}
index 89beb70392d8a9a01822480cb9fafea3ba042c2a..d8316d0433c79fb79a430a3b50bc130041e02998 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
@@ -10,13 +10,12 @@ DESCRIPTION="Intelligent Python IDE with unique code assistance and analysis"
 HOMEPAGE="http://www.jetbrains.com/pycharm/"
 SRC_URI="http://download.jetbrains.com/python/${P}.tar.gz"
 
-LICENSE="PyCharm_Academic PyCharm_Classroom PyCharm PyCharm_OpenSource PyCharm_Preview"
+LICENSE="Apache-2.0 BSD CDDL MIT-with-advertising"
 SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="~amd64"
 IUSE=""
 
-RDEPEND=">=virtual/jre-1.6
-        dev-python/pip"
+RDEPEND=">=virtual/jre-1.6"
 DEPEND=""
 
 RESTRICT="mirror strip"
diff --git a/dev-util/pycharm-professional/pycharm-professional-4.0.6-r1.ebuild b/dev-util/pycharm-professional/pycharm-professional-4.0.6-r1.ebuild
new file mode 100644 (file)
index 0000000..dfb1dc5
--- /dev/null
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils readme.gentoo
+
+DESCRIPTION="Intelligent Python IDE with unique code assistance and analysis"
+HOMEPAGE="http://www.jetbrains.com/pycharm/"
+SRC_URI="http://download.jetbrains.com/python/${P}.tar.gz"
+
+LICENSE="PyCharm_Academic PyCharm_Classroom PyCharm PyCharm_OpenSource PyCharm_Preview"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.6
+        dev-python/pip"
+DEPEND=""
+
+RESTRICT="mirror strip"
+QA_PREBUILT="opt/${PN}/bin/fsnotifier
+       opt/${PN}/bin/fsnotifier64
+       opt/${PN}/bin/libyjpagent-linux.so
+       opt/${PN}/bin/libyjpagent-linux64.so"
+
+MY_PN=${PN/-professional/}
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_install() {
+       insinto /opt/${PN}
+       doins -r *
+
+       fperms a+x /opt/${PN}/bin/{pycharm.sh,fsnotifier{,64},inspect.sh}
+
+       dosym /opt/${PN}/bin/pycharm.sh /usr/bin/${PN}
+       newicon "bin/${MY_PN}.png" ${PN}.png
+       make_desktop_entry ${PN} "${PN}" "${PN}"
+
+       readme.gentoo_src_install
+}
index dfb1dc5e49a844026ae6d3374aa657878474da57..d679699964cb0e68741c19c779edcb8158c43a3b 100644 (file)
@@ -10,13 +10,12 @@ DESCRIPTION="Intelligent Python IDE with unique code assistance and analysis"
 HOMEPAGE="http://www.jetbrains.com/pycharm/"
 SRC_URI="http://download.jetbrains.com/python/${P}.tar.gz"
 
-LICENSE="PyCharm_Academic PyCharm_Classroom PyCharm PyCharm_OpenSource PyCharm_Preview"
+LICENSE="Apache-2.0 BSD CDDL MIT-with-advertising"
 SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="~amd64"
 IUSE=""
 
-RDEPEND=">=virtual/jre-1.6
-        dev-python/pip"
+RDEPEND=">=virtual/jre-1.6"
 DEPEND=""
 
 RESTRICT="mirror strip"
diff --git a/dev-util/pycharm-professional/pycharm-professional-4.5.2-r1.ebuild b/dev-util/pycharm-professional/pycharm-professional-4.5.2-r1.ebuild
new file mode 100644 (file)
index 0000000..dfb1dc5
--- /dev/null
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils readme.gentoo
+
+DESCRIPTION="Intelligent Python IDE with unique code assistance and analysis"
+HOMEPAGE="http://www.jetbrains.com/pycharm/"
+SRC_URI="http://download.jetbrains.com/python/${P}.tar.gz"
+
+LICENSE="PyCharm_Academic PyCharm_Classroom PyCharm PyCharm_OpenSource PyCharm_Preview"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.6
+        dev-python/pip"
+DEPEND=""
+
+RESTRICT="mirror strip"
+QA_PREBUILT="opt/${PN}/bin/fsnotifier
+       opt/${PN}/bin/fsnotifier64
+       opt/${PN}/bin/libyjpagent-linux.so
+       opt/${PN}/bin/libyjpagent-linux64.so"
+
+MY_PN=${PN/-professional/}
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_install() {
+       insinto /opt/${PN}
+       doins -r *
+
+       fperms a+x /opt/${PN}/bin/{pycharm.sh,fsnotifier{,64},inspect.sh}
+
+       dosym /opt/${PN}/bin/pycharm.sh /usr/bin/${PN}
+       newicon "bin/${MY_PN}.png" ${PN}.png
+       make_desktop_entry ${PN} "${PN}" "${PN}"
+
+       readme.gentoo_src_install
+}
index dfb1dc5e49a844026ae6d3374aa657878474da57..d679699964cb0e68741c19c779edcb8158c43a3b 100644 (file)
@@ -10,13 +10,12 @@ DESCRIPTION="Intelligent Python IDE with unique code assistance and analysis"
 HOMEPAGE="http://www.jetbrains.com/pycharm/"
 SRC_URI="http://download.jetbrains.com/python/${P}.tar.gz"
 
-LICENSE="PyCharm_Academic PyCharm_Classroom PyCharm PyCharm_OpenSource PyCharm_Preview"
+LICENSE="Apache-2.0 BSD CDDL MIT-with-advertising"
 SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="~amd64"
 IUSE=""
 
-RDEPEND=">=virtual/jre-1.6
-        dev-python/pip"
+RDEPEND=">=virtual/jre-1.6"
 DEPEND=""
 
 RESTRICT="mirror strip"
diff --git a/dev-util/pycharm-professional/pycharm-professional-4.5.3-r1.ebuild b/dev-util/pycharm-professional/pycharm-professional-4.5.3-r1.ebuild
new file mode 100644 (file)
index 0000000..dfb1dc5
--- /dev/null
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils readme.gentoo
+
+DESCRIPTION="Intelligent Python IDE with unique code assistance and analysis"
+HOMEPAGE="http://www.jetbrains.com/pycharm/"
+SRC_URI="http://download.jetbrains.com/python/${P}.tar.gz"
+
+LICENSE="PyCharm_Academic PyCharm_Classroom PyCharm PyCharm_OpenSource PyCharm_Preview"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.6
+        dev-python/pip"
+DEPEND=""
+
+RESTRICT="mirror strip"
+QA_PREBUILT="opt/${PN}/bin/fsnotifier
+       opt/${PN}/bin/fsnotifier64
+       opt/${PN}/bin/libyjpagent-linux.so
+       opt/${PN}/bin/libyjpagent-linux64.so"
+
+MY_PN=${PN/-professional/}
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_install() {
+       insinto /opt/${PN}
+       doins -r *
+
+       fperms a+x /opt/${PN}/bin/{pycharm.sh,fsnotifier{,64},inspect.sh}
+
+       dosym /opt/${PN}/bin/pycharm.sh /usr/bin/${PN}
+       newicon "bin/${MY_PN}.png" ${PN}.png
+       make_desktop_entry ${PN} "${PN}" "${PN}"
+
+       readme.gentoo_src_install
+}
index dfb1dc5e49a844026ae6d3374aa657878474da57..d679699964cb0e68741c19c779edcb8158c43a3b 100644 (file)
@@ -10,13 +10,12 @@ DESCRIPTION="Intelligent Python IDE with unique code assistance and analysis"
 HOMEPAGE="http://www.jetbrains.com/pycharm/"
 SRC_URI="http://download.jetbrains.com/python/${P}.tar.gz"
 
-LICENSE="PyCharm_Academic PyCharm_Classroom PyCharm PyCharm_OpenSource PyCharm_Preview"
+LICENSE="Apache-2.0 BSD CDDL MIT-with-advertising"
 SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="~amd64"
 IUSE=""
 
-RDEPEND=">=virtual/jre-1.6
-        dev-python/pip"
+RDEPEND=">=virtual/jre-1.6"
 DEPEND=""
 
 RESTRICT="mirror strip"